Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Startup drivers/services/programs not always loaded

17 Feb 2017   #11
TheoStudioC

windows 7 pro x64
 
 

Yes I know. It's all done before I wrote the first post. Oke I don't think it has anything to do with it but here it is.
The machine has an Intel core i7 5960 processor, 32 GB internal memorie, 500 GB SSD HD, Matrox P690 LP PCIE x1, Matrox P690 Plus LP PCIE x16, 7TB Raid Array HD for realtime 4K video editing, MADI HDSPe AIO audiocard with MADI HDSPe FX OPTO-X expansion and a software USB interface to communicate with a Allen & Heath 48 channel mixing console with fader automation. When something is defect, bad or incompatible it should never run well or run well for a long time. It does run well when everting is loaded even for days. I said before I can live with it. It's only so annoying.


My System SpecsSystem Spec
.
17 Feb 2017   #12
johnhoh

Win7 pro x64
 
 

The reason your icons don't always appear in the same order is that they appear only once they are "ready" and they are ready at a different moment each boot because your hard drive changes (e.g. pagefile.sys gets changed) with each boot. I would try disabling your paging file, and/or moving it to a different drive.

How to Disable or Move the Windows Page File

If your boot drive is pretty fragmented that can also cause slight changes to the order at which programs/drivers are accessed and loaded. Try defraggler.

Defraggler - Builds

If that does not work for you, check into Startup Delayer and Winpatrol, both of which give you better startup control

Startup Delayer - Freeware download and reviews from SnapFiles

WinPatrol (Free Edition) - Freeware download and reviews from SnapFiles
My System SpecsSystem Spec
21 Feb 2017   #13
TheoStudioC

windows 7 pro x64
 
 

Okay. Installed a 80GB HD (was lying in a drawbar, somewhere) only used for the pagefile. No difference.
Switched of the pagefile also no difference.
MeOnMine is talking about slowing down the boot process. I can't find any option for that.
My System SpecsSystem Spec
.

21 Feb 2017   #14
Callender

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

You can possibly delay loading of some third party software startup entries that you have added.
Startup drivers/services/programs not always loaded-delay.jpg
RE: System tray icons.

Reset them using this tutorial which also clears out old items.

Notification Area Icons - Reset

You would need to select order of icons to be displayed after running the script and rebooting.

Order depends upon whether you choose to "always display all icons" after making your choices.

Would also suggest running a full disk check when you have finished using your computer. A reboot is needed,

Run this command:
Startup drivers/services/programs not always loaded-run-command.jpg
You will find a lot of discussion in this forum on services management. Personally I disable services that I don't need. Some other services are set to manual start instead of automatic.

Anyway take a look at:

Start> Run then type msconfig and press enter.

On the services tab hide all microsoft services and see what's left. Work out if you can safely disable any or set to delayed start or if not required to be running on boot set to manual start.


My System SpecsSystem Spec
13 Mar 2017   #15
TheoStudioC

windows 7 pro x64
 
 

I figured it out. It has to do with the order of installing the hardware.
Start with a basic machine, no additional hardware installed.
Install windows 7.
Switch off.
Put in first piece off hardware.
Start up.
Install the software of the new hardware.
Switch off.
Install second piece of hardware.
Start up.
Install software of the new hardware.
Switch off.
Repeat until all hard- and software is installed.

Order of insallation:
1) Matrox P690 Plus
2) Matrox P690 LP
3) MADI HDSPe AIO
4) MADI HDSPe FX Opto
5) Install Fader Automation software
6) Set Up RaidArray

When I change someting in the installation order things go wrong right away or after a while.
If so I have to strip the machine and start all over again.
But ..... when it's running its running.
My System SpecsSystem Spec
Reply

 Startup drivers/services/programs not always loaded




Thread Tools




Similar help and support threads
Thread Forum
Can't access via RDP programs that was loaded on start
Hello! I have a remote PC with a server application, which is started automatically on system boot like this:...
Network & Sharing
Startup And Computer Slowed After Instaling Drivers,Programs,.Dlls etc
Hi all,i recently had an 0xc000007b error with a headset software.I tried everything on the internet to solve problem including uninstalling and installing .net framework, visual c++ (all versions), some .dll s both in system32 and syswow64,reinstalling drivers and some other things that i cannot...
Performance & Maintenance
all DLL's are being loaded for every application on startup
this problem started happening after I had run WMI.bat( that was in tutorial to fix system restore not working) System restore now works, but now every time I restart system the following happens, Event 11, Wininit Custom Dynamic Link Libraries are being loaded for every application see...
Software
Programs Only Open In Safemode, Less Processes Loaded On Startup
After having scoured the internet for help, not really gotten anywhere, and feeling reinstalling windows might be my only option, I'm going to leave this here before I fall asleep and see if anyone can shed some light on this. I guess I should start from the start? Earlier I'd finished watching...
General Discussion
Startup programs & services per user
Hi again, please does anyone know if there is a way to configure startup programs like in msconfig on a per user basis? A friend of mine has a laptop that is capable of running the game that he wishes to play but not with all the Acer rubbish & so many windows services running. I proved that to...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:26.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App