Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Cannot change registry permissions

05 Feb 2017   #1
Mike99

Windows 7 Ultimate x64
 
 
Cannot change registry permissions

I’m trying to delete the Display key in the registry as outlined here.
HowTo Switch monitor 1 Monitor 2 Identity | Overclockers Forums

I followed all the steps to change permissions & ran RegEdit as Administrator but had no success.

When I go to Advanced > Owner and select “Replace owner on subcontainers and objects” & click Apply, I get the following message:
““Registry Editor could not could not set owner on the key currently selected, or some of its subkeys.”

I click OK and proceed.

When I get to Advanced > Permissions and select “Replace all child object permissions with inheritable permissions from the object” & click Apply, I get the same message.

When I’m all done with trying to change permissions, I go back and right click on a key & try to delete it I get “Cannot delete DISPLAY: Error while deleting key.”. Which is what I got before I tried to change permissions.

I tried to delete just a single monitor and was successful so I figured that was the way to do it. But so far have not been able to duplicate that even though I tried many times. So I’m back to going nowhere.

Any suggestions on what I’m doing wrong?


My System SpecsSystem Spec
.
05 Feb 2017   #2
Callender

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Okay I'm no expert on permissions. If I ever need to change permissions on anything I make sure that original permissions can be restored. Maybe take a look at the software mentioned here:

Can't modify registry key even after changing permissions

However if you've already screwed up permissions then I can't tell you how to fix.

Pyprohly seems to know a lot about permissions so maybe try asking.
My System SpecsSystem Spec
07 Feb 2017   #3
Mike99

Windows 7 Ultimate x64
 
 

I downloaded RegOwnershipEx & unzipped it but could not run it because there was no exe file. Turns out Norton removed it & said it was not safe. I can turn off Norton but figured I'd better ask first. Is that Winaero.com website the proper place to download the software from?

Also, I sent Pyprohly a PM and hopefully he'll respond.
My System SpecsSystem Spec
.

07 Feb 2017   #4
Callender

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

It's safe. See VirusTotal report:

Antivirus scan for b5e6dfce52951e328d72a139e1ff7579ff6461c56d3bf739821dc0fee76454c6 at
2017-01-11 15:26:24 UTC - VirusTotal

Cannot change registry permissions-file-information.jpg
Cannot change registry permissions-voodooshield-scan.jpg
Cannot change registry permissions-vt-file-information.jpg
Obviously it can make changes to your system that could screw it up if you use it incorrectly. That's why Norton doesn't like it. It's not spyware and does not steal your data. It does connect to the internet to send usage statistics just like many other programs. You can block connection and it will still work.

You need to use the correct download link. From memory the links on the site for downloads can be misleading.

Here's the correct place to download it from:

Downloads / Software / RegOwnershipEx
Cannot change registry permissions-downloads-_-software-_-regownershipex-opera.jpg


My System SpecsSystem Spec
Reply

 Cannot change registry permissions




Thread Tools




Similar help and support threads
Thread Forum
Need help with permissions change in registry
Trying to remove all of Acronis True Image 2011...used Revo, Acronis cleanup utility, and manual search of registry. It's recommended that before installing ATIH2013...I should clean as much as I can of ATIH2011 from my PC. Have removed scores of Acronis entries...but I have three left I...
Backup and Restore
Registry Permissions help
Hi.. i've recently installed a customized version of Windows 7 SP1. I removed some languages, added some programs, drivers, settings and a unattended script. It installed without issue and everything has been running fine. However, i've just noticed a potential major issue waiting to happen....
System Security
How do I get Registry permissions?
Using Win 7 Pro x64. Even though I am listed as an Owner in all of the Registry keys, I do not have permissions in all of those same keys. I have Admin rights. This is causing problems installing software. Most recently, I can't install Ghost 15. The install almost completes and then I get...
General Discussion
Registry Permissions HELP!!!
Ok I really don't understand this!! Why is it that subinacl.exe works on my version of Win 7 Home Premium and yet not on other people's Win 7 Home Premium?? Also, the files that I downloaded from this site to set the uac levels work fine on my machine (OS) but open something totally different on...
System Security
Registry Permissions
I'm Administrator in my PC, but when i try to give me permission of a key in the registry, it appears an error message. It doesn't happen with any other key.Any ideas? Thz^^
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 06:29.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App