Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Hard Drive Response Delays - Windows Explorer hanging

26 Mar 2017   #1
rcanino

Win7 Pro 64-bit sp1
 
 
Hard Drive Response Delays - Windows Explorer hanging

Hi folks -

Win7 Pro 64-bit / MSI Big Bang XPower X58 / 2 SSDs + 5 HDDs (1 is external USB) / HX850 PSU

The HDDs on the SATA II ports don't always respond immediately when I click on a directory or a file. It takes anywhere from a few seconds to ~20 secs. and then everything is fine. A few times (over 6 years) the system hangs indefinitely and I've been forced to reboot.

SSDs (SATA III ports) are unaffected; the external HDD is fine.
Problem HDDs are both on SATA II ports - two are WD Black, two are Samsung HJ 103SJ.

The trouble was always with just one HDD so I replaced it but it's still happening. Lately the problem seems to be spreading: my 2-month old WD Black FZ5001FZWX is the worst offender.

I don't defrag on a regular basis but I don't ignore it altogether. These delays are beyond a defrag issue; they're clearly caused by Windows Explorer hanging.

I configured new a power plan where everything is set to "never" turn off and that didn't help. It doesn't appear to be a hardware issue, unless the SATA II ports are slowly dying (though I've never heard of that happening).

I'm pretty much convinced it's a Windows Explorer problem - that is the service that hangs - but I haven't a clue how to address it.

Well...thanks for any thoughts / ideas you care to share. And thanks for a great website!

-Richard


My System SpecsSystem Spec
.
26 Mar 2017   #2
samuria

win 8 32 bit
 
 

Are the drives sata3 running on sata2 ports? its normal on first run as windows has to read all the disk content if you do it again it will have cached data so should be quicker
My System SpecsSystem Spec
26 Mar 2017   #3
rcanino

Win7 Pro 64-bit sp1
 
 

thanks for your reply samuria -

Good thought, only this happens randomly and fairly often - I don't think loading the cache explains it. If it happened just once at the start of the day then maybe but this happens all the time. Not every time but often.

Seems to me something is causing Windows Explorer to hang.
My System SpecsSystem Spec
.

26 Mar 2017   #4
samuria

win 8 32 bit
 
 

Its a lot of info so any cache is short lived you didnt answer are they sata3 running on sata2 that wouldnt help some need a jumper to reduce speed
My System SpecsSystem Spec
01 Apr 2017   #5
rcanino

Win7 Pro 64-bit sp1
 
 

thanks S - sorry i've been away for a few days -

the drives are SATA III capable - if that's what you're asking me - and they're running on SATA II ports, yes. I've never seen delays like this when running the exact same setup, i.e. SATA3 drives on SATA2 ports.

AFAIK you only notice slow downs with SATA3 SSD drives on SATA2 ports - mechanical drives like the ones I'm talking about are too slow to saturate even the SATA2 bus lets alone SATA3.

very strange behavior - it happens so randomly - I highly doubt it's cache-related.

Anyway thanks again for your replies - I appreciate it!
My System SpecsSystem Spec
01 Apr 2017   #6
GEWB

Linux (Mint is primary) / XP, Win7 Home / Win7 Pro, Ultimate / Win8.1 / Win10 archived VM
 
 

Some drives go into a power saving type of sleep mode after a period of inactivity - they take a few seconds to wake and spin up when accessed in that mode. I have several spinning disks that behave just like that.

That's not to say it couldn't be a Windows related issue.

Try using a live Linux DVD to access your drives and see is the problem remains.

Regards,
GEWB
My System SpecsSystem Spec
01 Apr 2017   #7
rcanino

Win7 Pro 64-bit sp1
 
 

Quote   Quote: Originally Posted by GEWB View Post

Try using a live Linux DVD to access your drives and see is the problem remains.
Interesting. I have zero experience with Linux but I can't imagine how using a different OS will evaluate a hard disk(s).

Quote   Quote: Originally Posted by GEWB View Post
Some drives go into a power saving type of sleep mode after a period of inactivity - they take a few seconds to wake and spin up when accessed in that mode. I have several spinning disks that behave just like that.
GEWB
this is certainly how it appears - as if the disks are sleeping. In fact I can duplicate the problem by using a power scheme that puts the disks to sleep after x-minutes. After x-minutes the symptoms are similar, except for the randomly-occurring part.

I've begun to wonder whether the High Performance scheme (or the HP scheme I configured, which is nearly the same as the stock HP scheme) is actually being implemented.

I ran a powercfg /energy command for 2 minutes and found nothing unexpected. Don't know what's going on but I'm sure these WD Caviar Black drives shouldn't automatically sleep. If it was "a few seconds" before they awoke I wouldn't be concerned but 5, 10 even 20 seconds surely isn't normal.

Well thanks for your reply G, I appreciate your help!
My System SpecsSystem Spec
02 Apr 2017   #8
GEWB

Linux (Mint is primary) / XP, Win7 Home / Win7 Pro, Ultimate / Win8.1 / Win10 archived VM
 
 

You posted "I can't imagine how using a different OS will evaluate a hard disk(s)" - that is to work on eliminating the Windows OS as a cause rather than test the HDs. If under Linux the condition improves then I would start looking into Windows as a contributing factor.

Regards,
GEWB
My System SpecsSystem Spec
02 Apr 2017   #9
rcanino

Win7 Pro 64-bit sp1
 
 

Ah - of course - thanks for the explanation. I think I will look into that idea GWEB - thanks again!
My System SpecsSystem Spec
Reply

 Hard Drive Response Delays - Windows Explorer hanging




Thread Tools




Similar help and support threads
Thread Forum
Very slow response in Windows Explorer
In drive S:\ I have a number of folders and subfolders. One of the subfolders holds about 20 image files, each about 35MB. When I point Windows Explorer to that folder it takes about 30 sec. for the results to be displayed. Meanwhile a green progress bar slowly creeps along the address window....
Performance & Maintenance
Windows 7 Explorer Hanging Up
Hello Forum! I am experiencing a problem with windows 7 Explorer. After being logged in for short time (1/2 hour or less) I select a folder / application on my desktop and Windows (Explorer) will just sit & spin (the ‘thinking’ circular icon) until I either select another function, or try to...
Software
Can't see hard drive or DVD drive in Computer or Windows Explorer
I reinstalled Windows 7 and everything went well. I can access the internal drive and the DVD drive through Open on Disk Management and a shortcut for the hard drive on the desktop that I created after the install but can't see the hard drive or the DVD drive in Computer or Windows Explorer. I...
Hardware & Devices
External hard drive not showing up in Windows Explorer
I am having a strange problem with my external hard drive for my backups. When I plug the drive in, it does not show up in Windows Explorer. I can make it show up by going into disk management and assigning it a drive letter, but the next time I plug it in, I have the same problem again. Any ideas...
Hardware & Devices
Windows explorer crashing on cloned hard drive
I have bought laptop with ore installed windows 7 premium 64 bit. It came with a 320 gig hard drive. I have upgraded to a 1 tb and using seagate disk wizard I cloned the 320 hd to the 1 tb. But ever since then the 1 tb hard drive boots fine to windows but the explorer keeps crashing and restarting...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:25.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App