Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Cannot Delete Pevious Owner/Administrator Due To File Open In Another

05 Apr 2017   #1
CAG43

Windows 7 Professional 64-bit SP1
 
 
Cannot Delete Pevious Owner/Administrator Due To File Open In Another

For several weeks now I have been trying various methods in trying to delete the former owner/administrator that came with my HP8460p Win Pro 7 64 bit laptop computer.

I followed the tutorial in Security and would like to know if I might have chosen the incorrect options somewhere along the way.
FYI - my account is CAG and the account that came with the computer is hp.
You may have seen my posts on this before.

This is what happened:

I went to Users/Properties/Securities.
The options to check were,
1. Everyone, 2. System, 3.Administrators (CAG-NB) Administrators and 4. Users (CAG-NB -Users).
I selected option, 3.

That brought me to "Change Permissions" where I clicked on, "Edit."
I checked all but one option which were, 1. Read and Execute, 2. List Folder Contacts, 3. Read/Write, 4. Special Permissions.
Number 4, Special Permissions would not let me check it.

So, I next went on to Advanced where it said I must be an administrator user with permission to view the object's security properties.
I clicked and filled in "Change Owner" to CAG (CAG-NB(CAG).

The other choice was Administrators (CAG-NB)/Administrators.
Then I clicked on, Replace all child objects permissions with inheritable permissions from this object.

The last two options were either to replace or include all inheritable permissions from this object's [aren't.

I tried both options and was given the message that an error occurred and I don't have permission because the file is running in another program.

The other program, I am guessing, is the original owner/administrator, hp, which I have been trying to delete.

Can someone tell me if I missed something by checking the wrong option along the way?
This has really got me stumped and I would like to know if it something I did or did not do.

All thought would be very welcome!

CAG43


My System SpecsSystem Spec
.
10 Apr 2017   #2
marsmimar

Microsoft Community Contributor Award Recipient

 
 

Please forgive me if I've misunderstood your question. In your title you indicate "Cannot Delete ... File Open In Another." I'm guessing you're saying the file is locked because it's open or in use by another program or user. If that's the case you might be able to use this free tool from Malwarebytes.

Malwarebytes | FileASSASSIN - Free Software to Delete Locked Files

Again, if I misunderstood your question I sincerely apologize.
My System SpecsSystem Spec
10 Apr 2017   #3
jacky99

Windows 7 Ult x64
 
 

@CAG43, to change the permissions level of Admin/User is so easy. Here is a simple way after click the Users/Properties/Securities > click Advanced > Change Permissions at the bottom (don't touch any button on above) > and select User/Admin you preferred, then click Edit button. Now you can change what you like to Allow or Deny > then OK, Apply, OK all to close.
My System SpecsSystem Spec
.

27 Apr 2017   #4
pramardhika

Windows 7 Ultimate x64
 
 

Hi CAG43!

IMO, you cannot delete it because there is a running program in your "HP" user account and the account itself is not yet logged off.
Or
Your account "CAG" has no permission as administrator to manage another account. To check this, click windows logo in bottom left corner of desktop and type "user account" in search bar. Is your CAG profile has Administrator status already? If it's not, then you have to change it as administrator.
My System SpecsSystem Spec
Reply

 Cannot Delete Pevious Owner/Administrator Due To File Open In Another




Thread Tools




Similar help and support threads
Thread Forum
Trouble removing former owner/administrator of refurbished HP8460p Win
I recently purchased two HP8460p 64 bit Win Pro refurbished laptop computers and tried to change the owner/administrator from hp to my own name but could not delete the hp account. When I click on delete, the hp temporarily disappears but when I reboot, it comes back. All my programs are in my...
General Discussion
Can't delete a file requiring Administrator's permission when I am adm
I'm trying to get rid of the Windows 10 upgrade nag. I removed the offending Windows update but I'm still getting the nag. Another website suggested renaming Windows\System32\GWX\GWXUX.exe. I changed ownership of System32 and subdirectories from Trusted Installer to Administrators. I'm logged...
Windows Updates & Activation
New owner but cannot remove previous owner as administrator
I recently bought an Acer AX3810 with Vista 7 Home Premium 64 bit from the widow of my neighbor. I had transferred all his personal files and copied all the photographs to an external hard drive for her then deleted all the files using "Eraser". I cannot seem to be able to delete the previous...
General Discussion
I need admin permission to delete/move file (but I'm both admin/owner)
Hi, I'm new to Windows 7. I'm still trying to master the file permissions.. I need some help and I'd appreciate it if someone could help me out. I have a folder with mp3s (created with my old Windows XP system). I've included this mp3s folder in the "my music" library and then I inspected...
System Security
Welcome screen shows Administrator and Owner icons (options)
How do I permanently show only one "Owner/User"? - the Welcome screen (and after hibernation/sleep) always shows Admin + Owner - as the only user + administrator ... the options are pointless for me - I would like to skip the Welcome user options all together. I have had days of problems...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:34.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App