Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: What is icon with "$" sign that comes up temporarily during startup

05 May 2017   #1
blacksky200

Windows 7 Professional 64 bit
 
 
What is icon with "$" sign that comes up temporarily during startup

I am currently trying to figure out why some of the times my laptop takes ~20 mins to boot up, when I start my laptop (generally after a gap of a few hours). Other times or after a restart it is fine.

Question here is though about an icon that appear in the taskbar when the windows starts up and starts all the services. The icon appears for a bit and disappears and clicking on it did nothing (as far as I could tell).




Now, it could be something malicious or it could be a normal process that temporarily starts up and I am only seeing it because every process was very slow. So slow that I even saw a status of Windows "playing logging off sound" when i tried to shut the computer down.

Any help on the app with "$" sign would be helpful


My System SpecsSystem Spec
.
05 May 2017   #2
Barman58

Windows 10 Pro x64 x2 Windows 10 Enterprise x64, Ubuntu
 
 

Hold down the Windows Key and Tap the "R" key

In the box that appears type "msconfig.exe" (no Quotes)

The MSConfig Applet will start - on the start-up tab you should see a list of all the programs that start automatically, (actually most not all due to some technical items being started by alternate means), investigate these items, Use google or upload a screenshot of the app here and we'll see what we can advise, and disable those you do not "need" - Think to yourself " do I really want to start "X program" every time to save the 10 seconds it takes to manually open it.

Have a look for anything that may be producing the $ icon especially If we cannot tie this down we can move this thread to our security section and let the pros have a go at solving any possible malware infection
My System SpecsSystem Spec
05 May 2017   #3
blacksky200

Windows 7 Professional 64 bit
 
 

Hey Barman58

Thanks mate. Hope this tells something:
My System SpecsSystem Spec
.

05 May 2017   #4
Barman58

Windows 10 Pro x64 x2 Windows 10 Enterprise x64, Ubuntu
 
 

That looks to be about 20% of the complete list, (based on the size of the scroll bar), and I can see multiple anti-malware programs, although you may assume that more is better this does not often if anytime apply with anti-malware, it possible that one AM will scan another's files which is in the process of scanning the first AM's files and by the time that loop ends a long time has passed without any productive outcome.

Take a look at the system security section here and you will see a few ideas of the most efficient way to set-up your anti-malware protection, and I have to say it does not often include McAfee products

With the other items keep just the essentials - Eg Adobe Reader running all the time will use a number of resources and save very little time for anyone who is not using PDF files most of the day, especially these days where most of the internet browsers have built in support for PDF.

Not sure what if anything is actually active on the other pages that are not shown - but what I can see it does look a lot like the start-up overload that is normal with OEM laptop installs - It is "fondly" known in the industry and the enthusiasts as Bloatware and causes a lot of systems to underperform significantly to what they should do
My System SpecsSystem Spec
05 May 2017   #5
blacksky200

Windows 7 Professional 64 bit
 
 

Hey

Sorry should have said...... The image was put together on Paint to show all the processes as I couldn't resize the window to show them all. Hence the scroll bar still appears despite showing the full list.

- I am in the process of unticking all the unnecessary programs, so that will help to speed up the loading.
- The McAfee and Malwarebytes combination is enforced by the powers that be at our company and seem to be working without issues for most people.

Thanks for the advice on these.

Any idea on what application brought up the "$" taskbar icon in the OP?
My System SpecsSystem Spec
05 May 2017   #6
Barman58

Windows 10 Pro x64 x2 Windows 10 Enterprise x64, Ubuntu
 
 

I cannot see anything specific to produce the "$", except you have three entries there for NCP... startup items one of which also included Budget in the title NcpbudgetGui that is one I would not be surprised to be the culprit
My System SpecsSystem Spec
05 May 2017   #7
blacksky200

Windows 7 Professional 64 bit
 
 

Good spot.

Turns out it is one of the processes that is run by our VPN client (WatchGuard Mobile VPN).



It obviously has been running every time system is started, but only noticeable now as the system is sooooo slow ... so slow that...
Quote   Quote: Originally Posted by blacksky200 View Post
.....that I even saw a status of Windows "playing logging off sound" when i tried to shut the computer down.

Thanks for looking into this @Barman58
My System SpecsSystem Spec
Reply

 What is icon with "$" sign that comes up temporarily during startup




Thread Tools




Similar help and support threads
Thread Forum
Windows 7 stuck on "Welcome" screen - system restore fixes temporarily
As in title. I have an issue where the PC boots up fine, then after I log on the PC hangs up on the loading screen. I system restored from safe mode, and the issue was fixed. Two days later, the issue recurred. Again system restore fixed the problem. Any ideas how to fix it permanently? I did not...
General Discussion
When opening a tab ion IE8, and it temporarily says, "connecting"...
....what is it connecting to? I have about:blank set as my homepage, so the browser is not trying to connect to a site...so what does "connecting" mean? Thanks!
Browsers & Mail
set "My Documents" env var temporarily for a certain GUI program?
Ok, I know, I can change/set environment variables through Control Panel--->System The current environment variable values are fine for most of my programs. However there is one program which puts some config files into the folder which is currently defined as user variable "My...
General Discussion
Shield sign on icon(s) (not the "usual" problem)
Hi, I have searched the forum, but I just found the "usual" asks - and solutions for it - in this issue and not the right for me. My problem is; a few weeks ago on many of my icons on the taskbar (that earlier I have pre-configured to "Run as Administrator") suddenly appeared that blue-yellow...
General Discussion
"Frequent" and "attached" disappear from Explorer Icon
Hello, I got this problem today. Normally when right clicking on the "explorer" icon it shows shortcuts of folders that I added as well as frequently visited folders. But now it shows nothing but two options: "Windows explorer" and "detach the program". I tried to move new folders in but...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:34.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App