Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: MS Hazel TTS voice install, not working properly

08 May 2017   #1
Gtrshop

Win 7 Ultimate 64bit
 
 
MS Hazel TTS voice install, not working properly

I am trying to get something other than MS Anna working for Text to Speech.
I have installed the Speech server 11 from Microsoft and the required voice packs (Hazel and ZiraPro).

After editing the registry (something I had to search for information on..it wasn't included with the MS install), I can now see the voice packs in Control Panel, and they read the text in the test box.

I have an application that gives me real time voice feedback. It cannot seem to use the Hazel or ZiraPro voice pack, despite being correctly set up in control panel, and even correctly selected within the program.

I'd like to get this working correctly. MS Anna is far too choppy to listen to.


My System SpecsSystem Spec
.
08 May 2017   #2
Gtrshop

Win 7 Ultimate 64bit
 
 

OK, I have managed to get MS Hazel working, so I'm posting this for the benefit of anyone else who might have trouble. I can't make and guarantees this wont crash your system as its a REGISTRY MODIFICATION...so do so at your own peril

The initial tutorial (do a google search for installing tts voices, the link is on SuperUser) indicates to make some modifications after downloading and installing the required files. Do all those things first.

Next...

GO back a level or two and export the Voices folder. This will grab values for ANNA also. You have to be able to see ANNA and whatever other voice packs in the TOKENS folder. Since the ANNA files are referenced from this location, you have to see the added voices packs here also.

The important part:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Speech\Voices\Tokens\MS-Anna-1033-20-DSK\Attributes]
"Age"="Adult"
"AudioFormats"="18"
"Gender"="Female"
"Language"="409"
"Name"="Microsoft Anna"
"Vendor"="Microsoft"
"Version"="2.0"

Hazel's language is 809 by default. Change it to whatever ANNA is set to...409... and change the Version number to 2.0, instead of 11.0.
See my registry entry below:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Speech\Voices\Tokens\TTS_MS_en-GB_Hazel_11.0\Attributes]
@=""
"Age"="Adult"
"AudioFormats"="18"
"Gender"="Female"
"Language"="409"
"Name"="Microsoft Hazel"
"Vendor"="Microsoft"
"Version"="2.0"


I also changed the "name" to Microsoft Hazel, instead of whatever was there... I doubt that had any effect, I believe that changing the VERSION was the key.

I did the same thing with ZiraPro, but have not tested it..since getting Hazel to work was my goal.

I hope this helps someone else.

Steve
My System SpecsSystem Spec
Reply

 MS Hazel TTS voice install, not working properly




Thread Tools




Similar help and support threads
Thread Forum
Mic is not working properly
I checked my mic using Microphone Test - Test Your Mic With Our Online Tool and it shows variation in line. But others are unable to hear my sound my device manager shows this View image: Capture1 I have run m"setup a microphone " and its fine. but in sound recorder the resultant audio...
Hardware & Devices
usbport.sys not working properly(?)
Hi! Recently I experienced that my cursor randomly stops for about half a second, and in some cases, the scroll wheel completely stops working (I have to restart the computer). Also, I ran the xperf command, and I found out that sometimes usbport.sys causes some pretty high DPC latency spikes....
General Discussion
CD Rom not working properly
I am running windows 7 and my cd rom is not working properly. It was reinstalled which seemed to help a LITTLE, but sometimes you have to incert a cd 7 or eight times before it will read it. I can see that there is a cd inserted (when I go to my computer I can see the D drive). Just doesn't read...
Hardware & Devices
Voice audio is dim after Mic install, other sounds are normal
Hi, I have a strange problem: I recently used a plug-and play microphone, and now my speaker volume for voice audio is extremely low. Even on random youtube videos I can hear the background music but the voices are only faint. I did not know such a thing was possible. The background music...
Sound & Audio
Fifa 08/09/10 working properly?
In Vista 64bit, the Fifa games I played (so 08 and 09) played fine in the actual game, but the menu's were very very slow. I mean like really slow, they responded very slowly and I had to click several times untill something happened. It was very annoying. I have tried everything in Vista 64bit to...
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:59.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App