Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Taking 'ownership' questions.

21 May 2017   #11
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

If you desire to run check disk this tutorial by Brink will give you guidance.

Disk Check - Windows 7 Help Forums


My System SpecsSystem Spec
22 May 2017   #12

Windows 10 Pro x64 x3, Ubuntu

Ok lets try this ...

Open a CMD window as Admin (Find the CMD shortcut in the start menu right click run as Administrator)
In the CMD window type CHKDSK [Drive Letter]: /f (note the lack of /r) and enter
Make a large coffee, (other non alcoholic drinks are acceptable), and wait until it completes.

Repeat this for each other Drive letter you have on your system.

If there are errors presented but the command is completed ( ie it runs OK and lists some problem files (You may see the occasional error on the system drive where system folders are locked this is expected)) - Now you can run the more aggressive "CHKDSK [Drive Letter]: /f /r " on each drive (/r checks for and attempts repair of bad sectors, it will mark any that cannot be used as such and prevent disk failures in future.

This procedure should check the drive and then if any file structure errors are present the second run should fix them, also be aware that this cannot work on a drive in use so it will ask to schedule a run on reboot - accept this and let it reboot to run.

I would also run the SFC /scannow in an admin CMD window as I suggested earlier

If all else fails you could take ownership of any Data folders (or trees) on your system drive, (the Users folder and folders under it can actually be owned by the main user without serious issues, but do not do anything with things like the Windows folder, the program files folder(s) or other non data folders
My System SpecsSystem Spec
22 May 2017   #13

Win 7 64 bit
Taking 'Ownership' questions

Yes, I've already done the chkdsk thing...but I just did it again...using both methods...via DOS, and the right-click on the drive, properties, tools, check now(unclick both boxes)...all drives came back with 'no problems'.
I'm currently running a SFC /scannow....seems to be stuck at 85%. Does this scan just my 'C' drive, or all the drives in my PC?(besides my main 'C', I have 3 internal data drives, and 4 external drives). If it's scanning all the drives, it could take awhile. Will post back later after something happens.
My System SpecsSystem Spec

22 May 2017   #14

Windows 10 Pro x64 x3, Ubuntu

SFC stands for System File Checker so it should only ever Access the system drive, It is designed to check that all system files in the OS are compatible with each other and will take the correct ones from either the internal OS store or from the net if needed.

These files may be changed by program installers that must have of a system file, so it loads and registers this file, unfortunately this may be an older version than is required by the OS and other applications so can cause issues. SFC uses various techniques including symbolic links, to give each program access to the file it needs

Due to this way of working it can sometimes take a little while, or perhaps long while is more appropriate
My System SpecsSystem Spec
22 May 2017   #15

Win 7 64 bit
Taking 'Ownership' questions

Latest findings:ran chkdsk on my 3 'C' drives(one is my main 'C', one is an old HD, one is an old SSD drive),
all finished OK. Did a sfc /scannow on all three 'C' drives, all ran OK.

As per the Trend tech, I changed the ownership of my old HD to Administrators(Tod-PC\Administrators), and ran the chkdsk and sfc again...both ran OK.

Then Trend hung at 26% scanning my old HD(E) drive.

Emailed this to the Trend tech...waiting for a response.

Thanks everyone for all your help...will post back when I have more info.
My System SpecsSystem Spec
22 May 2017   #16

Win 7 64 bit
Taking 'Ownership' questions

Latest news:The Trend tech wanted to know exactly what file Trend was hanging on...I told him, along with the fact that when I scanned just that file, Trend ran OK.

Then I ran a scan using right-click on the drive(instead of using the Trend interface), and it hung.

Then I ran a scan on just the file it hung on, and it ran OK.

So, I asked the Trend tech why does Trend hang when running scans on whole drive, but works OK when scanning individual files. Waiting for response....
My System SpecsSystem Spec
22 May 2017   #17

Windows 10 Pro 64 bit
account permissions

Hello tkmops, I only run the scans from the Trend Console, and it does only take a couple of minutes to

scan the whole drive. I run a quick scan each day, and a full scan once a week. I received an email from

Trend Micro last week to download the free upgrade due to the WannaCry business. I have downloaded it,

and it uninstalls your current version and installs the new version, but your tech has probably already told

you about it.
My System SpecsSystem Spec
22 May 2017   #18

Win 7 64 bit
Taking 'Ownership' questions

Yes, I have the latest update. Not sure if this is related or not, but WMP is not working again. I've tried to change the owner of my old PC 'C'(E) drive back to 'TrustedInstaller', it comes up with 'name cannot be found'. How can I change this back?
My System SpecsSystem Spec
22 May 2017   #19

Win 7 64 bit

I googled how to do this and was able to use NT SERVICE\TrustedInstaller to put my E drive back to TrustedInstaller owner. WMP still won't work, maybe it will take a reboot? Will post back later...
My System SpecsSystem Spec
24 May 2017   #20

Win 7 64 bit
taking ownership?

After many hours of un-installing/installing, research, this is what happened:

1) I uninstalled Trend
2) uninstalled Mal-Ware Bytes...I didn't know I had this, as there was no desktop, or task bar icon.
3) Noticed that 'TrustedInstaller' was 'stopped' in task manager/services, at first, I got 'unable to start service', but after a few trys, it started.
4) Re-installed Trend, and a 'C' scan to completion(first time in 5 weeks)
5) Re-installed Mal-Ware Bytes, ran a 'C' scan OK
6) Ran another Trend 'C' hung.

So, it seems that Trend work fine by itself, but hangs when Mal-Ware Bytes is running.

7) Un-installed both Trend and Mal-Ware Bytes
8) Installed Mal-Ware Bytes first this time, then...
9) Installed Trend.
10) Ran a Trend 'C' scan, it hung.

Not sure why this is happening now, as I've had Trend and Mal-Ware Bytes(unknown to me) running for years. Maybe one of the Trend updates has made it impossible to work with
Mal-Ware Bytes?

So, after all this, I have just Mal-Ware Bytes running. I have about 6 months left on my Trend subscription, but it's only about $ no big deal.

My two questions now are:should I have 'TrustedInstaller' stopped, or running in Task Manager\services? And, is just having Mal-Ware Bytes(Premium 3.1.2) going to be sufficient protection?

(Latest:'TrustInstaller in Task Manager\Services is Stopped, and I get 'Access Denied' when trying to start this a concern?)

For every scan Mal-Ware Bytes checks for updates, pre-scan operations, scan for rootkits, scan memory, scan startup files, scan registry, scan file system, and Heuristics Analysis.

In the Mal-Ware Bytes dashboard, it has:Web Protection On, Exploit protection On, Malware protection On, and Ransomware protection On.

If just running Mal-Ware Bytes is not going to be enough protect, can the forum community recommend a anti-virus-mal-ware-ransomware/internet protection product? OK if paid.

According the Mal-Ware Bytes web site, it does this:
Protects you from advanced (zero-day) threats, including ransom-ware, so you can surf the Web without worry
Removes all traces of malware for complete safety
Removes potentially unwanted programs (PUPs) that make your computer run poorly
Scans fast so you don't have to sit around and wait for your security to finish working
Easy to use, just set it and forget it
Can replace antivirus or run alongside other antivirus programs(eh, this part not true)
My System SpecsSystem Spec

 Taking 'ownership' questions.

Thread Tools

Similar help and support threads
Thread Forum
Who's taking ownership
3 part question. 1 Why do I need to "take ownership" of files after I download them? 2 Who or what is taking ownership of my files? 3 Can that entity be removed? I am the only user of this machine and not on any network. I can download a video and after a day or two it won't open until I take...
General Discussion
Taking Ownership problem?
Hi, Before sending my dead laptop in for repairs, I pulled the drive and put it into an enclosure to copy some important files. But to access the files I found that my other computer had to change the ownership of the main folders. Here's my question: when I eventually reinsert the drive...
General Discussion
Odd problem after taking full ownership of C:
First the basics... Asus G71G laptop; dual core T9400 CPU; Nvidia 9800m; 6gb ram; Win7 Pro x64. Drivers and everything up to date (I think). What happens is that immediately following taking full ownership of C:, the "safely remove hardware" icon stops working. I can hover the mouse over the...
BSOD Help and Support
Taking ownership did zip all.
All I'm trying to do is swap out some very annoying application wav files for some other not quite as "nails on chalkboard" annoying ones. Went though the changing ownership process and noticed "Replace owner on subcontainers and objects" although letting me toggle on becomes unchecked on...
General Discussion
Taking Ownership of an .exe
Hey all so I got the Takeownership.reg file off here it and its worked excellent so far but now when i went ot try to take owneship of a .exe the "Take Ownership" isnt there anymore. I clicked a folder and it was there but not when I select a .exe, you tell me what you think! =P Thanks, Kukag
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:22.
Twitter Facebook