Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: btmg missing, coupled with problematic ISO usb

25 May 2017   #1
LivingDegree

Windows 7 enterprise x64
 
 
boot manager missing, system repair failed

Hello, this is a pretty hair pulling problem and I have no idea if I should just upgrade to windows 10 when I put in my new graphics card, but here we go from the start:

So, I created a windows 7 ISO as I was having problems booting into safe mode. What would happen is after booting into safe mode the computer crashed unexpectedly, with nothing but that being reported in event viewer. So, stupid me decided to try and fix the problem by booting into the USB and letting it fix my safe mode starting errors. first, clicking repair your computer tells me that there are problems with the startup options. My thinking is well, lets go ahead and repair and restart, thatll fix the safe mode crashing! Clicking this option gives a "failed to save startup options", and lists nothing else. Next, I see that the system recovery options cannot find my OS, even though I just booted into my OS to see event viewer and go on chrome etc.

Clicking next to restore the computer to an early state kicks back: "an internal error occurred, the following information might help you resolve the error: "The system cannot find the file specified. (0x80070002)" clicking okay takes me to the options for system recovery.

I restart, and change boot priority to the SSD that worked flawlessly before and now its broken. Great! Now, I had a weird problem starting windows in the normal mode pop up, so I googled a bit and come across someone who lists how to set my drive as active so the OS may be found, completing those commands yields no results (it was just a disklist and active command using command prompt in the system recovery tools). This was done to try and get the USB to find my OS, but did nothing.

So, now I attempt to solve the boot problem by using a handful of bcd commands. Here is a link to an article that I used to solve the first set of booting problems listed in the article.

How To Fix Boot/BCD 0xc000000f Error Windows 7 | Think Like A Computer

completing the above steps yields this:
The boot configuration data store could not be opened.
The requested system device cannot be found.

great! Now my thought is this failed (again I used the command prompt in system recovery tools), so I decided to restart my computer. now we come to the final brickwall. it now doesn't even punch back an error code or anything, it just says bootmgr is missing. Restarting into the USB results in the exact same errors as first mentioned. Now, being bummed and mad I try to click system restore, which gives "To use system restore, you must specify which windows installation to restore. Restart this computer, select an operation system, and then select system restore" which I can't figure out how to do.

Nothing works, everything kicks back error codes and windows can't figure out how to repair itself. I have given up, and I don't know what to do. Clicking startup repair again just says it cannot repair this computer automatically, and upon viewing the problem details it lists missingbootmanager as problem signature 07. Booting into bootmanager yields some crazy error codes and puts me into a loop of selecting the OS and the restart not working or checking the memory which yields no errors.

Have I bricked my SSD? Is there any hope to repair? Should I just install my new graphics card, wipe this SSD and install windows 10?

last bit of info: The ISO is a windows7 enterprise ISO given out to students at my UNI to use for free, and saving money is big so i am trying to use that. Also, the windows 10 ISO is a windows 10 education ISO from my school as well. I think all my system specs are listed on my profile, I wrote them all out when i made this account.


My System SpecsSystem Spec
.
25 May 2017   #2
LivingDegree

Windows 7 enterprise x64
 
 

So, some further investigation finds some more fun problems. First, the only way to repair anything right now is via the command prompt, which makes things slightly more difficult. Second, I have identified 3 problems. Problem one is with starting boot manager in the BIOS selection option yields an error, saying that winload.efi is missing or corrupted, error code 0xc0000001. Trying to fix this gets me as far as the rebuild bcd command highlighted in the article below.

FIX: Steps to Fix Winload.EFI Error - Appuals.com

Which kicks back the highlighted error: The requested system device cannot be found. Trying to fix this has yielded me no where so far, and this is what I would like to fix before moving on to fixing the missing boot manager.
My System SpecsSystem Spec
25 May 2017   #3
LivingDegree

Windows 7 enterprise x64
 
 

Okay I fixed it, sorry for posting so soon but the guy who highlighted this fix is a legend, link to the full article that can help anyone else facing some crazy stupid errors can go to the link below. Turns out that a simple

bcdboot.exe C:\Windows /s C:

Forced the OS into finding and fixing the boot registry and winload.efi error. I dont know if it simply made these files accessible/findable again or if it wrote over them, but whatever the case it worked for me.

Link:
bcdedit - Problem recreating BCD on Windows 7 64bit - The requested system device cannot be found - Super User
My System SpecsSystem Spec
.

Reply

 btmg missing, coupled with problematic ISO usb




Thread Tools




Similar help and support threads
Thread Forum
Any problematic experience with Sapphire Hd7770 Ghz Ed?
I bought this (http://www.sapphiretech.com/presentation/product/?cid=1&gid=3&sgid=1159&pid=1723&psn=&lid=1&leg=0) card yesterday, runs just fine. Was just browsing through reviews, and came across a review that said something about manufacturing defect that renders it useless after 2/3 weeks?! I'm...
Graphic Cards
Downloaded program is problematic
I use a program (downloaded from the internet) which has become a problem. It has been OK, but when I updated it to the newer version, it made my startup and shutdown, real slow. I have uninstalled the program and wiped all traces of it. My PC then ran as fast as new. Am I allowed, in this...
Software
Problematic problem with sleep and lid
When I put my computer to sleep, and close the lid, every time I lift my case with the laptop in it the lid opens and therefore my laptop resumes from sleep. When I open my case the laptop is so hot the hard disk stops working and I need to turn off. Sometimes it's more severe than that. How do...
Hardware & Devices
Problematic Network driver.
Hey all. Well first of i start saying that i had win 7 64bit before. but formated and installed whit xp. But i miss w7 so i reinstalled it from same file as before. Tho now i have a problem i never had before. when i start the pc like when im home from work the internett (wiered) does not...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:20.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App