Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Permission trouble...?

16 Feb 2009   #1

Windows 7 Ultimate Beta
Permission trouble...?

I have constantly been plagued by this problem since upgrading to the public beta of Windows 7. Randomly, I will be unable to access certain files. I receive this error when I try to run one:
"Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item."
And when I right click -> Properties -> Security, I see [attached]
This will happen randomly for different files; sometimes when I'm updating programs, reinstalling/uninstalling applications, recompiling Visual Studio projects, etc.
The files seem to unlock themselves when I switch user and login with another user account, then logout and go back to my current one. I could do this, but it really does get annoying after a while, and the files locking will often interfere with whatever application setup/update processes may be running.
I've tried creating and using a new user profile and even using the 'true' Administrator profile, but the error still exists in all of these cases.
I upgraded from Vista SP1, so I've been suggested by some people to do a clean reinstall of 7, but I was hoping I could fix it without losing my personal settings.

Any help at all would be appreciated.

Attached Images
Permission trouble...?-permissionerror.png 
My System SpecsSystem Spec
16 Feb 2009   #2

7600.20510 x86

Don't bother with a clean install. I have a clean install here and I have the same problem. Once in a while, taking ownership manually and then adding my account to full permissions fixes it. Mostly a reboot or waiting is the only other way so far. I'm sure there will be a hack to disable this "feature" sooner or later.
My System SpecsSystem Spec
16 Feb 2009   #3


It's a random bug and I've reported it to MS :)
My System SpecsSystem Spec


 Permission trouble...?

Thread Tools

Similar help and support threads
Thread Forum
Permission issues. Fed up with "You do not have permission to....."
First, the important intro: I'm running two Win7 systems: my desktop runs 64bit Win7 Ultimate, the laptop is Win7 64bit home version. Both were clean installs, are routinely scanned for viruses, malware, hardware problems, regularly defragged, etc. I run lean machines; the only TSR (for all you DOS...
General Discussion
Trouble pasting, trouble canceling paste
I tried looking this up, tried searching multiple ways and I am not getting an answer, so here I am. Last night I cut 34.8 GB from one drive, pasted it to another. It said 50 minutes, I went to sleep. 8 hours later, it says 50 minutes remaining, so I hit cancel. It has now been canceling for...
General Discussion
You need permission - happening on networked drive that has permission
Have looked at the other postings about Windows 7 and "You need permission" - this one seems new. I have a laptop and a desktop both running Windows 7, both part of HOMEGROUP. The desktop has two hard drives (C and D), both shared with full access to EVERYONE. I can see both but can only...
Network & Sharing
Mouse Pointer trouble and startup trouble
I have trouble whenever start windows the start button appears as a white box and nothing appears on the desktop just the (just the background, no icons nor the gadgets) then I tried starting it on safe mode and did system restore however when it does start the mouse pointer keeps on appearing as...
General Discussion
No Permission
Windows 7 isn't allowing me to save anything to my desktop, it says I don't have permission. Why?>
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:46.
Twitter Facebook Google+