Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Cannot delete custom font, access denied in elevated command prompt.

09 Jul 2017   #1
Tobiasfrost

Windows 7 Ultimate SP1 x64
 
 
Cannot delete custom font, access denied in elevated command prompt.

Hello,

I'm trying to install the font family Clementine. It should include a regular, italic, bold italic, and expanded regular (which is like bold italic with slightly different spacing).

I thought I had installed it already, but only two of them were showing up. I forget which two. I downloaded and installed them again, but I still don't have all of them showing up, and the names seemed to be incorrect. I mean "Clementine" was definitely a bold or bold italic version of the font. I deleted all of them and tried reinstalling them, only to notice that in the font preview window the displayed font name wasn't matching up with the files. It also would tell me some of them were already installed.

After that I went into the font folder in an elevated command prompt and found there were some duplicate otf files for this family, with _X added to the file names. I tried to delete them but one file is telling me access denied. I tried rebooting and deleting it, and rebooting in safe mode, and it says the same.

I tried reinstalling the fonts again, and only two of them show up (this is in Photoshop's font list). I need to have a regular, italic, and bold/bold italic version. I'd also like to know why this is happening.


My System SpecsSystem Spec
.
10 Jul 2017   #2
Tobiasfrost

Windows 7 Ultimate SP1 x64
 
 

Well I still do not know what causes this to happen, I found a workaround after trying several things, but only for Photoshop I think.

I was able to delete the erroneous clementine_1.otf by opening an elevated command prompt and typing attrib -r -s C:\Windows\Fonts to unflag the folder as a system folder. This will also change the way the folder displays in Explorer to be like any other folder. I imagine you can change it back but I haven't tried yet. Then I was able to delete the font. However after doing that the fonts still would not install and display correctly in Photoshop. In a font manager like NexusFont, it would show all 4 Clementine variations, however the bold italic and expanded regular versions do not display properly. They display the same as the regular and italic versions. When installing them, the bold italic and expanded regular versions display incorrect names at the top of the preview window. They say Clementine or Clementine Italic. When clicking install, however, the installation progress window correctly says the bold italic and expanded regular names.

I also used CCleaner to check the registry for erroneous/old font entries and removed them. I manually checked the entries for clementine after reinstalling and they were correct.

After some searching I found that Photoshop has it's own folder it will check for fonts: C:\Program Files or Program Files (x86) depending on version\Common Files\Adobe\Fonts\
On my computer this folder wasn't there and I had to make it. Then I copied the 4 Clementine files and they all show up correctly in Photoshop now. Since Photoshop is the only program I want to use them in, this is fine for now. However I get the impression something is wrong with my Windows user account as the registry font entries appear fine.

Attached is how the fonts in question display in NexusFont. You can see that although the bold italic and expanded regular versions are named differently, they are displaying as duplicates of the regular and italic versions. In Photoshop however they appear correctly.


Attached Thumbnails
Cannot delete custom font, access denied in elevated command prompt.-capture.png  
My System SpecsSystem Spec
Reply

 Cannot delete custom font, access denied in elevated command prompt.




Thread Tools




Similar help and support threads
Thread Forum
Elevated Command Prompt
How to Open an Elevated Command Prompt in Windows 7 This will show you how to open an elevated command prompt with administrator rights (Run as administrator) instead of the default command prompt without administrator rights in Windows 7. If you opened the elevated command prompt from a...
Tutorials
Elevated Command Prompt Shortcut
How to Create an "Elevated Command Prompt" Shortcut in Windows 7 and Windows 8 This tutorial will show you how to create a shortcut that will open an elevated command prompt with administrator rights in Windows 7 and Windows 8. When you use the elevated command prompt shortcut, you may be...
Tutorials
Elevated command prompt over SSH
Not sure if this is the proper forum for my question, but here it goes. I'm using a SSH server to remotely access my notebook from work. It works well for SFTP and remote command line access using a dedicated, non-admin, user account. Problem is when I want to run something that requires...
Network & Sharing
Tip for Elevated Command Prompt
This probably is not new to many, but I find it useful. There are times I want an elevated command prompt. I usually type in "cmd", right click on it and run as administrator. If you need an elevated command prompt now and then, simply create a shortcut to "cmd". Right click on the shortcut,...
General Discussion
How to open Elevated Command Prompt?
Hi friends ! Uber Philf told me to start a new thread with my problem. I cannot open an Elevated Command Prompt, Dont know why. I know that I can open it in two alternative ways : 1). Win+R, type cmd, hit enter eith ctrl+shift pressed ; and 2). start > all programs > accessories > command prompt >...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:40.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App