Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Bootcamp Windows 7 fails with "Partition Signature=!55AA"

21 Oct 2017   #1

7 Ultimate 64
Bootcamp Windows 7 fails with "Partition Signature=!55AA"

I appreciate the awkward nature of this issue, I'd say I'm a competent tech but have fairly limited knowledge on issues regarding the MBR. I've read up a bit on the issue and most people never responded to the suggestions.

Windows 7 Ultimate installed on a Macbook Air (Mid 2013, i5). Mac OS, Bootcamp and Windows and all installed in Chinese (Can't read it but the Translator app by Microsoft is proving fantastic).
Mac will boot to Windows partition but instantly hits this error: "Partition Signature=!55AA". Nothing more comes of it. Boot to a Windows USB, Command Prompt, and Bootrec /fixmbr and reboot. Mac boots into Windows fine but upon restarting returns to the previous 55AA issue.

Things I've tried:
System Restore - No points available
Reinstall the Bootcamp drivers
Chkdsk /f c:\ - upon fixing the chkdsk responds "Cannot open volume for direct access. Autochk cannot run due to an error caused by a recently installed software package. Use the system restore feature from the control panel to restore to a point prior to the recent software package installation."
The bootcamp partition was already full to the brim (128GB SSD split in two) and the old restore points were probably deleted.

Any suggestions are welcome!

My System SpecsSystem Spec
21 Oct 2017   #2

Windows 7/8.1/10/XP multiboot

Well, this isn't really a Win7 issue, it's a Mac issue, so you may need to take this to an Apple forum somewhere. I don't do anything Apple, so am not familiar enough to give you any specific advice, but I can give you an idea what's going on.

The problem is with either the MBR or a partition boot sector, both of which should end in the two bytes 55h and AAh. This is one of the cues DOS, Windows, linux, et al, use to identify when they're dealing with partitions. Take a look at this screenshot of a NTFS partition's boot sector. You'll notice it ends in 55-AA. The same is true for the MBR sector (the first sector, with the partition table, on a disk).

Apple has a long history of writing those two bytes as AA-55. I had heard that the issue was related to the way Apple's PowerPC chips stored binary "words" (as opposed to two bytes) vs. Intel CPUs, but I thought the issue was rendered moot when Apple switched to Intel CPUs. FTR, Intel CPUs use "little-endian" math, where the word AA55h would be stored LSB (least significant byte) first, as 55h and then AAh. PowerPC's used "big-endian", where AA55h would be stored MSB first, as AAh and 55h.

I have no idea what Boot Camp really is (is it a multiboot manager using physical partitions? Or is it virtualization software using virtual partitions?), but use a sector editor to poke around wherever Windows would be trying to interpret as a partition table (MBR) or as a Windows partition. In the case of the partition table, it would be the first sector on a real or virtual disk. In the case of a Windows boot or system partition, it would be the first sector on a real or physical partition.

What you're looking for is the tell-tale bytes, 55-AA, at the end of the sector. If you see them as AA-55, the solution might be as simple as manually reversing them and saving the change. If that doesn't work, or if you see neither 55-AA nor AA-55 at the end, then it's not a simple solution and you'll probably need to check with Apple experts.

In either case, it's not a Win7 problem, it's a fundamental problem with the way the partitions are defined before Windows even gets started.
My System SpecsSystem Spec
21 Oct 2017   #3

7 Ultimate 64

Very interesting stuff! I do truly appreciate it. I've taken your advice and asked in the official Bootcamp Forums.

From my understanding, Bootcamp utilises a MBR/GPT hybrid. I'm struggling to comprehend how it works once and then reverts to the same issue. Unfortunately, the laptop is at work so I'll have to try on Monday.
My System SpecsSystem Spec


 Bootcamp Windows 7 fails with "Partition Signature=!55AA"

Thread Tools

Similar help and support threads
Thread Forum
SFC fails to repair corrupt member files "mstsc.mof" and "mstscax.mof"
Hello, I've scanned my laptop with SFC four times in this past week, and each scan ended with the same failure to repair specific files. I'm uncertain how to proceed with these corrupted files. I followed the instructions in the SFC /SCANNOW tutorial; I installed the System Update Readiness...
Performance & Maintenance
Partition Wizard Pro 9 "Bootable Media Builder" fails to burn CD
Just tried to create a bootable CD using Partition Wizard Professional's "Bootable Media Builder", and it failed to write anything to the CD. ==> This is Partition Wizard Professional 9's BMB feature, with the Jan 14 2015 build of the v9 product. Tried it on two PC's, and it failed...
Performance & Maintenance
Connect "Desktop" to other partition than Windows "C:"?
Hello, I'm interested in the following: Connecting "Desktop" to other partition than Windows "C:", so if I drop files on DSKT for easy reuse and availability, they copy on, f.e., "D:" or other partition. Any way to achieve this? Thank you.
General Discussion
"windows cannot verify the digital signature for this file" 0xc0000428
Hi, I went out and left my pc on, came back hours later and wiggled the mouse to get the pc to come on, nothing happened so i pressed some keys, may of restarted pc, pc boots as normal but a screen comes up saying choose and operating system to start, or press tab to select a tool. i then click on...
General Discussion
Moving bootmanager from "Storage" partition to "System" partition
Hey, whats up? New here. Right now my hard drive is split up into two partitions: System and Storage. However, when installing 7, for some odd reason, the installer put the boot manager (I think it is the boot manager) on my Storage partition, when I want it on the System partition. Is there a...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:11.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App