Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Import Reg File: cmd works - Reg\Regedit w/bat file doesn't work?

27 Oct 2017   #11

win 8 32 bit

/s on regedit runs it silent so no need for user to do anything

My System SpecsSystem Spec
31 Oct 2017   #12

Win 7 Pro 32bit

Thanks for everyone's input and suggestions.

I'm familiar with the /S switch but unfortunately, it seems I can't import .reg files with any .cmd or .bat files.
I've tried 'reg.exe import' and 'regedit /s' , nothing works except manually typing in cmd prompt or running the .reg files directly.

I've never run into anything like this.

I'll try to read\export key and see if that's possible.
My System SpecsSystem Spec
01 Nov 2017   #13

Win 7 Pro 32bit

Exporting is no problem - only importing or adding.
Tried Reg ADD but it recreated main key (HKLM\Software\...... Run).
Can't remember how to ADD via Reg.exe it's been that long.
Only need to add the entry for auto running or not auto running a program with windows start.
Import probably would work better for that? But ADD would allow direct input of value\data which works.

Any ideas how to reg add when RUN key is already present?
My System SpecsSystem Spec

12 Dec 2017   #14

Win 7 Pro 32bit

Just wanted to again thank everyone here for their input.
Was able to knock the cobwebs out of my war torn brain and figure it out.
My System SpecsSystem Spec
3 Weeks Ago   #15

Windows 10 x64

Quote   Quote: Originally Posted by KapaKai5O View Post
Was able to knock the cobwebs out of my war torn brain and figure it out.
Please tell me how you did it.

I am on the verge of just converting my .reg script to a .bat version and using reg add because importing the .reg file via .bat (using regedit /s) is not working. It applies fine if I manually run the reg file, but I am having the same problem you were having.

EDIT: Found at Technet:

"ok, it's weird but I think I worked it out. Windows 7 won't merge
a .reg file with regedit, reg or regedt32 at logon if the .reg file is
on the network during logon. It works ok after logon, though.

So, I changed our logon script to copy such files to %TEMP% and
apply from there and now it works ok.

I do often wonder why Microsoft do such things..."
I'll try doing xcopy to %TEMP% and see if it can be run from there.
My System SpecsSystem Spec

 Import Reg File: cmd works - Reg\Regedit w/bat file doesn't work?

Thread Tools

Similar help and support threads
Thread Forum
.bat file doesn't work without admin permissions
Hi All, I have bitlocker and have found a guide to allowing me to right click on the drive to relock it; it is done via a .bat file. Unfortunately this .bat file will only run if I right click on it and 'run as...
General Discussion
Search doesn't work for numbers in contents of a file
I'm having no luck figuring this out. So I hope you guys will be able to help. The search function doesn't work for me when I search for partial numeric strings. I created a text file and put 123456789 inside it. Search only seems to find the text file when I do a search for the exact...
General Discussion
regedit default uninstallstring file name
Hello, everyone I need some help. Could someone give me the default value data name for "Unistall String" I clicked on it while looking (just looking not trying changing anything) and renamed it. Thank you in advance. I used system restore. How do I delete this post?
General Discussion
Open file and Save as doesn't work
Hi there, I have the same problem already reported in the forum:File|Open and File|Save As does not work at all for any application. Basically nothing happens, the dialog never opens an in my mail is not possible to upload files.. nothing, the common dialog to handle files never opens. I tried to...
General Discussion
How can I replace my W7 registry file without using regedit ?
Having an issue with my system and trying to restore to an earlier state...but both System Restore and Regedit - import are giving me errors ? Here's a couple screen shots that show the main error messages attached On the registry...I have a full backup of my registry prior to the changes I...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:27.
Twitter Facebook