Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Serious Problem "services.msc" (and all the .msc) have disappeared

18 Nov 2017   #1
Zappastixs

Windows 7 Home Premium 64 bit
 
 
Serious Problem "services.msc" (and all the .msc) have disappeared

[SIZE=""]


Serious Problem "services.msc" (and all the .msc) have disappeared


Hi

I have a serious problem with Windows 7 Home Premium 64 bit Notebook.

Sorry for long-winded explanation - but I need to let you know what has happened.

I have been having a number of issues, one that it seems I have managed to solve after
computer was constantly running out of memory.

After running CHKDSK (with repair) three times it came out with clean bill of health
and Sfc /scannow a few days ago Ė the memory problem hasn't happened since.

But when I checked Task Manager/Resource Monitor my hard drive (one with two partitions)
is constantly spiking (blue colour) what seems like every fraction of a second.

So I tried to run Avast (free) but after it upgraded itself a few days ago, there seems to be a
problem because after I left it just scanning for viruses (nothing else) for over two hours it
had only completed one percent.

At that point I should have deleted the upgraded Avast and reinstalled the previous version
that was working okay.

But what I did instead was to try and open up Windows Defender that I hadnít used for ages,
only to find that it was blocked.

It was at this point where all the trouble started.

I read online that to get Defender running again I need to enable Group Policy Editor

So from this site it explained how to do this;

https://www.askvg.com/how-to-enable-...rter-editions/

I followed instructions to the letter - that included downloading a file with name;
Install-Group-Policy-Editor-in-Windows-10-Home-Edition.zip

and also copying from C:\Windows\SysWOW64\GroupPolicy
and C:\Windows\SysWOW64\GroupPolicyUsers [folder was empty]

and drop into C:\Windows\System32\GroupPolicy
C:\Windows\System32\GroupPolicyUsers [folder was empty]

And then try to run gpedit.msc . . . gpedit.msc failed

When it failed I followed the instructions between the lines below.
---------------------------------------------------------------------------------------------------------

When I ran gpedit.msc I received;

"MMC could not create the snap-in" error message.

I followed the steps to correct this (but it didn't work)

1. Run the installer and leave it at the last step (do not click on the "Finish" button).

[INSTALLER: https://drudger.deviantart.com/art/A...msc-215792914]

2. Now go to C:\Windows\Temp\gpedit\ folder.

3. If you are running 32-bit (x86) edition of Windows 7, right-click on x86.bat file and choose
"Open With -> Notepad" option.

If you are running 64-bit (x64) edition of Windows 7, right-click on x64.bat file and choose
"Open With -> Notepad" option.

4. You'll find a total of 6 lines containing the following string in the file:

I changed the 6 lines on Notepad;

From: icacls %WinDir%\SysWOW64\gpedit.dll /grant:r %username%:f
To: icacls %WinDir%\SysWOW64\gpedit.dll /grant:r "%username%":f

This didn't work.

---------------------------------------------------------------------------------------------------------

This morning I went back to delete the changes I had made to
C:\Windows\System32\GroupPolicy but couldnít find them.

For instance I searched for: gpedit.dll

But no results.

Although I just remembered I did use Notepad+ + instead of regular Notepad
but I canít see that would make a difference.


Then I thought I hadn't tried looking at Services.

I couldnít remember if Defender is listed, but if it is maybe I had turned Defender off there.

TO MY HORROR - when I tried to open it all I received was "services.msc" running as NOTEPAD.
I tried eventvwr.msc - the same, would only run as Notepad.

No problem I thought, I'll do a System Restore, that I had created the other day before I ran
CHKDSK

There were 4 restore points. I selected the last - the one I created the other day.

It ran for a long-time - but finally failed with Catastrophic failure (0x8000FFFF)

So I ran one of the other restore points.

This also took a long time with regular message . . . . System Restore is Initializing.

After around 90 minutes and nothing had changed - I bit the bullet and held power off
for 10 seconds to stop it restarting straight into continuing with System Restore is Initializing.

I started in Safe Mode and I had read I should select Last Good Configuration.

This started Windows proper - but where I had left off, in other words
nothing had changed.

I still could not open any .msc

So before I do anything else could some one help with getting "services.msc" to open normally.

Iíve had this ASUS for around 8 years and never had a problem like this.

Thank you very much in advance.

Stephen

[/SIZE]



My System SpecsSystem Spec
.
18 Nov 2017   #2
SIW2

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

You can borrow my boot media. Boot it up and you can see what youre doing. There are plenty of repair tools included.

17514x64v5.iso
My System SpecsSystem Spec
21 Nov 2017   #3
Zappastixs

Windows 7 Home Premium 64 bit
 
 

Thank you S1W2.

Sorry for the delay I have only just got back.

If it's okay I'll contact you again in a few days.

I haven't heard of this tool - but it sounds good.

Soon . . . .Ta!

Stephen
My System SpecsSystem Spec
.

26 Nov 2017   #4
Zappastixs

Windows 7 Home Premium 64 bit
 
 

I have just tried to download the ISO - we have rubbish broadband here, it failed with just 7% to go.

If/when I get to try this - if it helps/works I'll get back to you to thank you.

If not - thank you anyway.

S.
My System SpecsSystem Spec
27 Nov 2017   #5
Zappastixs

Windows 7 Home Premium 64 bit
 
 
Unfortunately iso kept failing



Unfortunately iso kept failing - we have a really bad broadband rate, but I always manage to get downloads to complete.

Since last night I have tried the iso 7 times.

Each time just before the end of download I recive a No File Found message.

Bit of a bugger - but thanks for trying.

Stephen
My System SpecsSystem Spec
Reply

 Serious Problem "services.msc" (and all the .msc) have disappeared




Thread Tools




Similar help and support threads
Thread Forum
boots up then freezes when "Windows Search" is checked in "Services"
Windows 7 Pro, 64-bit, boots up and runs fine as long as "Windows Search" is NOT checked in "Services". When I run msconfig in the Services Tab, that is the Windows Search checkbox that I'm talking about. If the box is checked, computer will start up, allow me to click on my user icon and...
General Discussion
External USB2 drives "disappeared" from the computer explorer window
I have four external usb drives. All seem to have disappeared at the same time. I checked one of them on another computer and it's fine. There's no error \ in the device manager, except it said that the device on one port had failed. I disabled that but left it plugged in because I don't know...
Hardware & Devices
The "Applications" screen in Task Manager has disappeared!
When I launch Task Manager, the only screen I have access to is the Processes screen - and I do not have any options to see what applications are running, or anything other than which processes are running, which makes it much more difficult to determine what's going on with my PC. I have run...
General Discussion
second hard drive icon "D" disappeared after reinstalling windows
"C" drive is showing in my computer but the "D" drive is not showing anymore after reinstalling windows
General Discussion
Partition "E" and "F" disappeared and unallocated
Hi I leave My PC turn on last night and today i go back and see my 2 drive disappeared.i use "Disk Management" but couldn't see them.then i use "Acronis Disk Director Suite" and see them "Unallocated" and joined together...!if i use "Create Partition" option in acronis , all my data will lost...my...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:42.
Twitter Facebook Google+