Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Color is missing in videos?

08 Dec 2017   #1
ItsMatty

Windows 7 Professional 64-bit
 
 
Color is missing in videos?

Hey all, so my computer usually runs perfectly, but I've had this little graphics bug for a while now and I've finally hit the breaking point.

A screenshot of my problem is below.

As you can see, some colors (blue i think) are now gray, it's been happening for ages now but it never bothered me before

anyone who's played overwatch knows that's not what the hero selection menu is colored like.

Is there some setting that's been turned on? Is it my graphics card acting up? Is it the format of the video file? (MP4)

Please help me. I want this fixed. If anyone has anymore questions about this I will try my best to answer them. Thanks.





My System SpecsSystem Spec
.
08 Dec 2017   #2
Acova

Windows 8.1 x64
 
 

Hi,

Hope I can be of any help in here by providing some thoughts of mine for your questions.

Quote:
Is there some setting that's been turned on?
It could be the case. You may like to try double-checking global graphic card's settings used to run along with specific application of your interest.


Quote:
Is it my graphics card acting up?
I believe it is not the case. If it was device's problem, it would not be so selective in terms of places to show color problems. As you may find, there are some blue areas visible on video player itself (buttons). So it tells that your card is working alright, but specific apps, might be set to run under different settings, or could be limited for some reason. If you trust that your graphic card is yet to live a long happy life servicing to your needs, then you shouldn't be taking this case seriously. It's a good news, at least.


Quote:
Is it the format of the video file? (MP4)
Sometimes it can be a problem in codecs used to help render videos in specific extensions. So you could check some settings or attempt to play around with them there.

Or you could download a set of codecs along with a different media player from here:

Codec Guide: K-Lite Codec Pack - For Windows 10 / 8.1 / 7 / Vista / XP

If you experience same issues over there as well, attempt to check up settings in codecs supplied along with the installation file there, though, I doubt it would be pre-set to run with artifacts like the one you mentioned about blue.

Also, if it is only about playing your videos in mp4, but the game itself has nothing wrong with colors, then yes, it's most likely something going wrong with codecs/settings that are used to help render videos in media player. You would then prefer to look in options of that media player you experience problems viewing in addition.

However, if your game shows some lack of colors as well, it could be graphic card's settings for that game. Or some bug in game, a fix for which is probably out there long ago.

For insurance, ensure that you have the latest driver's version for your graphic card. They often add features for graphic cards to run the game better, so if you are outdated on this one, then it could solve your problem of color lack in game, though, you haven't really specified it in your post there.


----

To keep it short and nice (I am not always successful with this part ) :

1) Try other media player, check how other one runs the same video and see if it gives you the same experience. If it does, then attempt looking up for some problems or incompatibilities within set of provided settings there (or in codecs), remember your initial settings, and try playing around with some related to color calibration/balance. I've already recommended this:

Codec Guide: K-Lite Codec Pack - For Windows 10 / 8.1 / 7 / Vista / XP

So perhaps you could give it a go, should you not have it already.

2) Check graphic card's global settings for specific applications if this is applicable in your case and if it is a problem not only with your MP4 video playing.

3) Ensure you've got the latest graphic card's driver which is for your specific OS and its bit.

I hope it helps you any how, also, you haven't provided more details regarding your graphic card, which is fine but there are chances your problem might be explained somewhere over the internet as well. You could attempt to google your card's model and include relevant issue's key words - for example "card's name and its model + color problem in videos"

I believe that it could shed more relevant sources for you to look at. I don't exclude the possibility of it being a bug indeed, and for bugs, there are usually fixes in later driver updates.

I tend to think that this is a case where you only need to check up with the settings your media being played with.

Ah and also, if it happens that the videos lacking color come from captures from specific source only, then it could also be rather captured videos' problem alone, e.g. lack of blue information, then it would not be the problem of your settings or graphic card at all. You can check it by viewing other video sources in same extension, or checking youtube videos - and should you indeed find that blue set of color is present in those videos you watched there, then you help yourself cut down on possible scenarios -> helps you to locate the problem's origin.

I gave my thoughts for this one, hope they are useful to you.
My System SpecsSystem Spec
08 Dec 2017   #3
ItsMatty

Windows 7 Professional 64-bit
 
 

Quote   Quote: Originally Posted by Acova View Post
Try other media player, check how other one runs the same video and see if it gives you the same experience. If it does, then attempt looking up for some problems or incompatibilities within set of provided settings there (or in codecs), remember your initial settings, and try playing around with some related to color calibration/balance. I've already recommended this:
I tried playing it with VLC media player, and it works fine! So now I know the problem is with Windows Media Player. Thanks for the help, but now I need to know why the media player is acting up..
My System SpecsSystem Spec
.

09 Dec 2017   #4
Acova

Windows 8.1 x64
 
 

As long as you know where the problem resides, it's much easier to deal with it, rather than listing all possible cases ;D

1) Somewhere in WMP settings something went odd
2) Graphic Card's settings overlay / get in conflict with your WMP's settings
3) WMP some module went corrupted/broken
4) maybe more cases...

In either case, you could try something like WMP re-installation or upgrade if you are not on the latest one already. If it doesn't solve the problem, then it is somewhere in graphic card's control panel settings.

For example, I looked up on internet and found some case, I believe, worth checking:

video is blue windows media player windows 7 64bit - Microsoft Community
My System SpecsSystem Spec
Reply

 Color is missing in videos?




Thread Tools




Similar help and support threads
Thread Forum
Windows 7 Log Screen Font Color/Background Color
Hey all, I have a question regarding the font/background colors on the Windows 7 log screen. I just accepted a position with a school and a few computers have customized log screen font colors/backgrounds. The Windows 7 classic background is there, but the username and password boxes have been...
General Discussion
"My Pictures/Videos/Music" missing from home folder
When I reinstalled Windows recently I decided to move my user data folders to my D drive since C drive is a new SSD - I did this by using the location tab in the properties dialog. Now, when I click the start menu and click on my username to open my home folder, it displays all my data folders,...
General Discussion
No Default Color Profile Listed in Color Management?
Hello everyone. I want to color calibrate my new Dell XPS 15z laptop, but before I do I'd like to back up the existing color profile in case I prefer it to the calibrated one ... The only problem is, when I open Color Management, NO default color profile is listed, so I don't know what to go...
General Discussion
thumbnail previews for m2t videos missing
These used to work just fine. I would view as various icon sizes and I would see the first frame of the video stream. Now, I see no first frame, just an icon. I have searched the web for a few days with no solutions. Any ideas how I can get this back working again? Thanks
Music, Pictures & Video
Videos, Pictures and Music missing from Start Menu
I was wondering if anyone on here could possibly help me with this. For some reason, even though its set to show the links on the start menu properties, for some reason the Videos, Pictures and Music links aren't anywhere to be seen on my start menu. The link to my documents, downloads and...
Customization


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:15.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App