Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows Wont Boot After Using Windows Repair Program

24 Dec 2017   #1
Mulsiphix

Windows 7 Home Premium
 
 
Windows Wont Boot After Using Windows Repair Program

Alright, I ran the Windows Repair program from Tweaking.com. I ran through the four steps to check my system for errors. After step 3 (chkdsk of all drives) it booted into Windows 7, following the reboot of the final drive being treated by chkdsk. Windows worked fine. I rebooted, power cycled (properly), ran SFC and it said it found corrupted files but fixed them. I immediately went to the repairs area and applied all repairs, except the three options that were specific to Windows 8.1/10.

Upon rebooting I received an error telling me that there was a problem with the Windows files, specifically "\Windows\system32\drivers\acpi.sys". I figured, since I've seen this issue on another PC I have recently, that it was a MBR issue. So I booted up FalconFour's Ultimate Boot CD and used its Bootsect command to fix the Windows partition ("bootsect /nt60 I: /mbr"). This is when I discovered that my Windows drive, which previously only contained a single partition with Windows 7 on it, had a new, second partition. It is 95MB in size and is set to be the boot partition (according to GParted). I ran bootsect on the partition containing Windows, not the new System Recovery partition.

I rebooted and I was receiving the exact same error about the missing acpi.sys. I have had trouble with getting my Windows Repair CD to work for quite some time. So I've been using something called "Easy Recovery Essentials for Windows" by NeoSmart Technologies. It has an Automated Repair option and I have had great success with that in the past. When it ran it mentioned it was messing with the MBR boot partition.

After rebooting I see the normal Windows 7 boot screen for about 1 second and then the screen turns blue. This is not the traditional diagnostic message "Blue Screen" but a screen that is blank and the color blue. The color is near identical to the blue that you see when Windows starts up past the boot screen and says on it that Windows is preparing to start. Except that if I leave it there, nothing ever happens.

At this point I made a new Windows Recovery Disc, disconnected all drives but the Windows hard drive, and it worked. I then told it to run Startup Repair and it says that it cannot fix the drive. I checked the details and among the information it lists "Corrupted Registry". Before making those Windows repairs with the Windows All-in-One Repair Tool, I did perform a registry backup. I found a RegBackup folder on my Windows drive. It contained the Windows Repair registry backup I created before applying all the repairs to Windows. It came with a file that would allow me to restore the previous registry from within Windows Repair Disc command prompt.

I did that successfully and now I no longer experience the blank blue screen during boot, that I described previously. Instead, I'm back to it saying "Windows failed to load because a critical system driver is missing, or corrupt". The file in question is "\Windows\system32\drivers\acpi.sys". I used the FalconFour Ultimate Boot CD to look at the file on my computer and I checked. That file does not exist in that location. However, it does exist in that location on my working Windows 7 PC. I have no idea why the Windows Repair program removed it. I tried running the Windows Repair Disc but it says that it cannot find anything wrong with the system.

I rebooted, started Windows Repair Disc, ran startup repair again, and it once again lists that the Registry is corrupt. So I'm really confused on what step I could possibly take next. Any advice would be greatly appreciated.


My System SpecsSystem Spec
.
24 Dec 2017   #2
SIW2

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

Do you have a system restore point to a time before the problem?

Otherwise, you could try putting a fresh copy of acpi.sys in the windows\system32\drivers directory.You can copy it from your other machine, or there should one in


"Windows\System32\DriverStore\FileRepository\acpi.inf_amd64_neutral_aed2e7a487803437"

or

"Windows\winsxs\amd64_acpi.inf_31bf3856ad364e35_6.1.7601.17514_none_80aec972e4a75989"
My System SpecsSystem Spec
24 Dec 2017   #3
Mulsiphix

Windows 7 Home Premium
 
 

As far as restore points and system images go, I've got nothing. Lesson learned, I need to change that immediately. My worry right now is the registry being corrupted, or at least that is what is being reported. I don't even understand how the registry can still be corrupted if I am restoring a backup I made right before this all started.

I will get started on restoring the file(s) to those directories and see if that helps things at all. If the registry really is messed up though, I fear it won't matter. Thank you for your feedback. It is very much appreciated ^_^
My System SpecsSystem Spec
.

25 Dec 2017   #4
Mulsiphix

Windows 7 Home Premium
 
 

I've been plugging away at this thing non-stop for four days. While I've seen the problem change from symptom to symptom, I don't feel like I'm making any progress. For Christmas my wife offered to finance me building me a new one, since I've had this install for about 8 years now. While it will take some time to get things back to normal, the hardship seems quite worth it. So it's time to start that project and abandon trying to fix this any further. I sincerely appreciate the advice and help offered. You rock!! Merry Christmas ^_^
My System SpecsSystem Spec
Reply

 Windows Wont Boot After Using Windows Repair Program




Thread Tools




Similar help and support threads
Thread Forum
Windows 7 Wont boot and repair cant complete (Update fail)
Hello everyone A couple days ago windows forced my computer to update the update didn't install correctly Or is broken When i start my computer i get a black screen with cursor I know it is not a virus or a piece of malware or anything hardware related Nothing works but i can access the...
Windows Updates & Activation
Startup repair wont boot up
I was installing a system image in windows7 and my pc froze up and I needed to restart but after that it just said operating system is missing. I can not get my PC to boot a startup repair disk made from my other pc running windows 7..... on a new dvd 16xrecordable. The PC just says No Boot Device...
Installation & Setup
system repair wont work windows wont load
not sure if im in the right place but computer wont do anything but load up with options to do system repair or whatever its called but it says it cant fix the problem i dont have disc for it or any pw's im on a reg user account it wont load in safe mode but by doing different things i have access...
Hardware & Devices
windows 7 wont boot, wont go to safe mode or start on windows 7 disk
hi, window will not boot goes to blue screen that says process 1 initizaltion failed and starts dumping, then reboots to reapir, wont repair, tried booting to reapir disc and used bitdefender rescue which showed no virus, then tried booting to my winodws 7 upgrade disc, it says loading files then...
BSOD Help and Support
windows 7 repair wont repair
the other night i was playing an online game. when i was done i went to desktop and java wanted to update as soon as it started updating the laptop restarted and wanted to do a windows repair and sure enough it cant repair anyone have any ideas on how to fix this without having to do a system dump...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:15.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App