Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Strange boot behaviour. Is Windows Update to blame?

27 Jan 2018   #1

Windows 7 Home Premium SP1 64-bit
Strange boot behaviour. Is Windows Update to blame?

One of my PCs (Win7 x64) has been behaving oddly the past few days. It boots to the desktop fast enough, but certain things won't run.. there's no desktop gadget (just ALL CPU monitor), certain scripts that I run at startup hang (batch files seem to run, but visual basic scripts don't); System Restore, when I click on it, doesn't open.

Then, some minutes later all the above suddenly comes alive. In Device Manager, the System Devices tree had expanded and the entry for AMDA00 Interface had a yellow exclamation mark against it. After things come right, the entry is OK again (I have had problems with that entry before, though I don't recall what I did to set it right, it was a long time ago. Perhaps someone knows the solution, other than using System Restore?).

When System restore finally opens, I run it to a point made a few days previous and all is fine again.

As far as I can tell, the problem starts when I allow Windows Update to run (though I may be wrong there; on the other hand I can't see what else could cause the PC to malfunction like this). Has anyone any ideas here, or has heard of any recent updates that may possibly be causing issues like this? I am not running any more updates until I get to the bottom of this, just in case that is the cause. (If I don't get to the bottom of it, I guess I'll have to try installing updates one by one to find a possible culprit, but I'll wait a while before I start down that path - could take a time to find the right one, if any).


My System SpecsSystem Spec
27 Jan 2018   #2

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring

Hi Martin,

as its a custom build - DONT let windows update your drivers, see screenshot, manufactueres only


Attached Thumbnails
Strange boot behaviour. Is Windows Update to blame?-nodrive.png  
My System SpecsSystem Spec
27 Jan 2018   #3

Windows 7 Home Premium SP1 64-bit

Thanks, I didn't know that that option was available. I never run updates automatically though, I always have Update just announce that updates are ready to download and I select them myself. I don't download drivers, through bitter experience...

Actually, I see that the only 'Important' update sitting waiting to be installed (and which therefore would have been installed before I ran System Restore) is KB4055532 - an update for .NET framework. Not sure that that makes any sense. As I said, I am only guessing that it's a Windows update that is to blame, given the circumstances.
My System SpecsSystem Spec


 Strange boot behaviour. Is Windows Update to blame?

Thread Tools

Similar help and support threads
Thread Forum
Strange boot behaviour ('partial hangs'). Any ideas?
Over the past several weeks one of my PCs (Win7 x64) has been exhibiting rather odd behaviour at boot - and sometimes at a reboot too (though less often). I get to the desktop fast enough, but although some startup items run (like batch scripts, run from the startup folder), others do not do so for...
General Discussion
Windows Update: Incredibly strange behaviour
Hello, First post here, hope some kind soul can help! I have Windows Update set to 'Check for updates but let me choose whether to download and install them', and this has been the setting since installation. When I start Windows update, over the last couple of days, it offers no new updates,...
Windows Updates & Activation
Strange boot up behaviour after Sapphire HD6770 installed
Hi, I have just upgraded from a Nvidia 8800GT512Mb to a Sapphire radeon HD 6770 Vapour-X GFX card. The PC has always booted fine, even right before the upgrade so I could unistall the Nvidia drivers. Since I added the new card I get several seconds of quiet clicking, then the system...
Graphic Cards
Windows update symbol strange behaviour
Hi, the windows update symbol would not show up in the notification area although "show symbol and notification" is activated. The symbol is visible only when some update is available. All other symbols are working as they should. Until yesterday there was no problem at all. I looked into some...
Windows Updates & Activation
Boot issues - strange behaviour?
Perhaps someone can shed some light on this... When I boot Win 7, if I let it go on it's own, it will hang at the "starting windows" screen forever - I've let it hang there for over an hour; however, if I hit enter soon after that screen comes up, it will continue and boot up. It seems as if...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:33.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App