Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Links not working for videos, etc.

09 Feb 2018   #1
redrooster01

Win 7 64 bit home premium
 
 
Links not working for videos, etc.

I have HP desktop Win 7 64 bit. Im having trouble when clicking on links to news stories and videos, the link would work and appear for half a second then the page would go white for about 40 to 60 seconds, then the story or video would work! Now the links wont work on YouTube, there is just a white page, it doesnt matter how long I wait the video wont appear? If I click on the link it will appear in the address bar, I can press enter on my keyboard and it will work from there. I have restored my system back a few days and re-installed Firefox 58.1 and run sfc/scannow. I dont know what to do next, any ideas anyone? P.S I havent installed anything , I just did a normal CCcleaning just before the YouTube links stopped working?


My System SpecsSystem Spec
.
09 Feb 2018   #2
mitchell65

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Have you tried another browser?
My System SpecsSystem Spec
09 Feb 2018   #3
redrooster01

Win 7 64 bit home premium
 
 

I turned the computer on this morning and everthing is OK and back to normal? If it was YouTube doing maintenance or whatever I wouldve thought they would notify me? I didnt think to use another browser at the time but thanks for that. So this is tentatively solved for now, I hope? lol
My System SpecsSystem Spec
.

10 Feb 2018   #4
Snick

Win 10 x64, Linux Lite, Win 7 x64, BlackArch, Kali, VMWare Workstation Player, OpenVPN
 
 

Hi redrooster01,

If your issue is resolved, please mark this thread resolved.

Thank you!
My System SpecsSystem Spec
10 Feb 2018   #5
redrooster01

Win 7 64 bit home premium
 
 

I have marked it solved?
My System SpecsSystem Spec
Reply

 Links not working for videos, etc.




Thread Tools




Similar help and support threads
Thread Forum
Browser links not working
Having a problem with IE and Firefox in Windows 7(on a different computer) .........they both work properly after switching off and back on for a while but then links will not open in either browser. I have refreshed Firefox and reset IE to defaults but makes no difference. Tried resetting the...
Browsers & Mail
Youtube Links/videos not working.. Plz help...
Some videos in Youtube cant be opened in chrome and IE....When ever I try to open those links, a blank page with link address appears... Why is it so? Im using the latest version of chrome and IE. My plugins are updated too... Help... :)
Browsers & Mail
Programme links not working
The images of all desktop shortcuts have disappeared and are not working a long with all of the programme links in the start menu. An error message did appear when originally clicking on a link but now only asks me to 'Choose the programme you want to use to open this file'. I have read forums...
General Discussion
My Music, My Pictures and My Videos links not showing up on Start Menu
As the title states, I cannot get my music, pictures and videos links to show up on the right side of my start menu. I have used all of Brink's tutorials and or registry hacks and double checked everything...but to no resolve. Any one have other suggestions. Cisco C.
Customization
posting links to videos?
Is that ok here?
Chillout Room


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:17.
Twitter Facebook Google+