Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Winsxs again ! ( The usual fix dont work)

09 Mar 2018   #1
rihtt

windows 7 Professional x64
 
 
Winsxs again ! ( The usual fix dont work)

Hello.... I am disappointed that Microsoft cant sort this out.
For a couple years ago, we all remember the "winsxs" bug.


(Lots of storage GB of the drive used by WinSxS)

Clean Up the WinSxS Folder | Microsoft Docs


Breaking News! Reduce the size of the WinSxS Directory and Free up Disk Space with a New Update for Windows 7 SP1 Clients | Ask Premier Field Engineering (PFE) Platforms

Back then, I read lots of deep-knowledge about this issue when the usual fixes didnt work.
So this problem can be a nightmare and If you have a 120GB SSD drive and suddenly
the winsxs-folder takes 20GB of that! Also after successful clean the problem could return, because of pending updates-job and you had to do it all over (!)


Briefly some things that seems to help, in most cases:
*Run the disk-cleanup tool
*cleanmgr.exe and select systemcopies etc
*bla bla dont work
*net stop WUA service
*delete contents of C:\Windows\SoftwareDistribution\Downloads
*net starting WUA

*Installing the so-called "Fix" for this kb/2852386
*Edit registry for a tweak to NEVER pick this up again.


But Now 2018-03-xx its back in one of my WINDOWS7 machines!


~16 GB storage in the winsxs folder, this preventing me of using the computer and storage
a onedrive sync I am also paying for



Yesterday I tried following:



Code:
C:\Windows\system32>dism /online /cleanup-image

DISM-verktyget (Deployment Image Servicing and Management)
Version: 6.1.7600.16385

Avbildningsversion: 6.1.7601.18489


Fel: 87

Det uppstod ett fel när kommandot skulle behandlas.
Kontrollera att kommandoradsargumenten är giltiga. Mer information finns i loggf
ilen.

DISM-loggfilen finns i C:\Windows\Logs\DISM\dism.log

C:\Windows\system32>dism /online

DISM-verktyget (Deployment Image Servicing and Management)
Version: 6.1.7600.16385


Fel: 1639

Kommandoraden saknar ett obligatoriskt underhållskommando.
Mer information får du genom att köra DISM.exe /Online /?.

DISM-loggfilen finns i C:\Windows\Logs\DISM\dism.log

C:\Windows\system32>dism /online /?

DISM-verktyget (Deployment Image Servicing and Management)
Version: 6.1.7600.16385

Avbildningsversion: 6.1.7601.18489





C:\Windows\system32>dism /online /cleanup-image /analyzecomponentstore

DISM-verktyget (Deployment Image Servicing and Management)
Version: 6.1.7600.16385

Avbildningsversion: 6.1.7601.18489


Fel: 87

Alternativet analyzecomponentstore känns inte igen i det här sammanhanget.
Mer information finns i hjälpen.

DISM-loggfilen finns i C:\Windows\Logs\DISM\dism.log
(Swedish) But results speaks for themself:

Error 87

Error 1639

I also did this again booted safe-mode with command prompt.


My System SpecsSystem Spec
.
19 Jun 2018   #2
rihtt

windows 7 Professional x64
 
 

So... The only fix, is a complete reinstallation of the system ?

I cant see no other solution than to install win7.
All again.
My System SpecsSystem Spec
19 Jun 2018   #3
Megahertz07

Windows 7 HP 64
 
 

My C:\Windows\winsxs is around 10G.
How much free space is on your C: drive?
My System SpecsSystem Spec
.

19 Jun 2018   #4
SIW2

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

My System SpecsSystem Spec
Reply

 Winsxs again ! ( The usual fix dont work)




Thread Tools




Similar help and support threads
Thread Forum
Downloads Work Offline But Once Website Is Live they Dont Work
I have recently built a new website, i tried all links and they worked fine before making it live on Filezilla. I was wondering if anyone knows the reason for it or even better the fix for the solution. The files are DWG. which is a version of CAD. PDF's, Jpegs, ect. all work except DWG's. ...
General Discussion
5TB drive seen as only 560GB - usual fixes don't work
I have a Dell XPS 8300 desktop, Windows 7/64, 12gb RAM. Boot drive is a 500GB SSD, and there's a 2TB SATA drive for data. I'm a photographer, so I need lots of data storage. I just purchased a Toshiba MD04ACA500 5TB to use as a data drive (NOT boot). My XPS 8300 can see the drive but insists...
Hardware & Devices
Black Screen after login, explorer.exe faulty, usual fixes dont work
Hi! I'm not sure this is the right section, but since a Virus started it all, I figured it is. Short story: -got Virus, got rid of it (probably) -used ccleaner to "clean" registry, which screwed it up (probably) -now get blackscreen after login, explorer.exe doesn't start and crashes 5...
System Security
Can't turn off transparency.The usual settings to change it don't work
Hi. I've read lots and used lots from this forum - thanks! - but first time posting here. I've searched, but haven't found a similar issue to this. My issue: I was using Aero with no problem. I had customized it a little, but only basic things through the Personalize section of Control...
General Discussion
Needs elevation (the usual fix doesn't work)
On a Win7 ultimate system (svc pack 1), when I try to open any file in the my documents folder I get an error message that says that this operation "needs elevation". So I picked one particular file that I couldn't open and I looked at the owner in the security tab. Indeed the owner was not set...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 08:24.
Twitter Facebook Google+