Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Registry Backup Gone Wrong Wrong Wrong

02 Sep 2018   #1
tidybear12

Windows 7 Home x64
 
 
Registry Backup Gone Wrong Wrong Wrong

I am still looking to fix the internet access problem (now Day 3!!!) that I posted about elsewhere on the forum. (Connected to network but no internet access.)


So I read that the problem with being blocked (Access Denied) from starting Wwan Autoconfig might be caused by a corrupted file in the registry.


I also read that before making any changes (and actually, before any problems, it's brilliant to back up the registry - how I wish I had done that!) you should backup your registry.


So, dear friends, in the process of backing up the registry something went wrong. It seemed like such a straightforward process but for people like me (any other ADD'ers on this forum?) the simplest first 1 then 2 then 3 can be fraught with difficulty. (Not listening to "This American Life" through my headphones might have helped too. 😔)


I SHOULD have followed these instructions from Microsoft support:


Back up the registry manually
  1. Click Start, type regedit.exe in the search box, and then press Enter. If you're prompted for an administrator password or for confirmation, type the password or provide confirmation.
  2. In Registry Editor, locate and click the registry key or subkey that you want to back up.
  3. Click File > Export.
  4. In the Export Registry File dialog box, select the location to which you want to save the backup copy, and then type a name for the backup file in the File name field.
  5. Click Save.


Instead I went to my favorite site Lifewire💕 to follow what they say and that's were things became a little confusing.


  1. I wanted a copy of the entire registry, just in case. But instead of following the exact and lengthy instructions I exported each key separately into a folder I had created in Public Documents so I have access to it from everywhere. (Proud of myself I thought of that.)
  2. I ASSUMED I had made a COPY, not exported the keys. Even though it said of course "Export." On the other hand, this process is called a BACKUP, so by definition that should mean it's a copy, right? When you backup your hard drive for example your are not exporting your hard drive to another location. I mean, how was I supposed to know it's any different with the registry?


After all this was done I went back to the registry to have a look and that's when I realized I had screwed up big time.


There is now the root key, all the folders are tight there in alphabetical order like before but without any possibility to go any higher in the hierarchy. The very first folder has a *. That's it. There is nothing else, and why this wasn't also "exported" if that's what I did, I don't understand. The root key is the very first one I copied or exported since I went in order, and it is in the appropriate Documents folder.


What gives? I'm stunned and completely paralyzed, afraid to go anything on this machine. Is it going to crash now?


Please help the resident idiot!!!😳😰






My System SpecsSystem Spec
.
02 Sep 2018   #2
tidybear12

Windows 7 Home x64
 
 

Quick update! It's all good! I feel foolish now. After posting the above I scrolled to the end of the key files, and the other folder keys were there as well, and when I scrolled up again I could see Computer again, so, phew. (Feeling foolish now but my sense of relief surpasses that. Lol! And yippeee!

Now I still have to "fix" the Wwan Autoconfig file.��
My System SpecsSystem Spec
Reply

 Registry Backup Gone Wrong Wrong Wrong




Thread Tools




Similar help and support threads
Thread Forum
Backup will not run, gives error 0x80070057 - wrong parameter
:( For the last two days I've been trying to find a solution to no avail. Backup has been running every night without issue for a long time. I tried the Microsoft support checking the decimal point and adding the entry CopyFileBufferedSynchronousIo in the registry...
Backup and Restore
MS Paint GUI wrong- Perhaps stuck in wrong mode- Example shown
Last night, My MS Paint GUI went screwy. It looks like it is out of Aero mode or something, but Aero troubleshooter found no problem & everything else is fine. I was having an issue with a video game for PC (full screen) which normally fiddles with the Windows theme, but I honestly dont know. ...
General Discussion
moved a program, its files opened wrong, editing registry didn't help.
I had a program in a subfolder on my desktop, and I had set it as the default program for opening .PK3 and .WAD files, and then, like a total idiot, I moved the program to a different folder. The next time I tried to open a PK3, the "open with..." dialog box came up. I browsed for the new location...
General Discussion
Windows 7 Backup identifies wrong drive as a system drive
This is a silly problem to be having. I have two operating systems in a dual boot system. Windows 7 Home Premium 32 bit, C drive, (where I am trying to run the backup from) and Windows Vista Ultimate 64 bit (I drive). It used to work fine, I think round about 4 weeks ago or so. I am not sure...
Backup and Restore
Registry Permissions... wrong?
Not sure this is the right subforum... but it doesn't seem to fit anywhere. Sorry if its the wrong place. I recently (few days ago) did a fresh install of Windows 7, and today I installed PowerISO which required a reboot... rebooted, and everything was, well, weird. For example: -Wireless...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:17.
Twitter Facebook