Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No Audio or Power Services after ArcGIS Update

10 Dec 2018   #1
khaos526

Windows 7 - 64 Bit
 
 
No Audio or Power Services after ArcGIS Update

Recently had an ArcGIS update and IT thinks this may have been what caused the issue (except it is fine with everyone else's computer here at work).

Looking more into it, I realized in Services that the Windows Audio Endpoint is disable. Looking that error up pointed me to the Power service being disabled.

I am unable to access the Power Options from the Control panel as nothing happens when I click on it.

I have tried to run the powercfg - restoredefaultschemes as admin to see if that would fix the issue, and that didn't help. Also tried to do a repair on the start up without any success as it wanted to start on the D drive which I don't have. Also tried to add quotation marks around the Power in the Registry under ImagePath from %SystemRoot%\system32\svchost.exe -k DcomLaunch to "%SystemRoot%\system32\svchost.exe -k DcomLaunch" which also didn't do anything.

The main error with the Power Service is the Power Failed to Read Description: Error Code 1006, and I checked for the "common" folder in or Program Files and for "Program" folder in my C: drive and nothing.

I finally tried to run as admin the Power in services and switched it from Automatic to disabled and applied it and then back to Automatic and didn't solve anything. Starting the service using the Start button in Services came back with the Windows could not start the power service. Error Code 193: 0xC1.

Finally I had recently found another thing I could try to run that checked drivers and startup files and such, but can't for the life of me find it anymore or what the command to run was. Anyways, just trying to think of something else before IT says we should just re-install windows which I would like to avoid like the plague if possible.

So anything else I should try? Oh and trying the sound in Safe mode didn't do anything either...

Thanks


My System SpecsSystem Spec
.
10 Dec 2018   #2
F22 Simpilot

Windows 7 Ultimate x64
 
 

Have you checked group policy to see if the Power policy was disabled there? You can get to group policy with the command gpedit.msc in search. I'd run it as Admin.


I'd think restoring the default schemes would accomplish that though, but you never know.

You said you did an in place repair install? Like the one outlined here: Repair Install

You checked for common, but I wonder if it's hidden? Go to Folder Options and show hidden files and protected files.

I don't see a dependency for Power, so that's probably not it. Odd because you'd think there was one.

Does this help: Error 193 0xc1 when trying to start Windows Audio Endpoint Builder and - Microsoft Community
My System SpecsSystem Spec
10 Dec 2018   #3
F22 Simpilot

Windows 7 Ultimate x64
 
 

A great tool to check all the crap that starts up at boot is Autoruns. Autoruns for Windows - Windows Sysinternals | Microsoft Docs

The fact sound still won't work in safe mode tells me it's a service issue, not a driver issue. Come to think of it, sound won't even work in safe mode! *slaps forehead* The driver wouldn't be loaded. But! You can try enabling the Power service in safe mode and see what happens. I'm not sure if safe mode will let you, but if it does work, you can probably blame a driver.
My System SpecsSystem Spec
.

11 Dec 2018   #4
khaos526

Windows 7 - 64 Bit
 
 

Ok so haven't tried your second post yet as I need to get some time to read up on it, but here's the results from your first one:

Group Policy - Ran this as Admin, did notice in Computer Configuration/Administrative Templates/System/Power Management there was the "Select an Active Power Plan" which was not configured. So I changed this to "Enabled" and selected "Automatic" which is kind of how it it should be under services.msc. Re-booted, no luck.

Repair Install - IT came over for this and we didn't actually run it with the disk, so that would be something we would need to do. I like the pros and cons from the weblink you showed. I think this might be the next best step before reinstalling

Common Folder - Yes I have always have "Show Hidden and Protected Files" on my Explorer, so only thing that shows up is "Common Files" which I think is normal from what I researched

Error 193 0xC1 link - Looked at this and the results were the same in Services.msc as they were in the registry.

Multi Media was:
C:\Windows\system32\svchost.exe -k netsvcs (Services.msc)
%SystemRoot%\system32\svchost.exe -k netsvcs (Regedit)

AudioEndPointBuilder
C:\Windows\System32\svchost.exe -k LocalSystemNetworkRestricted (Services.msc)
%SystemRoot%\System32\svchost.exe -k LocalSystemNetworkRestricted (Regedit)

Though it's kind of weird with the endpoint saying "LocalSystemNetworkRestricted", but Power Managment still won't activate anyways so that might be why.

Thanks for your suggestions by the way, at least it's giving me something more to test out...
My System SpecsSystem Spec
11 Dec 2018   #5
khaos526

Windows 7 - 64 Bit
 
 

Update, ran the Autoruns for Windows and found the "Power" part (took awhile). It links to the umpo.dll. Which it couldn't seem to find. Checking in my System32, I do have the umpo.dll but it is 0k (though has a modified date of 2014). Checked my coworkers and he has the umpo.dll with 160k And a date of 2013.

I think this is the problem as looking up the umpo.dll it is what is related to the Power Service and policy and such (https://www.win7dll.info/umpo_dll.html). Need to wait for IT to check into this, but this could very well be the cause. Also PlaySndSrv.dll and wlancfg.dll are also shown with 0k.

Hopefully this fixes it and saves me a whole lot of headaches with re-installing. Not sure if one can just copy my coworkers dll over or not, but I'll leave that to IT to figure out. Will report back on what happens...
My System SpecsSystem Spec
11 Dec 2018   #6
F22 Simpilot

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by khaos526 View Post
Will report back on what happens...

Please do and if it fixes your issue mark this topic solved.

As a side note, when I'm trying to find some file buried in the great Windows and beyond, I use Everything.exe by Void Tools. It will show matches whether the file is hidden or not and whether you have show hidden files on or not. Great little tool and fast. Using this you can effectively turn off indexing.


Well, their website isn't working for me so I have to share a damn cached page. Other sites do have it, but upload it to virus total and make sure it's not laced with crap.

Downloads - voidtools
My System SpecsSystem Spec
12 Dec 2018   #7
khaos526

Windows 7 - 64 Bit
 
 

Ok will look at that. So IT and I ran the SFC /scannow as admin and that fixed the umpo.dll issue, but didn't fix the PlaySndSrv.dll or the wlancfg.dll if those are in fact related at all.

Booted up after and found that Power in the Services no longer shows <Failed...> in the Description and seems to work, however, it showing it's status as "Stopped".

Running in Admin to start it, comes up now with the:
Code:
Windows cannot start the Power Service on Local Computer
Error 2: The system cannot find the file specified.
Running the Windows Audio Endpoint Builder, I get the:
Code:
Error 1722: RPC Server is unavailable 
The Remote Procedure Call in Services looks find and states it's started and it's dependencies seem fine.

The only thing I'm noticing different on my coworkers computer in his Services, is the on his Log On tab for Windows Audio. Mine is currently set to "Local System Account, Allow service to interact with desktop is checked, and his has "This Account" checked instead. That though requires the IT admin password, so haven't mentioned that to them yet, but I don't know if this would fix the issue that the Power still states "stopped" and I can't restart it with the error mentioned above.

I'll try the void tools though and just check if there's something I'm missing, though as you said that's good for finding things if you already know what you're looking for.

Thanks for trying though, but at least it's one step closer right now...
My System SpecsSystem Spec
12 Dec 2018   #8
khaos526

Windows 7 - 64 Bit
 
 

Update:
Fixed the issue with the Power Services not Started. Turns out in the registry that there were quotes around the Image Page. Once removed, it started that service.

It now also states that the Windows Audio Endpoint Builder has now started too, but that Windows Audio has stopped

No sound as usual, but maybe it has to do with those other two dll's that are 0k and the Log On for the Windows Audio to be "This Account"?

Just looked in Admin for the Windows Audio and tried to start it, and got this:
Code:
Windows Audio cannot start on Local Machine (or something like that)
Error 1079: The account specified for this service is different than the account specified for other services running the same process
So will get IT to use their Admin password as I was thinking in the above post and with the other two dll's (related or not), hopefully this solves the issue.

Of course it's Christmas and IT is swamped, so not sure how long it will take them to add those two other dll's from a compatible machine and be able to change the Log On for the Windows Audio, but will update this when I get that taken care of...
My System SpecsSystem Spec
12 Dec 2018   #9
F22 Simpilot

Windows 7 Ultimate x64
 
 

It looks like a permission issue with the audio service for some reason.

How on earth did all this happen? You just installed that mapping program and all of a sudden everything went South?
My System SpecsSystem Spec
13 Dec 2018   #10
khaos526

Windows 7 - 64 Bit
 
 

Well I didn't install it, our GIS team did, but this is what IT thinks happened. After it was installed (I went home during it), the next day everything was fine actually. Windows pop up came up reminding me my password was about to expire (which I knew was coming and kept ignoring it). So I figured might as well change it and instead of just Crtl-Alt-Del to change the password, I clicked on the popup which sent me to the password screen. Then after doing that, I came back in and suddenly I had some memory errors. Figured I'd reboot and that's when it all happened.

First thing was do a virus scan, we have our work one that sets off, but I manually did Malware Bytes and also re-set off our service one just in case. Nothing came back.

It was also noticed my computer was missing a number of updates too (probably because I kept forgetting to log off and instead logged out only). So could have been a combination of these 3 things that caused the failure.

Hopefully I can get the permission re-instated soon and I'll let you know what happens. But so far with the Windows Audio Endpoint Service now started, Power started and for the first time I'm able to actually open the Power Options settings in the control panel, it looks like we're near the end of this frustration.

Thanks all to you and your suggestion of using the Autoruns as I never thought of looking in the System32 for 0k files at all...
My System SpecsSystem Spec
Reply

 No Audio or Power Services after ArcGIS Update




Thread Tools




Similar help and support threads
Thread Forum
Windows Audio is not listed in the services and I NO HAVE AU
For the last 10 hours CONSECUTIVELY I've been downoading multiple dirvers from windows, realtek, and ASUS (Motherboard Provider) and absolutely nothing is working. When listed in the Services there is nothing saying, "Windows Audio", the first one is Windows Backup. Can someone please help me fix...
Drivers
Services Needed For Windows Audio To Run?
I was trying to optimize my W7 Pro 64 bit machine for music, according to a guide put out by Sweetwater. One of the steps is to disable all services (after first hiding all the MS ones). After doing all the steps, I lost my Windows Audio Service. I figured out that I need to enable Windows Audio...
Sound & Audio
Audio services does not respond
I have a dell Nspiron 5110 and my audio has been working fine untill lately it completly stopped working the small sound icon in the taskbar is working and volume is maxed but there is no sound at all when I ran the diagnostics it said that "audio services does not respond"...
Sound & Audio
1 or more audio services not running
I went to trouble shooter and when prompted I attempted to start them. The attempt failed. I am lost. I have Windows 7 Ultimate 32bit:sick:
Sound & Audio
Random BSOD first started after uninstalling/installing Arcgis
Please help. I get random BSOD in Windows every few minutes. First started after unistalling Arcgis 9.4 and installing Arcgis 10.1 through daemon tools lite. I already removed Arcgis, tried to update all my drivers, ran memtest overnight (6 passes, no errors), uninstalled Avast and Daemon tools...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:09.
Twitter Facebook