Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Folder icons aren't recognizing when folders have files in them

07 Jan 2019   #1
ymwing

Windows 7 Home Premium 64bit
 
 
Folder icons aren't recognizing when folders have files in them

I noticed recently that when I make a new folder and put stuff in it, the folder icon doesn't change from the one that signifies that the folder is empty, i.e. new folders I make always have that single empty folder icon. I can still use Windows File Explorer like normal—I can open all the folders and access everything normally—but I was wondering why this small visual feature wouldn't work, and I can't find a solution anywhere.

Folders that I had already made before the issue retain their icons showing me what kind of file is inside, but if I add another file inside the old folder, it then changes the folder icon to the empty one, and I can't seem to convert it back.

If I right click a folder and go to Properties > Customize > Choose File (to show on this folder icon), nothing shows up to select even if there are files within the folder. Inner folders might show up, but going into those inner folders reveals none of their files.

Even when I make a folder with nothing but other folders in it, the outer folder's icon won't change (it used to show the original icon but with an extra folder inside of it).

It seems like Explorer or whatever manages the default icons isn't recognizing when folders have things in them. Anyone encounter this before?


P.S. I have already tried pretty much everything I found on Google when I typed different abridged versions of my title for this thread, but the issue behind all of the fixes I found seemed to be that users couldn't see icons at all, or all their icons were blank.


My System SpecsSystem Spec
.
07 Jan 2019   #2
Brink

64-bit Windows 10 Pro
 
 

Hello ymwing, and welcome to Seven Forums.

Here's a list of things to check to see if they may help:

1) Refresh (F5) the window the folder is in to see if that may update its icon.

2) Make sure thumbnail previews is enabled.

Thumbnail Previews - Enable or Disable

3) Clear and reset the thumbnail cache in case it may be corrupted.

Thumbnail Cache - Clear and Reset
My System SpecsSystem Spec
07 Jan 2019   #3
ymwing

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by Brink View Post
Hello ymwing, and welcome to Seven Forums.

Here's a list of things to check to see if they may help:

1) Refresh (F5) the window the folder is in to see if that may update its icon.

2) Make sure thumbnail previews is enabled.

Thumbnail Previews - Enable or Disable

3) Clear and reset the thumbnail cache in case it may be corrupted.

Thumbnail Cache - Clear and Reset

1) and 3) I have tried to no avail. With 2), I tried options 1-3 and nothing, but I was wondering about option 4. Since I only have Home Premium, do you think I would be able to do something similar in the registry? If so, would it even work?


Thanks
My System SpecsSystem Spec
.

07 Jan 2019   #4
Brink

64-bit Windows 10 Pro
 
 

Option 4 wouldn't apply to you for this issue, so no need to worry about it.

You might also see if rebuilding the icon cache may help in case it is corrupted.

Icon Cache - Rebuild
My System SpecsSystem Spec
07 Jan 2019   #5
ymwing

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by Brink View Post
Option 4 wouldn't apply to you for this issue, so no need to worry about it.

You might also see if rebuilding the icon cache may help in case it is corrupted.

Icon Cache - Rebuild
Option one didn't fix it. For option two, the first time I tried, it was able to find the first directory ("%localappdata%\IconCache.db"), but not the second one, "%localappdata%\Microsoft\Windows\Explorer\iconcache*". I tried again after restarting and then it couldn't find either of them.
My System SpecsSystem Spec
07 Jan 2019   #6
Brink

64-bit Windows 10 Pro
 
 

That would be normal if it had already been deleted. No worries.
My System SpecsSystem Spec
07 Jan 2019   #7
ymwing

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by Brink View Post
That would be normal if it had already been deleted. No worries.

Well, thanks for the quick replies. Any other ideas? It's such a minor issue, yet it's driving me insane
My System SpecsSystem Spec
07 Jan 2019   #8
Brink

64-bit Windows 10 Pro
 
 

I suppose if this has just recently started, you could try doing a system restore using a restore point dated before this started to hopefully fix it.
My System SpecsSystem Spec
07 Jan 2019   #9
ymwing

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by Brink View Post
I suppose if this has just recently started, you could try doing a system restore using a restore point dated before this started to hopefully fix it.

That worked. Not sure what the hell was going on, but thanks.
My System SpecsSystem Spec
07 Jan 2019   #10
Brink

64-bit Windows 10 Pro
 
 

Great news. You're most welcome.
My System SpecsSystem Spec
Reply

 Folder icons aren't recognizing when folders have files in them




Thread Tools




Similar help and support threads
Thread Forum
Start Menu - All Programs - Custom Folder Icons For Selected Folders
This is out of control, I have been trying to setup a Windows 7 system to my liking and every time I am able to put out a fire, 3 or 4 more pop up to deal with :cry: I followed the following tutorial below which works great, my default folder icons are now custom in Windows Explorer and my Open...
General Discussion
New files aren't shared in shared folder
Hello everyone, I'm using a laptop (with Windows 7 Home Premium 64-bit installed) as a DVR and media streamer to all other devices in the house. My TV recordings are recorded into a temporary folder and when the recording is finished the program moves the files into the My Videos folder. ...
Network & Sharing
Windows says folders are empty when they aren't
I'm having a very strange issue after I did a boot time virus scan in Avast to remove a virus. Avast seems to have removed the virus just fine, however I can't get Windows to show directories or files any more. If I open Windows Explorer and go to C:\Users it says the folder is empty....
General Discussion
Locked folders aren't
Hello, I have folders in My Documents which I have chosen to lock so they are not shared on the network, but when I browse to my computer from another computer on the network, the locked files are present and accessible. I'm pretty sure there's another way to lock folders from being shared on...
Network & Sharing
Desktop Icons Aren't Working :(
I have W7 Home Premium and my desktop icons aren't working. I have to reboot to get them to work :( I use Microsoft Essentials for Virus Protection not Norton. Any assistance in solving this problem appreciated thanks Dorothy
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 17:56.
Twitter Facebook Google+