Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't use 'desktop' or gadgets

28 Feb 2009   #1

Windows 7 x64 & Ubuntu 9.04 x64
Can't use 'desktop' or gadgets

I posted in another thread but i think maybe my problem is different.

I had a BSOD and rebooted etc. Since then i have no gadgets nor can i display any shortcuts on the desktop or any files. Previously i could.

I ran a scan of my disk and it reported back no errors.

I disabled/rebooted/enabled/rebooted gadgets to try and get them to work, but to no avail.

If i drag a gadget to the desktop nothing happens. The same if i try to drag a file or make a shortcut.

Is this an easy thing to rectify? Or do i have to reinstall?


Strangely just had to right click desktop and choose 'Show Desktop items'. No idea how this was unchecked in the first place, but hey! If you have a similar error, try the simple things first!

My System SpecsSystem Spec
29 Jan 2010   #2

windows 7

Thanks for the update, that solved my problem as well.
My System SpecsSystem Spec

 Can't use 'desktop' or gadgets

Thread Tools

Similar help and support threads
Thread Forum
Win 7 Desktop Gadgets ?
Are widows seven desktop gadgets still considered a security threat - is there a recommended alternate (mostly clock) for them is security issues are still there ? Thanks....TRinAz
Desktop gadgets
Does anyone know were to get more desktop gadgets? I'm not sure were to look.
Gadgets on Desktop
Hi Forum, I placed the Clock gadget on my desktop recently but it does not appear to remain there very long. When I re-start the Laptop it has often gone "walkabout". Is there any way that the gadget can be placed there permanently and what must I...
Desktop Gadgets
My desktop gadgets were working fine until now I cant even change the settings i.e. when I click on the link to change desktop gadgets absolutely nothing happens. However, I can close already installed gadgets, but of course cant get them back now. Any one else had a similar problem?

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:19.
Twitter Facebook Google+