Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Something strange has just happened to my keyboard

23 Dec 2009   #1
Tommyd

Windows 7 Home Premium x64(desktop), Windows 7 Professional x86(laptop)
 
 
Something strange has just happened to my keyboard

I was typing a post on another forum, when I left the keyboard for a few minutes to see how much snow had fallen in the last hour, and when I cam back, I tried to type a pound symbol(), so I pressed shift+3, and got a hash instead of .
All letter keys work perfectly, as far as I can see, it is only the 2 and 3 keys which dont work.
2 gives me the @ symbol, whilst pressing the @ key gives me ".
3 gives me #, whilst pressing that key gives me \, shift pressing the # key gives me |.
What has just happened?
The keyboard is part of a keyboard/mouse set, the Microsoft Wireless Optical Desktop 700 v2, and I am running Win 7 Home Premium x64.


My System SpecsSystem Spec
.
23 Dec 2009   #2
jfar

Vista Ult64, Win7600
 
 

You are using the US keyboard. Type into the Start Menu, Keyboard / and then change Keyboard.

Something strange has just happened to my keyboard-k.png

Something strange has just happened to my keyboard-capturkk.png


My System SpecsSystem Spec
23 Dec 2009   #3
Tommyd

Windows 7 Home Premium x64(desktop), Windows 7 Professional x86(laptop)
 
 

I have solved it, and that wasn't the cause, I checked about five times.
The cause was that I had, at some point during the day, pressed ALT+Left Shift, which switches the keyboard layout, despitre the only layout shown in the second screenshot you posted being United Kingdom.
Pressing ALT+Left Shift again solved the issue.
My System SpecsSystem Spec
.

23 Dec 2009   #4
TaraSWinTeam

Windows 7
 
 

To change your keyboard follow these quick directions: Add or change an input language.

Tara
My System SpecsSystem Spec
23 Dec 2009   #5
jfar

Vista Ult64, Win7600
 
 

Well don't mention it , I am glad you have got it fixed.
My System SpecsSystem Spec
Reply

 Something strange has just happened to my keyboard




Thread Tools




Similar help and support threads
Thread Forum
Strange BSOD that happened in my sleep.
I'm sorry for the weird title but I was showing a friend something on my laptop and put it down on the table. Maybe an hour or two later I noticed the computer was on the table and turned off. During this period me and some friends got into something and I lost track of time. When I turned my...
BSOD Help and Support
Very Strange Keyboard Issue
Salutations SevenForums People. This week I started using a new PC with Win7 Ultimate. There is something wrong with the way my keyboard responds in all first person shooter games. The move forward key stops working when I hit other keys. For example, when I hold the move-forward key down my...
Hardware & Devices
Strange problem with keyboard
Hello. Each time i try to press on shift and ' , instead of instantly appearing ", it does not appear anything. Only after i press another button, the symbol " appears. Same if i just press ' , i must press another button to make ' to appear. This thing occured after i reinstalled windows. Hope...
Hardware & Devices
strange keyboard problems
i recently bought a new keyboard for my computer and its been working fine for a little over a week now but today it started acting really strange. I went to try to go to a website and after i typed the address i pressed the enter key to go to the address wanted but after i pressed enter it showed...
Hardware & Devices
Strange keyboard behavior
Hello, I have installed Vista and Windows 7 in dual boot. My keyboard is acting strange only in Windows 7. i tried usb and ps/2 keyboards and both are acting strange only in Windows 7. While you type, there is some sort of lag, and if you type some word fast if lag happens, the word is typed in...
Hardware & Devices
(System Restore) Something very strange happened...
Can anybody explain this: For a reason I had to do System Restore. It worked and told me my system was restored to a restore point I had chosen. Reboot, everything seemed fine. Logon screen, my password, and then the usual Welcome-screen which normally lasts only a couple of seconds before...
Backup and Restore


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:37.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App