Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Always getting "The file name is not valid"

28 Dec 2009   #1
MoeAlza

Windows 7 Ultimate
 
 
Always getting "The file name is not valid"

I just upgraded my Windows Vista 64x to Windows 7 Ultimate 64x.

Everything went smoothly. I installed all the programs I use but I now receive "The file name is not valid" error when ever I try to save something. Whether it is a notepad file I am trying to save or an image in PhotoShop I always get "The file name is not valid".

I did run some secuirty software including IObit Secuirty 360, Glary Utilities, Advanced System Care, and a few others so I am not sure if they altered the system files or not. I used them before on Windows Vista and I never had this problem before.

Please help.


My System SpecsSystem Spec
.
28 Dec 2009   #2
garysgold

Vista Ult 64 bit Seven Ult RTM x64
 
 

Hello MoeAlza,

Welcome to 7 Forums.

You could try this. System Restore

Hope this helps.

Gary
My System SpecsSystem Spec
28 Dec 2009   #3
MoeAlza

Windows 7 Ultimate
 
 

If I was to do that I would have to reinstall some programs and updates, isnt there another way?
My System SpecsSystem Spec
.

28 Dec 2009   #4
raf051888

Windows 7 64-bit
 
 

Did you do an upgrade or actual clean install?
My System SpecsSystem Spec
28 Dec 2009   #5
MoeAlza

Windows 7 Ultimate
 
 

Upgraded from Vista, But I re-installed Vista from factory settings right before so I would have a "clean upgrade".
My System SpecsSystem Spec
28 Dec 2009   #6
raf051888

Windows 7 64-bit
 
 

That is more than likely your problem. You may want to try a clean install. I've attached a link that describes how to do a clean install with upgrade media.

Clean Install with a Upgrade Windows 7 Version
My System SpecsSystem Spec
28 Dec 2009   #7
MoeAlza

Windows 7 Ultimate
 
 

In that Clean Install Manual I think I did option two because I also had a "Windows.old" folder but deleted it.
My System SpecsSystem Spec
28 Dec 2009   #8
1Bowtie

Windows 7 Home Premium 64 bit
 
 

Quote   Quote: Originally Posted by MoeAlza View Post
Upgraded from Vista, But I re-installed Vista from factory settings right before so I would have a "clean upgrade".
This looks like your prob, when you re-installed Vista from factory you removed all the assocations with the progams you are haveing trouble with. I think you will have to reassociate the programs.

Smitty
My System SpecsSystem Spec
28 Dec 2009   #9
MoeAlza

Windows 7 Ultimate
 
 

Quote   Quote: Originally Posted by 1Bowtie View Post
Quote   Quote: Originally Posted by MoeAlza View Post
Upgraded from Vista, But I re-installed Vista from factory settings right before so I would have a "clean upgrade".
This looks like your prob, when you re-installed Vista from factory you removed all the assocations with the progams you are haveing trouble with. I think you will have to reassociate the programs.

Smitty
I would understand if photoshop didn't work... but notepad too? notepad was built to work with a fresh install of windows....

But how can I re associate these programs?
My System SpecsSystem Spec
29 Dec 2009   #10
fseal

Windows 7 x64 Ultimate
 
 

That's some random bunch of advice without even trying to find the cause...

Where exactly are you trying to save the file?
What is the path that's having problems? (paste an example)
Does it happen anywhere?
Is it ALL programs or just the two mentioned?

Unfortuantely you have installed a crapload of "security" programs and they all do lowlevel system stuff and probably have not been vetted for W7. In the end a reinstall might be necessary, but maybe it's something to do with how/where your trying to save a file...
My System SpecsSystem Spec
Reply

 Always getting "The file name is not valid"




Thread Tools




Similar help and support threads
Thread Forum
"win boot conf data file does not contain a valid OS entry" oxc0000098
Ok, so I had the "file recovery virus." I was using malwarebytes and Another malware removal program (can't remember that name) to get rid of it. I remember one of them listed a file name with "boot" in it as infected so I deleted it as suggested. Well now I can't boot windows 7 64 bit on my HP...
Installation & Setup
Default "Browse for file" location in web browser "choose file" box
Hi, how can I change this? Some background - this may not be the issue I need to solve at the end of the day: I believe the location is causing crashes, since I blew up lots of Library registry values (in an attempt to remove them from the OS), and I think it defaults to the library page....
Customization
""Local Area Connection" Doesn't have a valid ip config "
i Recently bought and hp windows 7 computer 64 bit and it was fine but two weeks later it does this it was working few hour ago and now it saids this ""Local Area Connection" Doesn't have a valid ip config" what does that mean? i couldnt fix it, i turned off the router, modem did a pc recovery...
Network & Sharing
"Not a valid font file". Huh?
I use both Mac & Windows 7 & want to convert some Mac's dfont to Windows 7 ttf. I straighten out some my earlier permission issues I had with the C:\Windows\fonts folder but now get the dreaded "Not a valid font file" when trying to install the converted fonts. I used Dfontsplitter to do the...
General Discussion
""Local Area Connection" Doesn't have a valid ip config
This is the error I got, and I couldn't connect to the internet. ""Local Area Connection" Doesn't have a valid ip config. It also stated that I had an unknown network, and I couldn't get an IP from the DHCP Server for some reason. I currently have it fixed, somehow. And would really appreciate...
Network & Sharing
Win7 "workstation" to WinXP "server" file copy FAIL
This is driving me bonkers and I have almost no hair left. I really hope someone can help. When I attempt to copy or move a file or folder from my Win7 box to my WinXP (SP3) media server, the operation nearly always fails. Take, for example, my trying to copy the VLC Media Player folder (704...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:53.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App