Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Message every time I open a program

02 Mar 2015   #11

Windows 7 Professional 64bit

One other thing to confirm before one has to resort to turning down UAC settings: Do look to see where the program file you are having trouble with is located on your drive!! That was my problem.

Background: three years ago I upgraded to Windows 7 64bit Professional from an XP computer. I liked the idea of being able to run legacy programs in compatibility mode but had never had a 64bit computer before and I didn't understand why there were both Program Files and Program Files (x86) folders on my c:/ drive. Being used to the old computer and not knowing which to use I did neither and just moved some programs directly into c:/ from an external hard drive using the tried and true cut and paste approach. So for e.g. I had a program file path that looked like this for my Family Tree Maker 16 program: C:/FTW . When I opened that program the first time I got error messages saying that the program was not designed for Windows 7 but pushed thru this till my program finally opened. I assumed that it was just a matter of playing with the compatibility settings (right click icon, click properties, select compatibility tab) to make it run OK and I did that. I still got the annoying "do you want the following program to make changes to this computer?" prompt every time I opened the program but it at least it would open and run so I was satisfied that what I had done was more or less working. I just resigned myself to living with the annoying prompt. It stayed that way for three years. Yesterday, I got fed up and went on line to find a solution and saw this post and others. First I tried playing with the permissions box to make it go away -- no joy.

Then on a whim I decided to clean up my program file lists and recalled that this and other program files were just sitting directly under the C:/ in the path. So I moving them into my Program Files (x86) folder, created a new shortcut icon and went to open the Family Tree Maker to make sure the shortcut was working. Wonder of wonders -- the annoying prompt had finally vanished. All while leaving the User Account Control settings at the recommended level.

For experts I suspect the proper location for the installation of programs is such a 'no brainer" that no one seems to have thought it worth mentioning on any of the forum pages related to this subject -- none I could find anyway. So, at the risk of stating the bleeding obvious I thought I would post my tip in the hopes of helping others who may have done things wrong when they were still learning the ropes of Windows 7 and are getting the annoying prompt.

My System SpecsSystem Spec

 Message every time I open a program

Thread Tools

Similar help and support threads
Thread Forum
Program Problem - Program won't open - No Error Messages
Ahhh back to the experts. I have a rather unusual, 'never happened before', problem. When I click on one particular shortcut either on the desktop or elsewhere it flashes real quick on the screen but does not open. The program is Webroot Window Washer which is no longer available nor is support....
Can't copy or move files - error message "open in other program"
When moving or renaming files I frequently get an error messages informing me that "The action can't be completed because the folder or a file in it is open in another program". This typically happens with the second or third folder I try to rename or move. Navigating away to another folder and...
General Discussion
Open With message. What's this all about
I was greeted with this message on boot up this morning. I never got it before. I tried a reboot and got the same message. Since it is so non specific I have no idea what to click on. I am so grateful for you experts on this forum whom I am sure can end this problem. I don't have a clue. ...
General Discussion
many program I cant open Only Run as Administrator I open the program
many program I cant open Only Run as Administrator I open the program how to disable Run as Administrator I want to open a double click program
'Open with' every time I try to open a program
So I've spent a while browsing and can't find anything related to the problem I'm having. My girlfriend recently lent me her laptop (Win7 32bit) it was still using IE so when I go to install chrome the built in 'security program' (Win7 internet security 2011 or something like that) tells me that...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:19.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App