Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: ICO. File Problem

08 Jan 2010   #1
Macropus

Windows 7
 
 
ICO. File Problem

Hi,

I'm currently running Windows 7 and I have an interesting problem.

I have recently created a file called dog.ico and when I did I used a picture of a black dog.

I then decided, a white dog would be better so I deleted dog.ico and created a new dog.ico of a white dog.

However, whenever I go to view the picture in explorer as a thumbnail, it always defaults back to the black dog. That is it shows a preview picture of the black dog. It is the same whenever I copy the white dog file, it automatically becomes the black dog. When I open the file it is the white dog but the preview of the icon is incorrect.

I'm thinking this has something to do with the registries. Does anybody have a solution to how I can fix this preview though so it is correct? I would like the preview icon to represent what the file actually is.

Any help would be greatly appreciated.

Kind regards,

Macropus


My System SpecsSystem Spec
.
08 Jan 2010   #2
Crispy

Windows 7 Ultimate x64 Service Pack 1 (Build 6.1.7601)
 
 

Hope this helps: File Extension .ICO Details
My System SpecsSystem Spec
08 Jan 2010   #3
Frostmourne

Windows 7 Ultimate x86-64
 
 

Press F5 a couple of times and then reboot.
My System SpecsSystem Spec
.

08 Jan 2010   #4
Brink

64-bit Windows 10 Pro
 
 

Hello Macropus, and welcome to Seven Forums.

You might see if rebuilding the icon cache may be able to fix this for you.

Hope this helps,
Shawn
My System SpecsSystem Spec
08 Jan 2010   #5
Macropus

Windows 7
 
 
ICO. File Problem (Solved)

Hi,

Thank you Crispy, Brink and Frostmourne for all your responses. They are greatly appreciated.

I've tried all three ways and the answer is rebuilding the icon database in the cache. Actually, I literally just did it moments before you posted Shawn but this is the correct answer.

I was also helped out by a very helpful sales representative at Harvey Norman who provided me with documentation on how to achieve this so I'm grateful also for his excellent service.

Thank you again.

Kind regards,

Macropus
My System SpecsSystem Spec
08 Jan 2010   #6
Brink

64-bit Windows 10 Pro
 
 

You're welcome Macropus. We're happy to hear that you got it sorted.
My System SpecsSystem Spec
13 Aug 2011   #7
hieronymous

windows 7 home premium 64 bit
 
 

thanks for that advice, i was using AWIconsLite to create tailor-made icons, and suddenly i could SAVE them but the saved files weren't displaying correctly in explorer (or elsewhere). weirdly they appeared ok when i reloaded them into AWIconsLite, and if i saved the .ico files using a file name that hadn't ever been used before, then they appeared ok in explorer, but if i tried to save them or rename them to a name that HAD been used before then they showed up in explorer as blank icons

your fix seems to have cured the problem




(probably didn't explain any of that very well, but the bottom line is that the fix seemed to work)
My System SpecsSystem Spec
Reply

 ICO. File Problem




Thread Tools




Similar help and support threads
Thread Forum
File problem (I don't know where to put this.)
I need help! I accidentally changed .lnk file into adobe reader. I really really need help because this laptop is not mine and my sister will definitely scold me. :( How can I change it back?
Performance & Maintenance
File problem in WLM
I have loaded my F: drive (data backup) with music files from the C: drive and deleted them form there but I now have the same music tracks doubled up and even tripled up ie track 1/2 /3 /4 etc is listed twice or three times. Now short of working tediously through the listings and deleting the...
Software
Possible File Association Problem or Open With Problem! MAJOR
Apologies if this is not the appropriate catagory but i had trouble finding a suitable one, here is my problem: I was messing about with a file using winrar, (sorry i cant remember which file it was) i right clicked the file and clicked 'open with' i chose winRAR and it screwed up and decided...
Software
Problem with file copying adversely affecting media/file sharing & WMC
WMC recording/playback and media/file sharing seems to work fine until I go to copy a file between drives, where one of those drives is currently using some of its i/o bandwidth to do media. The copy hogs the i/o bandwidth, doing nasty things to the real-time needs. How do I permanently tell...
Performance & Maintenance
Problem Installing, missing file or HD problem?
Hi I hope someone can help me on here - I've tried for about 2 hours to get a copy of windows 7 working on my old pc and really can't see what the problem is when it comes to doing a clean installation. It's not "old' only a year old or so with very good specs but I use another machine now so...
Installation & Setup
WMP 12 - file problem
So, I recently did a clean install of 7048 to replace 7057. All of my mp3 and movie files are stored on a different partition than Windows 7. When I got all of my programs back installed, I attempted to update my library in Windows Media Player. I had to take ownership of the D:\mp3 folder...
Media Center


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:46.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App