Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: How do I UNprotect system folders?

17 Jan 2010   #1

Windows 7 Ultimate x64
How do I UNprotect system folders?

I noticed that Windows 7 likes to hold the user's hand in just about anything more complex than everyday operations; maybe not as much as Vista, but definitely more than XP. Is there any standard way to remove this added layer of "protection"? For instance:

I occasionally make use of 'wiping' programs, but if I try to wipe something in the Program or System folder, I'm unable to. This appears to be due to some overlaying and unremovable "read only" attribute. "unchecking" read only (and propagate to child folders/files) doesn't seem to do the trick.

I did search through the forum and didn't find anything, so I figured I'd ask here for some possible help. Thanks in advance for any help or if anyone has any resources/sites in mind that might explain this better.


My System SpecsSystem Spec
17 Jan 2010   #2

Windows 7 Ultimate 64 bit

Hi toasty,

When I run my cleaning programs as admin (by right clicking and selecting 'Run as an administrator') I have no problems in the locations that you mentioned - With the exception of deleting some drivers from System32 (which makes sense to me anyway).

Another solution may be to change the read only attributes on the folder to be deleted prior to running your cleaning software. I can post a script for this if you wish.
My System SpecsSystem Spec
17 Jan 2010   #3

Windows 7 Ultimate 64 bit

I had another thought overnight about this. There is another method, however it comes with it's own risks of lowering your security. Therefore I am not recommending it, just posting it up as a possible solution for allowing your cleaning program access to those file areas that you mentioned.

The text explanation on the picture comes from the MCTS 70-620 Vista exam; but equally applies to Win7.

To screen print is of the 'Security policy', you can enter it by typing secpol.msc into the run or search dialogues.

Attached Thumbnails
How do I UNprotect system folders?-virtualise-file-registry-write-failure.png  
My System SpecsSystem Spec

23 Jan 2010   #4

Windows 7 Ultimate x64

Thanks for the tips guys. I'm not sure if I'm ready to try modifying the SecPol for W7... although I might end up there eventually. I've done SysAdmin for nearly a decade (couple years retired) so I'm not nervous about doing it, though I am cautious about unintentionally FUBARing my entire system, as Windows is prone to

I tried the other route of modifying the folder properties, both through right-clicking the folder (in this case "c:\Windows") and also through an administrative command prompt [attrib -R "C:\Windows" /S] (remove read-only attribute on folder and all subfolders).

Neither worked. The former spat out a message "An error occurred applying attributes to the file: c:\windows\bfsvc.exe; Access is denied". If I ignore it it goes onto the same message for tons of other files.

The latter command prompt spat out "File not found - C:\Windows".

Also, to address your earlier statement TimStitt, the point that I run into the problem isn't from running a cleaning program itself. But when I use the cleaning program (Heidi's Eraser) to right-click a file in the Windows/Program Files folder and attempt to use the program's context menu to erase the file(s).

I'll keep looking for a solution, there's bound to be something. But if anyone has any other ideas I'd love to know. Personally, I like how Windows XP would let me totally screw up my system if I wanted to
My System SpecsSystem Spec
23 Jan 2010   #5

Windows 7 Ultimate 64 bit

Hi Toasty,

I understand exactly now.

I downloaded a file cleaning program called ERASER and was able to replicate your issue and then solve it. The problem is caused because the context menu is trying to run under different authority than the program itself, which is effectively to run the program as an elevated user as well as a standard user. Win 7 doesn't like this, so you need to keep them all on the same level.

Here's how I fixed it for ERASER.
1. Uninstall the program and Reboot
2. On the set-up file, right click and open properties.
3. On the compatibility tab, make it compatible for XP (SP3) and alter the privilege level for all users to Run as an administrator (then close properties).
4. Double click on the program to run it (you will automatically be prompted to Run as an elevated admin, this is what we want)
5. Install it
6. Once it's installed, don't change the shortcut, just RUN it. You should be prompted automatically to run as admin.
7. Now that you have run the program as an elevated admin, you should be able to right click and ERASE your files (this will follow the set-up defaults and the already open program and run as admin also. Moving forward you don't have to open the main program first, just right click, select the menu and it works.

Well that's what worked for me with one little exception. I am unable to delete shortcuts by right clicking and erasing (unless they are in a folder that I am erasing). Weird but I'm not complaining.

Hope this helps you too.


PS: I am moving my entire house to Singapore as of tomorrow, so I may not be online for a few months (at least, I won't have my Win7 box for a few months). So I'm not being intentionally ride if I don;t get back to you.
My System SpecsSystem Spec

 How do I UNprotect system folders?

Thread Tools

Similar help and support threads
Thread Forum
Trouble moving system folders to 2nd drive... corruption of folders
Hi folks, this is my first time posting here. This looks like the right place for a post like this. I'm pretty knowledgeable. I've been building my own PCs for 20+ years. I've been out of practice for a while, but I did a ton of research when I decided to build two PCs recently. Even back in...
Installation & Setup
Unaccesible shortcuts created by the system in user & system folders
Hello All: Browsing the folders on my hard drive I have found a series of shortcuts (to default users, application data, "archivos de programas" (program files in English language) that I didn't create and that I can neither access nor delete. I have two administrator accounts in the...
General Discussion
post-trojan cleaning, Hidden/System folders no longer hidden/system
Greetings. Win7-64, Home Premium, SP1. I had a trojan infection last night, and successfully cleaned it using Combofix and MBAM, however, this morning I opened Windows Explorer, and noticed that hidden & system folders no longer have their hidden/system attributes, and they are all showing in...
General Discussion
locked system folders
How do i unlock documents and settings folder when logged on with admin account? 7 PRO
Network & Sharing
Moving system folders
In Vista I was able to move all system folders to another drive...Windows recognizing that drive as the default location from then on...I can't remember how I did that. I have read some posts on here about the topic but none of them sound familiar. What's the process for moving the default...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:24.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App