Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: I removed U3 from FD, but it has old name still?

17 Feb 2010   #41
JohnnyScience

Windows 7 64 & Ubuntu 64
 
 

This is really weird, I'm still having the issue of the U3 name, JScience showing up on my computer.

I've tried it on the MAC's at school & my buddy's computer & they both showed up as JohnnyScience

Then I formatted to a Fat32 on my buddy's computer & then reformatted on mine to NTFS with a different letter for the drive & yet still showing up as JScience?

What the hell?


My System SpecsSystem Spec
.
17 Feb 2010   #42
WindowsStar

Windows 7 Enterprise (x64); Windows Server 2008 R2 (x64)
 
 

I was reading this thread and I am glad I remember it or I would not have paid close attention to what was going on with my USB drive.

I don't know if this related but I noticed something the other day. I have a Cruzer 32GB USB drive that I bought new. I put it in my Windows 7 machine and named it and then put files on it and never had an issue. The other day I put the USB drive in a Windows XP Professional machine (I had never used in any other machine or OS) and the name of the drive wasn’t there. I thought that it was weird but no matter what I did the name was not there (i.e. Windows Explorer, Command Prompt, Disk Manager etc.). So without missing a beat I figured it had somehow been erased and I just renamed it on the Windows XP machine. What I did not realize is that I misspelled the name and even after using it for an hour I had not noticed the mistake. The next time I put it in my Windows 7 machine I noticed the name was misspelled so I renamed it. What happened next it what you are experiencing. The name stayed spelled wrong no matter what I did. I took it with me to work found a Windows XP machine and renamed it spelling it correctly. Now the drive is correct on my Windows 7 machine. However a side effect of all of this is now some times on some Windows XP machines the name will not show up at all. It does on my Windows 7 machine and it does on most Windows XP machines but once and a while it does not show up on some Window XP machines.

I don’t know if this helps but have you tried renaming it on a Windows XP machine??
My System SpecsSystem Spec
17 Feb 2010   #43
JohnnyScience

Windows 7 64 & Ubuntu 64
 
 

Quote   Quote: Originally Posted by WindowsStar View Post
I was reading this thread and I am glad I remember it or I would not have paid close attention to what was going on with my USB drive.

I don't know if this related but I noticed something the other day. I have a Cruzer 32GB USB drive that I bought new. I put it in my Windows 7 machine and named it and then put files on it and never had an issue. The other day I put the USB drive in a Windows XP Professional machine (I had never used in any other machine or OS) and the name of the drive wasn’t there. I thought that it was weird but no matter what I did the name was not there (i.e. Windows Explorer, Command Prompt, Disk Manager etc.). So without missing a beat I figured it had somehow been erased and I just renamed it on the Windows XP machine. What I did not realize is that I misspelled the name and even after using it for an hour I had not noticed the mistake. The next time I put it in my Windows 7 machine I noticed the name was misspelled so I renamed it. What happened next it what you are experiencing. The name stayed spelled wrong no matter what I did. I took it with me to work found a Windows XP machine and renamed it spelling it correctly. Now the drive is correct on my Windows 7 machine. However a side effect of all of this is now some times on some Windows XP machines the name will not show up at all. It does on my Windows 7 machine and it does on most Windows XP machines but once and a while it does not show up on some Window XP machines.

I don’t know if this helps but have you tried renaming it on a Windows XP machine??
Yeah my friends computer I used is running XP Pro. I couldnt change it to the full JohnnyScience because there was a character limit in XP I think.

But regardless I changed it, formatted & as soon as I plugged it back in my computer the old name came up. Even after formatting it again on my win7 computer still the U3 name.

I think I'm going to contact Sandisk & see if they will send me a new one...
My System SpecsSystem Spec
.

19 Feb 2010   #44
JohnnyScience

Windows 7 64 & Ubuntu 64
 
 

Any ideas where else this file can be located that is still naming the flash drive with the U3 name while its plugged into my home computer?
My System SpecsSystem Spec
19 Feb 2010   #45
Packet

Windows 7 Ultimate x64
 
 

just a suggestion - have you tried changing the drive letter associated with the drive?
i've seen some 'stickiness' due to the drive letter.

and of course, there's the unplug drive, open a command prompt and do "set devmgr_show_nonpresent_devices=1 && devmgmt.msc" - then show hidden devices in device manager and remove the ghosted out drive
My System SpecsSystem Spec
21 Feb 2010   #46
JohnnyScience

Windows 7 64 & Ubuntu 64
 
 

Quote   Quote: Originally Posted by Packet View Post
just a suggestion - have you tried changing the drive letter associated with the drive?
i've seen some 'stickiness' due to the drive letter.

and of course, there's the unplug drive, open a command prompt and do "set devmgr_show_nonpresent_devices=1 && devmgmt.msc" - then show hidden devices in device manager and remove the ghosted out drive
Yes I've tried changing the drive letter as well. No dice.

Whats this second suggestion you are telling me to do? I'm not familiar with what it does?

You think it will get rid of my problem?
My System SpecsSystem Spec
21 Feb 2010   #47
Packet

Windows 7 Ultimate x64
 
 

well, windows keeps a history of every device connected - even after it's unplugged.
however, just opening device manager will not show you previously connected devices that arent connected at that very moment (even if you choose to show hidden)

however, if you set that variable in the the way i listed above - and as long as you keep that command prompt window open (while you have device manager open), you can see the previously connected devices.

i dont know for certain if it'll work - but it's worth a shot. it's what i would do if faced with your issue.
My System SpecsSystem Spec
23 Feb 2010   #48
JohnnyScience

Windows 7 64 & Ubuntu 64
 
 

Quote   Quote: Originally Posted by Packet View Post
just a suggestion - have you tried changing the drive letter associated with the drive?
i've seen some 'stickiness' due to the drive letter.

and of course, there's the unplug drive, open a command prompt and do "set devmgr_show_nonpresent_devices=1 && devmgmt.msc" - then show hidden devices in device manager and remove the ghosted out drive
Ok so I unplugged it & ran that code & couldnt see a ghosted drive? Was I in the wrong section?


Attached Thumbnails
I removed U3 from FD, but it has old name still?-untitled.png  
My System SpecsSystem Spec
23 Feb 2010   #49
antt

Windows 7 build 7100 x86
 
 

check under Universal Serial Bus controllers
My System SpecsSystem Spec
23 Feb 2010   #50
JohnnyScience

Windows 7 64 & Ubuntu 64
 
 

Quote   Quote: Originally Posted by antt View Post
check under Universal Serial Bus controllers
Hmm. Ok now what?


Attached Thumbnails
I removed U3 from FD, but it has old name still?-untitled.png  
My System SpecsSystem Spec
Reply

 I removed U3 from FD, but it has old name still?




Thread Tools




Similar help and support threads
Thread Forum
Login name removed after ransom virus removed
Please help! After a ransom virus was removed from our desktop computer (originally a display model at Sam's), my administrator account is no longer visible...Only "Kiosk" and "Other User" . I have checked to see that net user administrator /active yes is successful but still do not see my user...
General Discussion
USB cannot be removed
Hi everyone, I got this problem recently. I try to remove the USB drive, but when I click on the icon on the tray, nothing shows up. So, I try to open device and printers, it loads for a long time, until now, it is not loaded yet. I also try to run "C:\WINDOWS\system32\rundll32.exe...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:43.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App