Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: wont let me delete a file : (

24 Jan 2010   #21


Quote   Quote: Originally Posted by sky01110227 View Post
oh i have another idea....could i delete the desktop folder and create a new one ?? ....
There are easier ways if other tools dont help delete files

Open cmd and run chkdsk C: /f /x, then press Y to continue and reboot.

chkdsk will check the MFT (Master File Table) for the files existance on disk and correct any other index errors and the reboot will help clear the NT Handle Table from system memory.

Every application when its doing something with an object like a file/device will open a 'Handle' aka exclusive session, immediately when its finished using that object or file, it should release the Handle so other applications can do what they like with it. Sometimes these handles are not handled properly and never get released 'leaked', nothing minus a reboot can close that handle once its leaked because the application that locked the file has exited taking the Handle with it and afaik there's no application that can find a handle once its leaked.

My System SpecsSystem Spec
24 Jan 2010   #22

Windows 7

Quote   Quote: Originally Posted by zay View Post
You could use the take ownership take ownership , once you run this reg file, right click the file, and select the take ownership option, then try to delete the file. Worse case scenario, reboot in safe mode, or safe mode with command prompt, then navigate to the file then delete. Let me know if you need help with synthax.

omfg i knew it was something to do with permission .... after i take ownership of the file...i can then delete it ....

thank you so much

i love you

and also thanks to all others who reply : ) ....

Problem solved !!!!
My System SpecsSystem Spec
14 Oct 2010   #23

Windows Ultimate x64

Hi. I've encountered the same problem but when i run take ownership the cmd window just have a cursor that blinks. I still can't delete the file. I've tried everything here.
My System SpecsSystem Spec

24 Feb 2011   #24

Windows 7 Ultimate x86

Quote   Quote: Originally Posted by xylhynne View Post
Hi. I've encountered the same problem but when i run take ownership the cmd window just have a cursor that blinks. I still can't delete the file. I've tried everything here.

Same problem

please help
My System SpecsSystem Spec
26 May 2011   #25

Windows 7 Enterprise x64


I am having a similar problem, it seems there is a file on my desktop that REAPPEARS every time I delete it. I can do whatever with it, open it (though it doesn't do anything) I can use properties with it, rename it, whatever... But when I delete it, like in 2-3 minutes, its AGAIN on my desktop!

WTH I get this thing permanently out of my desktop and out of my system?!

NOTE: The file is an .exe (application) and the application has 0 bytes but when I click on it, the following error appears:
"not a valid Win32 application"
(That's obvious...)

But how do I get raid of this thing!

Also, I'm the only one that uses my computer, no other accounts on it but MINE which is of course, the admin of the computer.
My System SpecsSystem Spec
02 Jun 2011   #26

XP SP3 32bit, Vista HP 64bit, Seven Pro 64bit

I just had a file like that, could not open it, could not delete it, could not scan it with MSE.

What's worse it would completely jam up Explorer (not responding) and slow down my system to a crawl if I left or right-clicked on it to try to do anything with it.

Rebooted (Win 7) in safe mode with command prompt. I navigated to that partition to that folder and was able to "del" the file.
My System SpecsSystem Spec
15 Nov 2011   #27

windows 7 ultimate x32

Quote   Quote: Originally Posted by sky01110227 View Post
there is a .flv file on my desktop that i can't delete it...

i downloaded a zip file contains that .flv ... so i unzip it ....and the .flv was in a folder....and which i can delete that folder along with the .flv .... but i also made a copy of the .flv file onto my desktop ......and i could not delete that .flv : (

once i click on "delete"
it shows "Preparing to Recycle" from Discovering items
Time remaining: Calculating
Items remaining : Calculating
speed: Calculating

Hold shift + delet
Preparing to delete ....... the rest are the same as above

1: everytime i rename the file , = Windows Explorer is not responding ....
2: click on the .flv properties .... nothing happened....
3: run the .flv ....nothing happened...
4: try to replace with another file with a same name = doesn't work.
5: try to delete the file with del command ....= no luck : (
6: boot from safe mode ....still won't let me delete it
7: it won't let me move the .flv to other folders as well ....

please help me out
i also had the same problem of yours... but i used unlocker and solved the problem
My System SpecsSystem Spec
07 May 2013   #28

windows 7 pro x64
changing file extension with 7-zip solved my problem

The change the filename to a .txt using 7-zip was a great suggestion. It fixed my problem
My System SpecsSystem Spec
03 Aug 2013   #29

Windows 7 Professional 32 bits

Assuming one can navigate in DOS, the easiest way for me was:

1. Right click on the file and note where it is located (path)
2. Restart Windows in safe mode with command prompt (Not just safe mode as in this case explorer still loads)
3. Navigate to where the file is located as noted in 1
4. del <filename> (Including extension)
My System SpecsSystem Spec
08 Feb 2015   #30

Windows 7 Pro 64 bit

I wanted to offer a quicker solution to resolve this issue. As others may have stated you should kill the process that is accessing the file in question. Yes there are programs that can do this for you and eventually you will run into one file that will not work with these awesome utilities. Here is the fix when all else fails.

1. The issue is with Explorer (No IE). Windows Indexing which doesn't seem to turn off even when you force it to is locking the file. Probably due to some corruption or something else.

2. Open up Command Prompt and Windows Task Manager.
- Start > cmd
- Start > taskmgr

3. Go to the Processes tab on Task Manager and find "explorer.exe", kill this process. Your start menu and any fold you had open will disappear along with not panic, this is a good sign.

4. Proceed into the Command Prompt window that did not close because you had it open prior to killing explorer. Do not close Task Manager, if you do you will need to do Ctrl+Alt+Del to get it back.
- Find the file in question within the command prompt. If it has a long complicated description use "dir *partialfilename* to locate it.
- Once you are able to isolate that single file proceed to use "Del <filename>" to delete the file.
- Close Command prompt.

5. Go back to Task Manager and do the following.
- Click on File > New Task(run)
- Type in "explorer"
- Close Task Manager

6. Smile you are done!
My System SpecsSystem Spec

 wont let me delete a file : (

Thread Tools

Similar help and support threads
Thread Forum
Unable to delete a file,can't delete it can't shred it,
I looked at my firewall events earlier and i saw a file had been trying to connect to the internet but had been blocked by my firewall. Whenever i install a program i am unsure of i block the exe file from connecting to the internet until i'm happy its a safe program. The file is...
General Discussion
File wont delete, win 7 says no longer there, but its there
It was a download that got cut off or something happened. Ive tried redownloading the file but they dont merge or anything. Cleaning software (Auslogics) doesnt catch it. Any ideas?
Music, Pictures & Video
Help file wont delete win 7 says there is no file
I have a download that got interrupted and now have a file with extension .file that cant be deleted. Cleaning software wont catch it, restarting not working either. Havent tried a restore yet
General Discussion
A file that wont delete even through DOS
i have been trying to get a folder named WhiteSmoke_bar off my PC since it suddenly showed up one day out of the blue to give you a little insight on the problem im facing im gunna post an image of what my problem is to sum it up apparently this folder has more permissions then the owner of the...
0kb Desktop File Wont Delete and Can't be Moved
So a couple months ago I downloaded a .rfa file (Autodesk Revit) using Firefox. I had to abort the download midway, which subsequently left a 0kb file on my desktop. When I try to delete the file, explorer says it's "Preparing to Recycle" and "discovering items", but no matter how long I leave...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:58.
Twitter Facebook Google+