Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: wont let me delete a file : (

09 Feb 2016   #31

Windows 10 Home x64

Just wanted to add what worked for me. I tried most of the stuff suggested in the early parts of the thread and nothing worked.

To describe my problem I had a .zip file usually these take a while to start deleting for me not sure why but this one just wouldn't, also to add I'm on Windows 10 but the same applies for 7 & 8. If I tried to delete it the delete window would just "scan" forever, if I tried to delete it with Administrator or normal command prompt it would go down a line and not come back with C:\ and freeze. If I tried to take ownership the same thing would happen with the window that pops up. I couldn't find the Malware Bytes option most likely cause the program has changed so much over the years.

What worked for me has already been mentioned but I will go into a bit more detail, I ended up using Safe Mode with Command Prompt. Here are the steps I used:

1. Left click the Start Menu
2. Hold Shift and right click Power
3. While continuing to hold shit left click Restart
4. This will take you to a page with 3 options, select "Troubleshoot"
5. This will take you to another page, select "Advanced options"
6. Once again another page, this time select "Startup Settings"
7. Finally on the last page click "Restart" in the bottom right
8. Now your PC will boot and show you 9 boot options, press F6
9. Wait for the system to boot and the command window to appear
10. Use the cd command to browse to the directory and the del command to remove it
11. You're done!

Hope this helps someone at some point, and thank you to others for your contributions here.

My System SpecsSystem Spec

 wont let me delete a file : (

Thread Tools

Similar help and support threads
Thread Forum
Unable to delete a file,can't delete it can't shred it,
I looked at my firewall events earlier and i saw a file had been trying to connect to the internet but had been blocked by my firewall. Whenever i install a program i am unsure of i block the exe file from connecting to the internet until i'm happy its a safe program. The file is...
General Discussion
File wont delete, win 7 says no longer there, but its there
It was a download that got cut off or something happened. Ive tried redownloading the file but they dont merge or anything. Cleaning software (Auslogics) doesnt catch it. Any ideas?
Music, Pictures & Video
Help file wont delete win 7 says there is no file
I have a download that got interrupted and now have a file with extension .file that cant be deleted. Cleaning software wont catch it, restarting not working either. Havent tried a restore yet
General Discussion
A file that wont delete even through DOS
i have been trying to get a folder named WhiteSmoke_bar off my PC since it suddenly showed up one day out of the blue to give you a little insight on the problem im facing im gunna post an image of what my problem is to sum it up apparently this folder has more permissions then the owner of the...
0kb Desktop File Wont Delete and Can't be Moved
So a couple months ago I downloaded a .rfa file (Autodesk Revit) using Firefox. I had to abort the download midway, which subsequently left a 0kb file on my desktop. When I try to delete the file, explorer says it's "Preparing to Recycle" and "discovering items", but no matter how long I leave...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:44.
Twitter Facebook Google+