Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't delete file because it's in use by System

28 Jan 2010   #11

Windows 7 64-bit Professional SP1

The image isn't mounted by one of those ISO mounting programs. I checked the permissions, and System, Administrators, and Magnetite (me), all have full control of the file.

I'll try the CD burning thing, but if that doesn't work I'm not going to worry about it.

Nope, I burned it to a CD, canceled halfway, then tried it again. Still said that the file is in use by system. The firewall doesn't list the file nor is the anti-virus using it.

My System SpecsSystem Spec
25 Apr 2011   #12

Windows 7 64 Ultimate

Just wanted to post a solution I found when having the same problem. I went through the same steps as you, booted to safe mode, tried unlocker and lockhunter, etc.

Even without any image mounting software running, including the process list, the MagicISO program I was using had a virtual drive listed in the device manager. After disabling this drive windows finally allowed me to delete the files.

Confirmed to work on two different Win7 64 computers, Ultimate and Premium.
My System SpecsSystem Spec
25 Apr 2011   #13
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

Are you trying to delete this file from your 2 tig hhd or your ssd.
My System SpecsSystem Spec

17 Oct 2011   #14

windows 7
thaaaaaaaaaaaaank you FUMBLES

Thaaaaaaaaaaaaaank you FUMBLES
you sort it out :)
it was magic iso program and should disable all the drives
thank you aloooooooooooooooot
My System SpecsSystem Spec
22 Jun 2012   #15

Windows 7 Premium Home Edition 64-bit
Easiest fix ever...

Had the very same issue with an .ISO file...

I couldn't trash the file (I got a similar message saying it was in use by System); but somehow I was still able to change the extension to something different... then delete the file without problems.
My System SpecsSystem Spec
21 Nov 2012   #16

Windows 7 Ultimate 32b

I had a similar problem just now with a half-downloaded .iso file. I had DaemonTools Lite set up to auto-associate .iso files, and the download stopped halfway through and wouldn't resume, and I got this error anytime I tried to screw with it. After reading this thread I was able to delete the file after removing all of my virtual drives in DT.

So yeah, if you have a virtual drive manager program and you get this, try deleting or disabling your virtual drives. You can always re-enable them later after the offending piece of data is in the recycle bin where it belongs.
My System SpecsSystem Spec
11 Jul 2014   #17

Windows 7 Professional x64

Glad this helped a couple people but going through EVERY one of those steps and still coming up dry...

Please help :c
My System SpecsSystem Spec
09 Sep 2014   #18

Windows 7(64)

If you are using image mounting software, even if the program does not appear to be running (such as Daemon Tools etc.) Open the program and make sure that the file which you can't delete isn't mounted to any drives. For instance, the same thing happened to me and I could not delete an ISO until I opened Daemon Tools and clicked the unmount all drives button, which solved the issue.

(Even if your mounting software does not show any files to be mounted click the button anyway, mine did not show anything to be mounted, but the ISO was mounted nonetheless.)
My System SpecsSystem Spec

 Can't delete file because it's in use by System

Thread Tools

Similar help and support threads
Thread Forum
File permissions, can't delete file with 0 bytes size
I downloaded a file, didn't download correctly, size = 0 bytes. Reports owner unknown. I can't change ownership, remove file properties, any of that stuff. Can't rename or delete. I'm logged in as administrator but it keeps asking for administrator permission. ?? Another question about...
When to delete old files and create System Image after System Repair
I have just finished a System Repair on my Windows 7 using repair ISO, and I'm not sure if I should do a system image backup before deleting old files with Disk Cleanup, or delete them after I've done a Repair Disc and System Image as well. I'm also afraid to delete anything at this stage. Would...
Backup and Restore
File that doesn't delete,uses more memory & system response takes long
HI all, recently I downloaded a software from the internet to my flash drive & I click on it just to check but I think that software had virus or something that uses more memory & makes system slow & the software didn't start at all.So, I deleted it as soon as possible. I didn't realize that all my...
System Security
Unable to delete a file,can't delete it can't shred it,
I looked at my firewall events earlier and i saw a file had been trying to connect to the internet but had been blocked by my firewall. Whenever i install a program i am unsure of i block the exe file from connecting to the internet until i'm happy its a safe program. The file is...
General Discussion
Help file wont delete win 7 says there is no file
I have a download that got interrupted and now have a file with extension .file that cant be deleted. Cleaning software wont catch it, restarting not working either. Havent tried a restore yet
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:44.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App