Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't login, Atbroker.exe error

29 Jan 2010   #21
Capt.Jack Sparrow

Windows 7 Ultimate - 64-bit | Windows 8 Pro - 64-bit

Quote   Quote: Originally Posted by Fairchild22 View Post
Hi guys i'm new to t he forum. I just want to add what i have experienced as well. Windows 7 is a GREAT!! OS, but it appears this Atbroker.exe application ERROR is a real killer and once you get it. There is nothing you can do about it pretty much, but reinstall. Now hear his the thing that many people are referring to resolving the issue and that that's the CTRL+ALT+END command, but that only works if you are already logged into a Windows OS and your accessing Win7 from Remote Desktop.

The issue that the main poster is facing is the same issue I'm having. You start Windows it comes to the load screen. You enter your password and it acts like like its about to load. Then you get ERROR: AtBroker.exe Application error and Explorer.exe Application error.

Doesn't matter is you click "ok" or close it out. You are still doomed to be staring at a "BLACK SCREEN". Nothing seems to work. System restore, desk check, driver restores, or anything. I'm logged into SAFE MODE now and that's how I'm able to post my information on the forum now. These 2 ERRORS that you get before and after you try to log in have to be the worst things you can get on Windows 7. I'm not giving up though. If I find a fix for this I will post it ASAP!!! cause it seems to be a well known problem and Microsoft is not able to fix either. This ERROR was even on vista and you would think they would have came up with some sort of fix for it before releasing Windows 7.
Just out of curiousity are you able to Create a New Profile (Administrator) in Safe Mode and login under that profile. ??

- Captain

My System SpecsSystem Spec
29 Jan 2010   #22
Shahid Malik

Window 7

If you using CA antivirus try this:

restart in "safe mode with command prompt"
run sfc /scannow

restart in safe mode
set exclusion for \windows\system32\shell32.dll in CAAV options panel for Real Time and On Demand virus checks.

It worked for me. thanks to Win32/WebSearch infection - CA Home and Home Office Forum
My System SpecsSystem Spec
30 Jan 2010   #23

windows 7

Atbrocker error happen after a patch was installed, I need advise on how to repiar please
have tried ALT-CTL-DEL no luck
can start i safe mode but can not repair
all scans are good
My System SpecsSystem Spec

30 Jan 2010   #24

win 7
I found a fix

I use CA Security suite and after the latest updates from Microsoft my CA antivirus
kept finding a problem with shell32.exe. This was an error, the virus signature dat for some reason identified shell32.exe as a threat after the updates. To fix this I:
restarted in safe mode
set exclusion for \windows\system32\shell32.dll in CAAV options panel for Real Time and On Demand virus checks.
Once excluded from Quarintine a re-boot and all was well.
Also on a second machine, I
restarted in safe mode
Updated the CA dat files and all worked.
Hope this helps. Maybe more antivirus programs see the updated Shell32.exe as a threat and are blocking it.
My System SpecsSystem Spec
30 Jan 2010   #25

Windows 7

I am having the same problem and also running CA. The exclusion didn't help me. I'm stilling having the problem at log in. I Hope someone can figure this out since tech support from Dell, CA, and Microsoft have all denied responsibility for this and a complete restore is not an option.
My System SpecsSystem Spec
30 Jan 2010   #26

Windows 7

My problem is fixed after excluding the win32.sys file. I'm actually not sure if it is the virus or not but it gets through those errors to log in.
My System SpecsSystem Spec
31 Jan 2010   #27

Windows 7

I had CA also and excluding shell32 worked for me. Thanks to everyone who posted replies. I should have known something would happen when I saw that CA was unsupported during the windows 7 install. Hopefully there are no more issues.
My System SpecsSystem Spec
04 Feb 2010   #28

Solution to atbroker.exe crashing on windows 7 login

An even easier solution is to boot into safe mode, and uninstall CA antivirus.

Soon as you do this reboot your system and it will work. Get rid of CA only causes problems in my experience. Go with Norton, Pccillin, nod32.
My System SpecsSystem Spec
24 Jul 2010   #29

Windows 7 Professional X64 and Linux Mint 9 Isadora

Would a full restore work? We have a home server and we do weekly backups
Safe mode doesn't work
Dulabooting with LinuxMint...haven't used windows in like a week or two.
My System SpecsSystem Spec
12 Aug 2010   #30


This sucks. I'm starting to dislike W7 more and more. I installed it on my home workstation. Since I work on the fly I'm hardly ever home. I log on remotely through RDP. Now, the other day I got that annoying message. I don't know what else there is to say, except that it sucks.
My System SpecsSystem Spec

 Can't login, Atbroker.exe error

Thread Tools

Similar help and support threads
Thread Forum
KSOD error before Login Screen then BSOD, error 0x0000007A
Hi 2 days ago I turned my computer on and I was logging in as normal. It finished doing the 'starting windows sequence' and then the screen turned black, with a cursor. I waited then the BSOD came up. ALSO the KSOD comes up in the Safe Mode as well.I spam f8 and I have tried everything.The most...
BSOD Help and Support
AtBroker.exe, Explorer.exe failed to start
When I boot up my laptop, I get a place to type in my password. Then I get a black screen with only a pointer, and two error messages. Atbroker.exe failed to start and Explorer.exe failed to start I do Control+Alt+Delete and click Task Manager, and get another error: Task manager failed to...
General Discussion
!! Restored image of windows, now wont login, login service error!!
Hi, my windows was set up like this: C: windows 7 F: all user accounts inluding default user ( users folder ) are on F drive. I imaged windows, and restored it on a different PC. On another HDD, I assigned it as F: and put a copy of the user folders on there. But now when it goes to log...
General Discussion
AtBroker.exe (0xc00000ba)
Ok, so i changed some settings on my Windows 7 64bit, and it said i needed to restart to activate the changes. When it came back on, i logged in, and got an error message saying: AtBroker.exe: Failed to run application properly (0xc00000ba). click OK to terminate the program. Then, i click ok. then...
BSOD Help and Support
Atbroker could not be found!!
Hello. Pls help me! I dont have any others os installed on the computer!! I use Win7 32-bit! Runed well and really great! But now that error wont let me log in!! Cant get into safemode! The method with Ctrl+ALT+Del wont work!! Any of the ways(log off,start taskmanger I get an error,and...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 05:53.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App