Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: cannot set file association - option greyed out

04 Feb 2010   #1

windows 8.1 Pro x64
cannot set file association - option greyed out

Ok so I set the association for .ini files to regedit. I assumed it be easy to change back again.

Now when I try to set via open with or the control panel this happens.

I see notepad and wordpad as reccomended programs. I can select one but the "always use the selected program to open this file" is greyed out and unticked so the change doesnt stick.

If I navigate to notepad.exe manually it still is the same problem.

A reboot doesnt fix the problem.

If I try to fix in the registry it is set to notepad.


value notepad.exe

double clicking opens regedit.

My System SpecsSystem Spec
04 Feb 2010   #2

windows 8.1 Pro x64

ok I found the fix, weird I have to say.

microsoft it seems have in their wisdom that if regedit is set as a association for a file it then is disabled to set it to a new program, this setting is what controls it.


REG_SZ value called NoOpenWith

I renamed to NoOpenWith2 and when I went back to the control panel the box was still ghosted but this time ticked and double clicking notepad saved the new setting.
My System SpecsSystem Spec
04 Feb 2010   #3

64-bit Windows 10 Pro

Hello Chrysalis,

You can also download and use the INI download option in the tutorial below. It will restore all of the default associations for it.

Default File Type Associations - Restore

Hope this helps,
My System SpecsSystem Spec

04 Feb 2010   #4

windows 8.1 Pro x64

Hi, yes those restore files look handy and would have done the job so will remember if a next time, thanks.
My System SpecsSystem Spec
04 Feb 2010   #5

64-bit Windows 10 Pro

You're welcome. Hopefully will not have to.
My System SpecsSystem Spec
04 Feb 2012   #6

Windows 7 64 Pro

Old Post but I know people will go nuts trying to figure this one out. Nothing here or from other sites worked for me. Some of the fixes seemed too general and I did not want to reset all, only fix the one. I'm an IT guy and tried the usual Windows Control Panel etc...

So... delete the UseChoice from hkcu. In my case I associated .shader with Visual Studio. After doing it, realized VS does not highlight code like Mono Developement, but couldn't switch it back.

Removing the key below re-enabled the check box. now I could re-associate with Mono.


For you, find the extension giving you grief in HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\
If it has a "UserChoice" key delete it. (Back it up if you are paranoid, right click export!)

I don't think I even rebooted and the check box was back.

My System SpecsSystem Spec
04 Feb 2012   #7

64-bit Windows 10 Pro

Hello MJR, and welcome to Seven Forums.

That's what the specific downloads in the tutorial below does automatically for only the selected file extension that you wanted to restore back to it's default associations.

Default File Type Associations - Restore
My System SpecsSystem Spec

 cannot set file association - option greyed out

Thread Tools

Similar help and support threads
Thread Forum
xp install option greyed out using new partition on hdd windows 7
i've tried a virtual machine and formatted a 40gig partition on the pc hdd running win 7 then tried to load my copy of xp and in all cases the option to install xp is greyed out on the welcome screen. i even used administrator privileges.
Installation & Setup
Sleep Option greyed out.
Title says it all. I have all the power down options available EXCEPT Sleep. It is greyed out(even in safe mode). I've searched the forums and found multiple threads. I have tried the registry tweaks, self-executable files to reactivate sleep, etc. all to no avail. The only other unfortunate option...
General Discussion
Sleep option is greyed out! Cannot hibernate too!
My sleep option in windows 7 ultimate is greyed out!! Also, I have my graphics driver installed etc so please dont comment on that. I get the follow error when I try to type "powercfg -Hibernate ON" in CMD and I don't know how to resolve it! Please help me , I need back sleep and ...
Performance & Maintenance
Option greyed out
Why can't I change the checked setting shown here? I'm the administrator:
Network & Sharing
Share Folder option greyed out
I am having a mini-lan with a couple of mates running Vista 64 and I cant seen to share one of my drives (or any folders) becuase the "share" option is greyed out!?!? The network is fine because they can both access my "public" folder but is there any way to enable sharing?? Cheers, ...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:47.
Twitter Facebook Google+