Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't Get AppLocker to Function Properly

11 Feb 2010   #1
Jforsyth

Windows 7
 
 
Can't Get AppLocker to Function Properly

Hello,

I am trying to set up a user account that can be used to run Windows Media Center. I would like to restrict access to just about everything else on the operating system (files, programs, etc). It seems like AppLocker would be perfect for this.

However, I cannot get AppLocker to succesfully restrict a program. I wanted to test out restricting just one program, so I did the following:

1. Created a new, standard user account.
2. Enabled Executable Rule Enforcement.
3. Created a new rule that denys access to the individual executable file for the individual account.

However, when I log onto the other account, I am completely free to run the executable that I selected.

Does anyone know what I'm doing wrong? I'm using Windows 7 64-bit Pro, if that matters.


My System SpecsSystem Spec
.
11 Feb 2010   #2
Barman58

Windows 10 Pro x64 x2 Windows 10 Enterprise x64, Ubuntu
 
 

you will have to check with the option list on the Microsoft website but I think that applocker only operates in enterprise or ultimate SKU's of win7

You could also have a look at parental controls as this should also allow you to restrict access to programs through a white/black list system for standard user accounts.
My System SpecsSystem Spec
11 Feb 2010   #3
Jforsyth

Windows 7
 
 

Quote   Quote: Originally Posted by Barman58 View Post
you will have to check with the option list on the Microsoft website but I think that applocker only operates in enterprise or ultimate SKU's of win7

You could also have a look at parental controls as this should also allow you to restrict access to programs through a white/black list system for standard user accounts.
Oh, silly me.

Quote   Quote: Originally Posted by Microsoft
AppLocker is available in all editions of Windows Server 2008 R2 and in Windows 7 Ultimate and Windows 7 Enterprise
That would explain it.
My System SpecsSystem Spec
.

11 Feb 2010   #4
Barman58

Windows 10 Pro x64 x2 Windows 10 Enterprise x64, Ubuntu
 
 

I would definitely advise you have a look at the parental control option - it is a hidden gem of the win7 system - there is a lot of power to control the system built right into the OS
My System SpecsSystem Spec
12 Feb 2010   #5
Jforsyth

Windows 7
 
 

Thanks for the help! It seems like I'll be able to do everything I wanted through the Parental Controls.
My System SpecsSystem Spec
Reply

 Can't Get AppLocker to Function Properly




Thread Tools




Similar help and support threads
Thread Forum
Hibernate Button Does Function Properly
When I clicked Hibernate, the screen turns off then after a few seconds, the screen will now show the account log in. I'm running Windows 7 64-bit Ultimate. I suspected this happened after I installed (dual boot) openSuse in the same partition where my Windows 7 is. Any solution?
General Discussion
Windows Internet Explorer AND sleep function not working properly!
I've never seen anything like this. Okay, here's the system rundown --- Running win 7 pro sp1 64 bit on a Dell xps 8000. Replaced hard drive one month ago, and I've used Seagate's diagnostic tool to check out hard drive, which didn't find any errors with the hard drive. So, here's problem 1:...
General Discussion
Programs Won't function/close down properly
Heya, I know that people have come across similar issues and I have looked through hundred of threads regarding each bit of software, but I now am thinking it is something for my case, stuffing everything up. My PC is fairly new, I know it's not my hardware. My problems I have are for...
Software
Modem/router function properly, but no internet
My modem (Siemens SpeedStream 4100) and router (Linksys WRT120) both function properly, but my desktop computer (HP-Pavillion Elite m9077c) won't connect to the internet. I never had a problem connecting up until a month ago, but since then, nothing. I know the modem and router function properly...
Network & Sharing
Firefox 4 doesn't function properly in the taskbar
This is quite a weird problem and it started when I replaced Firefox 3.6 with Firefox 4 (as in uninstall Firefox and install Firefox 4). Everytime I am browing now Firefox 4 doesn't function properly in the taskbar. I made a screenshot of it which shows the problem much better. As you can see...
Browsers & Mail
Windows SP1 - now explorer doesnt function properly
I installed SP1 last evening with no issues what so ever, but now today when I am using my computer I am not able to double click on anything in windows explorer. When I try and open a drive or a folder I get the message there is no default program associated with this type of file, please go...
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:38.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App