Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Another permissions problem

04 Mar 2010   #1

Windows 7
Another permissions problem

I have been trying frantically to delete the "Windows Defender" folder from my new PC as I have a much better anti-malware program. After reading probably 20 posts about people having the same "You require permission from X" issue as I was, I have changed ownership to administrator accounts (mine is the only one) and allowed full control in both the admin boxes and my personal user boxes. After all that I'm still getting "you need permission from administrator" even though I AM the admin. So I tried to go back and check the "include inheritable permissions" and "Replace all child object" boxes....the "Include" box went fine but when I try to check the "Replace" box I get an "access denied" window for each file in the folder.

I am running 64-bit windows 7 home edition and there are actually two "windows defender" folders, one in program files and one in program files (x86). I have swapped permissions on both of these folders to no avail, I am still completely unable to delete this freaking folder. Please someone help!

My System SpecsSystem Spec
04 Mar 2010   #2

64-bit Windows 10 Pro

Hello Towelie, and welcome to Seven Forums.

Sorry, but Windows Defender is a part of Windows 7. The Windows Defender folder is a proteced operating system folder and cannot be deleted.

If you do not want to use it, then you can turn off Windows Defender to have it not run or use any resources other than the very tiny amount of HDD space for the files.

Hope this helps,
My System SpecsSystem Spec

 Another permissions problem

Thread Tools

Similar help and support threads
Thread Forum
Permissions Problem ??
I fitted a spare 500GB HDD in a Windows-7 Pro 64-bit machine (machine AA). It's called drive F:/ I filled it with photos across the network from an XP machine (machine BB). I had full access to \\AA\F for a few days from \\BB. Later I had reason to put the UAC up to full and then back down...
Network & Sharing
Homegroup permissions problem
So I had a "build your own" pc in the garage running W7 Ultimate 32 bit and it was networked with my HP desktop in the house which had a TB external hd full of service manuals and stuff I wanted to access from the garage PC. Worked like a dream before. I recently had someone give me a newer HP...
Network & Sharing
Homegroup permissions problem
My Homegroup was working perfectly between my PC and laptop, and then without knowingly changing anything the Homegroup libraries just stopped appearing. I left the Homegroup on both computers, restarted them and created and joined a new Homegroup. From my PC, it all works perfectly, but from my...
Network & Sharing
Permissions Problem
Hey, I'm trying to paste a .dll file into system32 for my program but it keeps denying me because i don't have permission even though im on as administrator... how can i setup permissions properly so i won't get this issue again on any thing on my OS, i managed to rid of it on vista but i...
General Discussion
Odd Permissions Problem
I have recently updated to build 7077 (from 7000). I have noticed some strange problems when trying to write new files. Sometimes Windows will tell me I do not have the proper permissions to write to that location (such as when installing an app to the Program Files x86 folder or saving a Maya file...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:18.
Twitter Facebook Google+