Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Incredibly frustrating permissions error

04 Mar 2010   #1

Windows 7 Professional (x64)
Incredibly frustrating permissions error

I am running 64-bit Windows 7 and am trying to install the windows media player plugin for firefox. The installer tries to install the plugin np-mswmp.dll to c:\program files (x86)\mozilla firefox\plugins......but I keep getting an error that the file cannot be written to that directory and that I do not have access.

I have taken ownership, set all permissions to full, enabled the built in full, local administrator account and tried with no luck. I have ran command prompt as administrator and taken off the read only attribute using the attrib command, but whatever I do I cannot remove the "Read Only" status of the folders.

Any suggestions?

My System SpecsSystem Spec
04 Mar 2010   #2

Windows 10 Pro (x64)

Quote   Quote: Originally Posted by bkesting View Post
but whatever I do I cannot remove the "Read Only" status of the folders.
Folders do not have a "read-only" setting.

Have you tried just running the installer as Admin? Right-click > Run as...
My System SpecsSystem Spec
04 Mar 2010   #3

Windows 7 Home Premium Edition

Yes I agree with logicearth, run as admin.
My System SpecsSystem Spec

04 Mar 2010   #4

Windows 7 Professional (x64)

Tried that.........same result.

"Error writing to file: C:\Program Files (x86)\Mozilla Firefox\Plugins\np-mswmp.dll. Verify that you have access to that directory."

The link is a screen shot of what I'm talking about.
My System SpecsSystem Spec
04 Mar 2010   #5

Windows 7 x64 Ultimate

The read only flag on the folder is an indication that the folder is customized. It cannot be unset by hand.
As was mentioned before, there is no such thing as a read only folder.

So I wouldn't be looking at that part of the properties for the answer. It probably is still a permissions issue, but the read only flag on the folder is not part of it.

I'm afraid that I am lacking in any helpful way forward with the issue atm though
My System SpecsSystem Spec

 Incredibly frustrating permissions error

Thread Tools

Similar help and support threads
Thread Forum
System Folders Permissions Error
I have two computers both exhibiting the same problem. One is a Dell desktop, the other a HP laptop, both are running windows 7 Home Premium x64. I have a homegroup set up and also share a set of folders on the Dell. My difficulty is that although logged on as an administrator, I cannot...
General Discussion
Restore permissions error
Took full back up (AMOMEI Backupper) on W7 64 bit Ultimate OS Now trying to restore ... Mounted Backup image .. as only need to copy one folder & its contents. about 140MB gone in OK .... but some files in one folder won't copy get errror: "You'll need Administrator permission to copy...
Backup and Restore
Permissions Error
I tried copying a bunch of photos from a memory card to my 1TB Samsung F3 HDD but it wouldn't work. As in when I selected "copy" nothing happened. So I checked the permissions and got this: It's all greyed out. How do I fix this and the...
Performance & Maintenance
Error : Application Error.Very frustrating
Hi all..matt new members at this forum. i just want to ask how can i fix this error?
BSOD Help and Support
Error Applying Permissions
Hey . I am new in this forum and not so expert in computer. i was trying to use some protection for my drives then i disabled all the permission for SYSTEM from the properties of my G drive. Now i can't open the drive whenever i am trying to allow all the permission for SYSTEM it's giving me an...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:47.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App