Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't Repair 64-bit Boot Problem with RAID

04 Mar 2010   #1

Windows 7 64-bit 7100
Can't Repair 64-bit Boot Problem with RAID

I flashed my BIOS yesterday in an attempt to address a fairly recent issue coming out of sleep (black screen of death) on Windows 7 Home 64-bit.

When I rebooted, I didn't realize that the flashing had turned off RAID, so Windows didn't see what it was looking for and went into a repair mode that obviously horked one of the drives when it should have seen RAID.

When I boot from the CDROM and go into Repair, it doesn't see any OS to repair. Then I try to add the Intel Matrix Storage Manager drivers and it does see them on the USB. But it grinds for a minute or so and then says the driver install failed. The is with the exact same Intel RAID drivers I've used many times last year with the betas and later the purchased version. I've also confirmed these drivers still load up fine if I start down the full install path (vs. repair). It can't read things and wants to do a format & install so I back out and quit.

The official repair steps of opening a DOS window and using 'bootrec /RebuildBcd' do not work for me. These are:
bcdedit /export C:\BCD_Backup
cd boot
attrib bcd -s -h -r
ren c:\boot\bcd bcd.old
bootrec /RebuildBcd
When I run the Bootrec commands above from a DOS prompt, the BCD steps say 'file not found' and the Bootrec command says it will take a few minutes, but is immediately done. And afterwards, the reboot fails so that doesn't work (obviously because it didn't load RAID).

The only good news is that I was able to create a rescue CD using BartPE (with the 32-bit RAID drivers) that has allowed me to copy everything off to my 1TB external USB drive. Once I boot to Windows PE on my rescue CD, I can see everything on my RAID drives just fine, so everything is still there.

It's a darned shame that I can't fix that boot record, but with RAID drivers not loading in repair mode, I'm stuck.

This is on a nice homebuilt system built last summer with an excellent Asus mobo, terabyte drives, quad-core Intel, 6G RAM, etc.--all current stuff.

Any advice most welcome! I suspect I'll be reformatting it later tonight.

My System SpecsSystem Spec
04 Mar 2010   #2

Microsoft Community Contributor Award Recipient


You can try this.

When you get to the Black screen of death, press the windows key once.
My System SpecsSystem Spec
04 Mar 2010   #3

Windows 7 64-bit 7100

Thank you theog, but I tried all sorts of combinations of the Windows key on those occasions when it failed to come out of sleep. I figured it's either a graphics driver or possibly BIOS and Asus released a new one last month.

Right now my severe problem is that I have an unbootable PC and no ability to fix the boot files on RAID.
My System SpecsSystem Spec

04 Mar 2010   #4

Windows 2000 5.0 Build 2195

Do you have software RAID or hardware RAID?
My System SpecsSystem Spec
05 Mar 2010   #5

Windows 7 64-bit 7100

Uh, the motherboard supports RAID, and it also requires the Matrix Storage Manager drivers. So both?

In any case, I gave up and reinstalled and am putting things back -- too much to do and not enough time to keep fiddling with it in hopes of magically bringing back the boot record.
My System SpecsSystem Spec
05 Mar 2010   #6

Windows 2000 5.0 Build 2195

^Nah, it's hardware. When your motherboard supports raid, usually the OS doesn't even realize you're on a RAID system (based on my experience; diskmgmt.msc, device manager, etc) and views it as a single drive.

Just for your info, I would think that you might have needed to rebuild the MBR since it can't find which boot drive is which.

Remember, after your BIOS loads the RAID materials, after that, software should think of your RAID system as just one hard drive.
My System SpecsSystem Spec
05 Mar 2010   #7

Windows 7 64-bit 7100

Oh yeah - I knew I needed to rebuild the MBR, but every attempt using every trick I could find failed.

I'm back up now, hand-restoring things from the image I grabbed of my hard drive before I reformatted...
My System SpecsSystem Spec

 Can't Repair 64-bit Boot Problem with RAID

Thread Tools

Similar help and support threads
Thread Forum
Boot repair problem
Hi, I have an ASUS N56VZ-S4082V with Win7 Home Premium 64 bit SP1 installed (EFI BIOS). I recently installed and then removed Ubuntu 12.04 on another partition, and used EasyBCD to remove the Ubuntu boot entry that was still present in BIOS. Unfortunately, I used the command to rewrite the MBR, so...
General Discussion
Win 7 x86 can't boot up, startup repair could not detect problem.
My system crashed on my acer laptop - I wasn't doing anything out of the ordinary - It wouldn't boot back up. Would boot into safe mode so I did this & followed instructions to stop all other programs running other than microsoft, still wouldn't boot up - just hangs at the win7 logo screen. I tried...
BSOD Help and Support
Windows 7 won't boot, can't repair, possible EFI partition problem?
Windows hangs at the flashing _ after booting. I can't run the repair program with the DVD and I suspect its a problem with the EFI partitioning or flagging or missing some boot files in the EFI partition or something. According to gparted I have: /dev/sda1 as FAT32 228.00 MB, it is marked as...
Installation & Setup
Cannot boot from non-RAID image restored to RAID SSD
OK, I was using one Vertex 120 as my Windows 7 C: drive and bought another to take advantage of RAID0 performance. Did a system image backup of the C: drive to my 1TB D: drive, installed the 2nd Vertex 120 (both are FW 1.5), enabled RAID in BIOS and created a RAID0 in the Intel RAID launch...
Backup and Restore
Advanced Boot problem with disk reverted from RAID 1 (Files are ok)
Screenshot from disk management(from former RAID1): This is what happened> I had RAID 1 running on Intel Matrix Storage,(Win 7 Pro x86) then the software failed first with one then with the another disk. I...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:03.
Twitter Facebook Google+