Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Weird Windows 7 Registry Issue - HKEY_CLASSES_ROOT

21 Mar 2010   #1

Windows 7 Home Edition (64 bits)
Weird Windows 7 Registry Issue - HKEY_CLASSES_ROOT

I am using Windows 7 Home edition (x64 bits) and have noticed that there are no permissions set for HKEY_CLASSES_ROOT. The following message is displayed.

No permissions have been assigned for this object.

Warning: this is a potential security risk because anyone who can access this object can take ownership of it. The object's owner should assign permissions as soon as possible.

I can't installed Windows applications (using Microsoft installer) ranging Office, Midmanager and any other application.

Please I need your help, I bought this in January
Any advise

My System SpecsSystem Spec
21 Mar 2010   #2

Windows 10 Pro (x64)

When did this start?
My System SpecsSystem Spec
21 Mar 2010   #3

Windows 7 Home Edition (64 bits)

I really don't know. I realized I had a problem when I tried to install MindManager. Each time I wanted to use the application I was forced to go over the initial setup. I googled my problem and was forced to realize that it was a registry issue.
My System SpecsSystem Spec

21 Mar 2010   #4

Windows 10 Pro X64

Try this:

Found the following here: Post by qella3, near the bottom. Also simliar/same in a post by Arthur Xi here: WIndows 7: No Administrator Rights and C:\ is not accessible

Before doing anything, create a new System Restore point and/or a full registry backup using ERUNT

1) Download SubInAclat Microsoft Download Center SubInACL (SubInACL.exe) and install it. Default install is to C:\Program Files\Windows Resource Kits\Tools. You can change this to whatever you want.
2) Open a Command Prompt and navigate to the directory subinacl was installed in.

Type (or copy and paste) subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f and press Enter.

That should reset HKEY_CLASSES_ROOT to it's normal value.
My System SpecsSystem Spec
22 Mar 2010   #5

Windows 7 Home Edition (64 bits)

All right !! I'll try this tuesday night. Thanks again
My System SpecsSystem Spec
23 Mar 2010   #6

Windows 7 Home Edition (64 bits)

should I run this 2 line instead of just one
subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=Administrators=f /grant=System=f /grant=Users=r /setowner=Administrators
subinacl /keyreg HKEY_CLASSES_ROOT /grant=Administrators=f /grant=System=f /grant=Users=r /setowner=Administrators

If I have to should I do it in a notepad file ? If it's yes how should I named the file ? Should I restored all my privileges (including HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER directories)

Could this problem was initially initiated by TuneUp Utilities ?

thanks again
My System SpecsSystem Spec
24 Mar 2010   #7

Windows 7 Enterprise (x64); Windows Server 2008 R2 (x64)

subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=Administrators=f /grant=System=f /grant=Users=r /setowner=Administrators

Is good. I will do the ROOT key and all subkeys.
My System SpecsSystem Spec
28 Mar 2010   #8

Windows 7 Home Edition (64 bits)

It doesn't worked. they all failed. It looks like I doesn't have the access to execute this line. What should I do ? I'm totally lost. thanks again.
RegSetKeySecurity Error 5 = Access is denied

My System SpecsSystem Spec
28 Mar 2010   #9

Windows 7 Home Edition (64 bits)

Thanks ! If I need a beautiful toy to put on my table, I'd buy a Mac but I need a real computer. So, I own a PC.
My System SpecsSystem Spec
29 Mar 2010   #10

Windows 7 Enterprise (x64); Windows Server 2008 R2 (x64)

Quote   Quote: Originally Posted by gouletjo View Post
I think I don't have an administrator account anymore. What should I do ?
What do you mean you don't have an Administrator Account anymore?

Built-in Administrator Account - Enable or Disable

Are you locked out of the Admin Account?

Account Lockout - Unlock a Locked Out User Account

Did you detete your Account?
My System SpecsSystem Spec

 Weird Windows 7 Registry Issue - HKEY_CLASSES_ROOT

Thread Tools

Similar help and support threads
Thread Forum
do you have this weird registry key?
Hi i have never installed paragon software , but i found this weird registry key yesterday ,in hardware manager i found unknow device and one is related to PARAGONBLOCKDEVICEHKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\PARAGONBLOCKDEVICE i uninstalled the unknown device but i have...
General Discussion
weird chinese registry key in registry
Hi I have Windows Seven utlitmate with SP2, clean installed. Three days ago, MSE noticed and prevent a virus while surfing. I did several indeep scans (MSE), then some online scan (Microsoft, F=secure and Eset) then 3 differents malwares removers, Malwarebit, super malware and Iobit) all...
System Security
Weird issue with Windows 7 & Boot Up?
Hi all, Having some issues with my machine which I suspect may relate to a motherboard issue. At first I thought that my graphics card had failed as its getting on a bit now, although its been a total workhorse (nVidia GeForce 8800GTX). My computer would start but no signal to monitor. So...
Hardware & Devices
Windows 7 boot problems (possible registry issue?)
Okay, I realize I shouldn't have messed with the registry, but I did ("I'm curious as a cat, that's why my friends call me whiskers!" sorry, SNL reference...). Now, I am not really sure how to fix my problem. My problem: Windows 7 (64 bit) reboots itself before it gets to the login screen. ...
BSOD Help and Support
hkey_classes_root]magnet\url pregvalue
I actually found this forum from searching for solutions to a problem so I'm hoping I can get some help here. Though it doesn't show up as a problem in my McAfee or CCleaner, my NoAdware program is finding this one problem: hkey_classes_root]magnet\url pregvalue I delete it but then it...
System Security
Weird Firefox issue: New Windows for No Reason
I can't figure out if this is Windows 7 or Firefox 3.5 I don't notice it happening on my XP installation but it could just be coincidence. Sometimes I'll be moving my mouse around kind of fast and click something and all the sudden my tab will disappear and open up in a new window. I can't...
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:01.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App