Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Lost program icons...

26 Mar 2010   #1
SafiAmir

Windows 7 x64
 
 
Lost program icons...

I was just working on my computer when suddenly i noticed tht i have lost my Windows Live icon and then found Google earth...Office. I didnt install any pograms or messed up with icons...
Here is the screenshot:




My System SpecsSystem Spec
.
26 Mar 2010   #2
MadMaxData

Windows 7 Enterprise x64
 
 

I've had that happen a few times when running the registry cleaner inside CCleaner. If you made a backup of the registry, try restoring it and your icons should come back. It works for me.
My System SpecsSystem Spec
26 Mar 2010   #3
Uber Philf

W7 RTM Ultimate x64
 
 

Maybe deleting the icon cache will fix it.

Navigate to C:\Users\*username*\AppData\Local

And delete the iconthumb.db (I think that's what it's called)

It will be the only .DB file there, so delete it, then restart explorer, and hopefully that should fix it.
My System SpecsSystem Spec
.

26 Mar 2010   #4
MadMaxData

Windows 7 Enterprise x64
 
 

Quote   Quote: Originally Posted by Uber Philf View Post
Maybe deleting the icon cache will fix it.

Navigate to C:\Users\*username*\AppData\Local

And delete the iconthumb.db (I think that's what it's called)

It will be the only .DB file there, so delete it, then restart explorer, and hopefully that should fix it.
I would think that would make it worse. How can deleting the icon cache recover icons? I've never tried it, but it sounds backwards to me.
My System SpecsSystem Spec
26 Mar 2010   #5
Uber Philf

W7 RTM Ultimate x64
 
 

Quote   Quote: Originally Posted by MadMaxData View Post
Quote   Quote: Originally Posted by Uber Philf View Post
Maybe deleting the icon cache will fix it.

Navigate to C:\Users\*username*\AppData\Local

And delete the iconthumb.db (I think that's what it's called)

It will be the only .DB file there, so delete it, then restart explorer, and hopefully that should fix it.
I would think that would make it worse. How can deleting the icon cache recover icons? I've never tried it, but it sounds backwards to me.
Well the situation works, that you delete the cache, will force it to rebuild it, and get the icons from where they are, and not from the possibly corrupt cache.
My System SpecsSystem Spec
26 Mar 2010   #6
MadMaxData

Windows 7 Enterprise x64
 
 

Quote   Quote: Originally Posted by Uber Philf View Post
Well the situation works, that you delete the cache, will force it to rebuild it, and get the icons from where they are, and not from the possibly corrupt cache.
I understand that, but every time I have been missing an icon it's because the .exe file that the shortcut belongs to no loger has an icon. See what I'm saying?

To the OP...I've also retrieved shortcut icons by going into the folder that contains the .exe file, and seeing if there's another file in there with the same icon that is now missing. If there is, then I simply go to the shortcuts properties, and change the icon to the available one.
My System SpecsSystem Spec
26 Mar 2010   #7
SafiAmir

Windows 7 x64
 
 

ok, i installed a trusted pogram and this thing happend and the system restore sint working...
My System SpecsSystem Spec
26 Mar 2010   #8
Coco15

Windows 7 Professional 64 Bit OEM
 
 

Sounds like corruption of Icon files. Have you tried reinstalling the programs or repairs and have you used system restore?
My System SpecsSystem Spec
26 Mar 2010   #9
Coco15

Windows 7 Professional 64 Bit OEM
 
 

Quote   Quote: Originally Posted by SafiAmir View Post
ok, i installed a trusted pogram and this thing happend and the system restore sint working...
When you click on them do the shorcuts work or do nothing? What program was it?
My System SpecsSystem Spec
26 Mar 2010   #10
MadMaxData

Windows 7 Enterprise x64
 
 

Quote   Quote: Originally Posted by Coco15 View Post
Sounds like corruption of Icon files. Have you tried reinstalling the programs or repairs and have you used system restore?
That didn't work for me when I was missing icons. Even an application reinstall ended up with missing icons. The only solution I found to work was restoring the registry to an earlier point.
My System SpecsSystem Spec
Reply

 Lost program icons...




Thread Tools




Similar help and support threads
Thread Forum
Lost desktop icons??
Hello! Just discovered this forum... Nice to meet you guys :) I have the leaked beta installed. Somehow, last night I managed (win+D? Not sure) to hide all my desktop items - shortcuts, system icons, files, and gadgets. Now I can't get them back! The gadgets are still running (I know this...
General Discussion
help! lost all desktop icons
i have Windows 7x64 Pro. The system is less than a year old and sparsely populated and clean. This morning when I booted up, Windows opened and none of my desktop icons were present. The Start Menu works and I can get to my programs but how do I restore my desktop? Any help would be...
General Discussion
Lost Icons
Yesterday after applying custom icons, I lost all the icons for all Office programs and pds. I have deleted the iconcache, set program defaults, tried "open with". I tried a system restore to the time before changing the library icons but it wouldn't do anything, it stayed on the "initializing"...
Microsoft Office
Lost My programs icons
hi, i lost my programs icon. outlook, messenger, word, itunes..... how can i return the icons... i attachment the problem of screen.
Customization
ICONS View/Hide program icons for users
How can you remove/delete program icons etc. for one user, not for other. I have my system set up with TWO users; Administrator and one other 'limited' user . When I install programs, icons are on both desktops. If I for instance delete an icon in one user, it also disapears in the other. I...
Installation & Setup
Lost icons after installing
After installing age of empires 3 onto my desktop i lost all my icons weird thing is that the default icons are under then error ones =\ i have uninstalled the game and nothing has changed Anything anyway??
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:24.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App