Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Cyrillic chars instead of Western European

19 Apr 2010   #1

Windows 7 Ultimate 32bits
Cyrillic chars instead of Western European

Hi people of the sevenforums. I'm sorry for this being my first post but I'm having a problem that's been giving me an headache for about 4 days now. Well it seems that all of a sudden my computer started showing cyrillic chars (they seem to be russian) in place of letters with special chars like , or , etc.
This problem is affecting a few programs like bsplayer, quicktime, subtitles, and Team Fortress 2. BSPlayer doesn't even start movies anymore but I don't know if it's related. I've already search on google a lot and did a bunch of things, like editing registry, cleaning it with a regcleaner, installing new MUI and switching between them, scanned with spybot, ESET Smart Security, MalwareBytes... one funny thing that happened to me when I was going to install it was that the part where you choose the installation language appeared in russian with russian selected by default. I also did a search on this site but I found nothing useful.
I've also tried reinstalling the fonts but it did nothing. I uninstalled some windows updates to see if that was the cause but, as expected, it didn't work.
One thing that made me curious was that in the subtitle options of MPC, if I choose ANSI instead of DEFAULT the subtitles show correctly.

Problem examples:

The text is in Portuguese from Portugal btw.
Thanks of any help provided, if you want me to attach the images instead of putting links, ask.

My System SpecsSystem Spec
19 Apr 2010   #2

Windows 7 Better then yours

Hi, well allow your windows updater, after that download all the updates, and even after that, you can see in a list all the language you can download. Test that and see if that works
My System SpecsSystem Spec
20 Apr 2010   #3

Windows 7 Ultimate 32bits

Thanks for the reply. Windows already has all updates installed. I tried installing the russian MUI and change everything to russian, then I rebooted as it was asked, then I switched again to the portuguese MUI but, as I expected, it didn't work... guess I'll have to format :/ What annoys me the most is not finding a solution to this problem anywhere.
My System SpecsSystem Spec

20 Apr 2010   #4

Win7 Home Premium 64x

In Regional Settings go to languages and then details and make sure the default is set to the one you want.

The default might be set wrong and is changing whenever a program runs and says use default language.

I am using XP at the moment so I cant list the exact way to get to the setting.

You can probably type in "Regional Settings" into the Start-Searchbar to get to the main screen then Languages should be one of the tabs or sections. and then look for an option to change the default language. Hope this helps
My System SpecsSystem Spec
20 Apr 2010   #5

Windows 7 Ultimate 32bits

There has been some development in the last few hours. If I choose, for example, Hebrew (Israel) in the current language for non-Unicode programs, bsplayer stops showing those black bars and can play movies again, but the installer for MalwareBytes (the part where we choose the installation language) shows up all written in hebrew. If I set the Language for non-Unicode programs back to Portuguese the part where we choose the installation language appears in russian again and those black bars come back and bsplayer stops playing videos again. Right now I'm trying to delete russian related files from my computer.
Thanks for the reply thorsen btw
My System SpecsSystem Spec
21 Apr 2010   #6

Windows 7 Ultimate 32bits

You can close or delete this. I ended up formatting my pc.
My System SpecsSystem Spec
04 Oct 2011   #7

Windows 7 Ultimate 32bit

I found this post to be the closest related to my problem and, as it is finally solved, I'm posting here my findings, hoping to help anyone else with a similar problem.

The first thing I noticed when this problem started were the subtitles in WMP not showing the Portuguese characters with accents, which became replaced by some weird characters/symbols. When I tried to change the encoding from ANSI to UTF-8 of the subtitle file in Notepad++ or UltraEdit, it was strange that it couldn't maintain the correct characters.

The second thing was a menu of an application, where the Portuguese characters with accents become replaced with question marks.

Finally, when I opened text files in Notepad that have been working correctly before, these same characters were replaced with those same new strange characters. Quite unexpectedly, I could write characters with accents. But, when trying to save these files in the default ANSI encoding, a warning was issued:

This file contains characters in Unicode format which will be lost if you save this file as an ANSI encoded text file. To keep the Unicode information, click Cancel below and then select one of the Unicode options from the Encoding drop down list. Continue?
Everything in "Region and Language" settings was configured to Portuguese (Portugal). I tried to change "Current language for non-Unicode programs" to English and then back again to Portuguese, but with no results.

SOLUTION: Definitely it was a problem with this setting of the system locale, which "controls the language used when displaying text in programs that do not support Unicode".

I checked the registry to detect any suspicious values in the keys that I think are related to this setting:
After a bit of luck I found something wrong in the last 2: the value name "1252" (Western Europe) was with the value data "C_1256.NLS" (Arabic).

Changing both to "C_1252.NLS" solved the problem.

After a quick research I found that the software UST-Pro 2 installation was the guilty for this stupid change in the registry.
My System SpecsSystem Spec

 Cyrillic chars instead of Western European

Thread Tools

Similar help and support threads
Thread Forum
Can you display more than 255 chars on a query report memo field?
Hello, I have a problem with an access database report I am working on. how do I get the memo field of the report to show more than 255 characters? The data is there in the table but when I try to run the report, it cuts off or truncates the data after 255 characters. I went into the query...
Microsoft Office
I need help - My computer does not read Cyrillic
Hi, My computer does not read Cyrillic. I added the Cyrillic font from Region and Language and I can write in Cyrillic but the computer can't read the language ,it shows me this: , . I know that I don't need to install a Cyrillic package on the computer because Windows 7 already has...
General Discussion
DragNdrop of a file from a word2013 doc to desktop adds special chars
Hi, A .txt file is embedded (via the insert-object option) into a Word2013 document 9 (.docx) When I try to view the file by double clicking, it looks good. However when I drag and drop the file from the doc into desktop (or any other folder) and then view the file, a new line with special...
Microsoft Office
must be more than 3 chars--error msg
OK guys, What am I doing wrong? When I try to use firefox to post a msg, i get-after hitting the submit button-a message about the message must be longer than 3 characters. I am NOT a fan of IE, but I'm forced to use IE to post/reply to messages here until I find out "what's up doc?". ...
Chillout Room
Mongolian Cyrillic problems
Hello all, I am currently using Windows 7 with Mongolian Cyrillic option enabled. However, when I try to search programs and files in cyrillic, garbled symbols show up (nevertheless search is completed): A similar...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:35.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App