Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Explorer search problem

16 May 2010   #11

Windows 7x64 Home Premium SP1

after modify here is the screenshot. Under users, the current account user has all folders ticked.
Could you elaborate on your feeling that I have inicated little to index. Thanks for your help.

Attached Images
Explorer search problem-index2.jpg 
My System SpecsSystem Spec
16 May 2010   #12

Microsoft Community Contributor Award Recipient


What I meant is that your previous screenshot showed you have only 351 items indexed. You also told you have over 400 pics on that account. Simple mathematics: it doesn't add up.

Check once more that all user folders and their subfolders are included in indexing.


Attached Images
Explorer search problem-index_modify_2.png 
My System SpecsSystem Spec
16 May 2010   #13

Windows 7x64 Home Premium SP1

I think all the boxes are ticked. Under "Michael" 9,500 files hidden in AppData, 1,000 files that should be searchable.

Advice from another forum (MS) was to quote "In short, Windows Search simply does nor work"... install a good third party tool !!!!!!

How many third party tools do I need to install

Attached Thumbnails
Explorer search problem-index3.jpg  
My System SpecsSystem Spec

17 May 2010   #14

Windows 10 Pro x64 x3, Ubuntu

One other thing to check - use the advanced options on the Indexing Options dialogue and check that the file types you are looking for are included in the search list.

Things such as .JPG should be included but I have seen occasions where these get de-selected.
My System SpecsSystem Spec
17 May 2010   #15

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86

Hi mjf,

A few things to check:

1) For files to be indexed, the folder containing the files must have SYSTEM permissions. These may have been removed. Right-click the My Documents folder. Select the Properties option. Click the Security tab. If SYSTEM is in the Group or user names box, system permissions is not the problem. If SYSTEM does not appear in the Group or user names box, click the Edit… button to open the Permissions dialog. In the Permissions dialog, click the Add… button. In the Select Users, Computers, Service Accounts, or Groups dialog, enter system in the Enter the object names to select box and click the Check Names button. Select SYSTEM from the list of Matching names and click OK.

2) Run an ATTRIB command on the My Documents folder from the command line. Does it have the "I" attrib? That is the indexing exclusion attrib and if so, the folder will be excluded from indexing.

3) Do you have McAffee installed? That sometimes causes this problem. Try uninstalling it completely, then rebuild the index and see if it helps.
My System SpecsSystem Spec
18 May 2010   #16

Windows 7x64 Home Premium SP1

1) SYSTEM permissions are present.
2) ATTRIB "my documents" does not show the "I" attribute. (My Documents is a junction point and I don't really undrstand them)
3) I am running McAfee. Stopping it is ok but completely removing it uses up a license. Probably will dump McAfee when the license runs out.

Some additional info:
(1) I restored an image from a month ago but this time carefully went through the event log and it did report "Catalog is corrupt". Anyway, I can't rebuild the index.
(2) Explorer searches fine from the root, c:\ but not from a lower folder (directory).
(3) From command prompt I can go into any directory and search it and it's sub directories without a problem. Dir *whatever* /s.

I'd be content to do non indexed searches from Explorer if I could start it from a specific folder and not the root.
My System SpecsSystem Spec
20 May 2010   #17

Windows 7x64 Home Premium SP1

In addition to SYSTEM /Users has permission "Everyone" - could this be causing a problem with Windows search/indexing?
My System SpecsSystem Spec
20 May 2010   #18

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86

hello again mjf,

Looks like Windows Search really IS broken. Hopefully sp1 will have some fixes.

As an alternative, there is a great freeware search tool GREPWIN that is accessible via the right mouse button on a folder.

grepWin | Stefan's Tools
My System SpecsSystem Spec

 Explorer search problem

Thread Tools

Similar help and support threads
Thread Forum
Problem using search in windows explorer
Hi. I have read a few posts already regarding this but none appear to be specific to the problem I have, or the solutions tried do not work. When new, my HDD was partioned (C:&D:) 225gb ea (don't know why, thats how it was new!!) up until recently, the search function worked fine. now,...
General Discussion
Internet explorer 8 accelerator and search bar problem
Hi, my first post. I have problem with Internet Explorer 9 (EDIT: title says IE 8.. its not 8) acclerator. After adding Google accelerator, I can't click on the blue button when you highlight on texts. Nothing pops up but when I remove the Google accelerator, it works again. It seems Microsoft...
Browsers & Mail
Explorer Search Bar problem
Hello guys! If I try to search for something (that I know it is on program files, for exemple) on "C:" using the explorer search bar, it stays a long time searching and bring me back NO results... But, if I go to program files folder, it almost bring me the result instantly! I don't know...
General Discussion
Explorer Search Problem !!!
Hi, I've installed windows 7 on my PC more than a year ago. Everything was working fine. But from the past few days I'm noticing that whenever trying to navigate a file by pressing any letter from keyboard in windows explorer it starts searching instead of highlighting that file/folder. ...
General Discussion
Windows Explorer search behaviour problem
Hi, I have found this strange little bug in the quick search feature. There are pictures on my CompactFlash memory. I was searching for a specific file (with the number "2755" in the name), and the search gave me no results. After manual search, i found it: But still, the Search can not...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:00.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App