Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: takeown only works on some files

10 May 2010   #1

windows 7 ultimate
takeown only works on some files

Hi everyone, I'm having a problem with the takeown command or with permissions in general.

I installed 64-bit Windows 7 Ultimate Version 6.1 (Build 7600) on a new machine that I built. I'm trying to copy files from my old hard-drive to the new one, but am having permissions problems.

After some research, I opened a command prompt as an administrator, and ran

takeown /f dir /a /r

On the dir I was trying to access. After that I moved the files to the new drive. It worked for the vast majority of files, but for about 100 of them it didn't. I tried running takeown on individual files, but even though it reports success:

SUCCESS: The file (or folder): "e:\Documents and Settings\User\Desktop\rnd.txt"
now owned by the administrators group.

I'm not able to do anything with the files - "access is denied".

There doesn't appear to be any consistent type of file or location that this fails with. Some .txt and .xls files, some .mp3, etc, when it worked with plenty of these file types already. Does anyone have any ideas? I'm hoping I'm just missing something obvious.

Thanks in advance.

My System SpecsSystem Spec
10 May 2010   #2

windows 7 64bit

My System SpecsSystem Spec
10 May 2010   #3

Microsoft Community Contributor Award Recipient

Win 10 Pro x64

Quote   Quote: Originally Posted by MDR View Post
404 error on that link
My System SpecsSystem Spec

10 May 2010   #4

windows 7 ultimate

Searching there only turned up a bunch of vista links. But I found a similar thing here:
Add Take Ownership Option Shortcut in Right Click Menu of Windows 7

I installed it and for some reason that works when the command line didn't. Still, it's done, so thanks.
My System SpecsSystem Spec
10 May 2010   #5

Microsoft Community Contributor Award Recipient

Win 10 Pro x64

Glad to hear you got it figured out.
My System SpecsSystem Spec

 takeown only works on some files

Thread Tools

Similar help and support threads
Thread Forum
Help with 'TAKEOWN' command
I am trying to take administrative ownership of a folder and it's subfiles. I cannot get cmd and the takeown command to find the file path. Here is what I've tried: TAKEOWN /F C:\ProgramFiles\xxx\xxx\xxx TAKEOWN /S system U/ xxx P/ xxx /F C:\ProgramFiles\xxx\xxx\xxx neither is working, I...
General Discussion
takeown cmd to recover harddrive files?
My cousin's laptop recently went to crap. The windows system startup folder got corrupted. Anyway, I pulled the harddrive and plugged it into my desktop to pull off her personal files (System restore/repair with CD did Not work) Anyway, I got it to show up fine on my machine, but every single...
Hardware & Devices
Are changes permanent using takeown/icacls?
As the title states, are changes permanent using takeown or icacls? Does it weaken windows security? I'm asking because sometimes, when I make a "lite" version of 7, I need to remove several files that require ownership. Instead of just applying onwership to those files only, I usually end up...
General Discussion
Sharing with XP PC works for some files but not others
I just introduced a Win 7 Pro PC into a small business network containing a few XP machines and an XP server. I have a microsoft access file that I want to open on the new Win 7 machine. It, and many others very similar are on the server. When I navigate to the server through the network or through...
Network & Sharing
Old Works wps files
I am setting up a new desktop for a friend which comes with Works 9 pre-installed. I have transferred a large number of documents from the old machine using Windows Easy Transfer. Many of those files have the extension wps having been created with an older version of Works (although he cannot...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:09.
Twitter Facebook Google+