Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unable to edit files in ZIP folders

28 May 2010   #1

Unable to edit files in ZIP folders

Win7 has this neat feature where I can navigate into a compressed (zip) file from Windows Explorer. The icon appears like a folder with a zipper through it & I can just navitage where I please.

However, I can't edit a file in the zip folder directly. I have to first copy it out of the zip, edit it, then copy back into the zip. What am I missing here? If I can overwrite a file why not just allow me to edit it?


My System SpecsSystem Spec
28 May 2010   #2

Windows 7 Ultimate (x64)

Zip is one of the several existing formats for "archive" files. These files are typically compressed to save space and simplify data transmission. Although Windows treats them as folders (a feature that I personally prefer to disable), they are not really folders. One can extract files from an archive or add files, but I've never heard of a possibility to edit files still in an archive. Maybe there is a third-party software that opens an archive, un-compress it (i.e. unzip) to some temporary folder, then allows you to edit files in this temporary folder and at the end puts the archive back together (i.e. zip the files from the temporary folder into a new archive of the same name). But I don't know any. Maybe someone else can suggest something.
My System SpecsSystem Spec
28 May 2010   #3
DarkStar GT

Windows Home Premium (64)

You're missing nothing (it was the same in previous Windows incarnations).

The "compressed folder" is really a single file, it just looks like a folder and files. What I do is drag the file out to the Desktop, edit it there, then drag it back in. The advantage is that you are working on a separate copy of the file too.
My System SpecsSystem Spec

24 Sep 2012   #4

Windows Vista Home Premium

7-Zip (7-Zip) is a freeware third-party program that does, in some cases, allow you to alter files and save them in-situ. That is, the file is updated in the zip file archive. It is a two stage save: first it asks if you want it saved in the temporary folder, and then it asks if you want it saved in the archive.

The problem I have encountered is that it works for .txt and .rtf but not .odt (OpenOffice Writer) which I use. I have not tried it on Microsoft Word, Excell, etc. Hence I rarely use it.

Hope this helps.

For some non-rational reason I keep looking for a Windows version of IMB's PDS--Partitioned Data Set. I think I just became so familiar with PDS files when working on a mainframe that I missed them. Really the Folder/File system is very similar, and the ZIP/in-situ-save is even closer. So I just keep looking when I am bored.

The same goes for IBM's ISPF, but even more so since precious few Windows editors have the same line/column range editing capabilities. There are one or two freeware versions of ISPF, but they are not as robust as the IBM version.
My System SpecsSystem Spec

 Unable to edit files in ZIP folders

Thread Tools

Similar help and support threads
Thread Forum
Unable to open folders and some files ????
A couple of days ago I noticed that Google Chrome was being a bit odd by not always opening as it should when clicked. Today things have gradually gone from bad to worse. I am now unable to open My Computer, Folders, Recycle Bin, and Text Files. Things like Photoshop, FLV files, PDF files will...
General Discussion
Unable to edit music files in Media Player transfered from old laptop
Hi All I had an ageing Vista laptop that developed a hard drive problem so I now have this great new 7 one. I am fortunate in that I work for a local computer company so I was able to salvage music etc. My issue is that I am unable to edit anything that was recovered from my old laptop in...
Music, Pictures & Video
Unable to delete certain folders and files, lacking permissions.
Hey there 7 Forums, I'm just coming from another post that was solved for me, in the hardware section, this time, with a permissions issue. I have a hard drive, that has some files from my old windows vista installation (which is now cleared) These files include things like many coppies of...
System Security
Unable to see windows 7 shared files/folders on my macbook
Hi guys, I have my mbp for 9 months, snow leopard should find automatically every pc on the network but It never found my home desktop everytime, only some times. but I could easily connect to it using automount maker or in finder with go -> connect to server. I haven't change anything (at...
Network & Sharing
Recently unable to delete some files/folders
Hi guys, I don't know if it's an update issue or a tweaked service, but over the past month or so, I've noticed that it's getting harder to delete some files and folders. It says it's in use, etc and can't be deleted (even after restarts, etc)...just random files/folders from my work (design and...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:26.
Twitter Facebook Google+