Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Permissions Nightmare

31 May 2010   #1
Serexx

Windows 7
 
 
Permissions Nightmare

Greetings - I jumped from XP to W7 and am having real problems getting my system setup because I keep running into permissions problems when trying to install programs.

Latest example: I downloaded RIA Services 1.0 to use with VS 2010 and Silverlight and, despite the fact that I am the only user on the machine, and should therefore be an Administrator and have set "User Control : Behaviour of the Elevation Prompt for Administrators in Admin Approval Mode" to "Elevate Without Prompting" any attempt to install RiaServices.msi is met with a prompt the I need to obtain permission form an Administrator to install the program.

I have also Disabled "User Account Control: Detect Installations and prompt for Elevation" with no apparent effect.

I have also downloaded and installed the 'Take Ownership' Registry patch and used that to no effect.

I would greatly appreciate some help with this, beyond being referred to the overwhelming abundance of tutorials - the truth is I just have not go the cycles to absorb all of that info at the moment - I just need to get this thing installed and running....


My System SpecsSystem Spec
.
31 May 2010   #2
Bare Foot Kid
Microsoft MVP

W 7 64-bit Ultimate
 
 

Hello Serexx, welcome to Seven Forums!



Have a go at running the installer in "Run as Admin ..." right click the installer and select run as, have a look at the snip below; click the image to enlarge; be sure to post back so we know if it'll work for you.
Permissions Nightmare-raa.jpg


My System SpecsSystem Spec
31 May 2010   #3
Bare Foot Kid
Microsoft MVP

W 7 64-bit Ultimate
 
 

If that doesn't work try installing it in compatiliblity mode with XP, right click the installer and select properties at the bottom of the context menu, then select the "Compatibility" button like in this snip below.
Permissions Nightmare-comp.jpg


My System SpecsSystem Spec
.

31 May 2010   #4
Serexx

Windows 7
 
 

Thanks for both of those -

On the first one - on my system the context (right-click) menu doesn't show "run as" or "Install as" options, there is only "install"

I also tried compaitbility mode "Run this program in compatibility mode for : Previous Version of Windows" (the only option available).. same result - it tells me I must be administrator

Sorry, back to the drawing board....
My System SpecsSystem Spec
31 May 2010   #5
Bare Foot Kid
Microsoft MVP

W 7 64-bit Ultimate
 
 

You are not the system administrator?
My System SpecsSystem Spec
31 May 2010   #6
WindowsStar

Windows 7 Enterprise (x64); Windows Server 2008 R2 (x64)
 
 

Serexx, please take a moment to fill out your system specs, please make sure you include the version of Windows 7 you are using (Windows 7 Starter, Home, Professional, Ultimate etc.).

How much tweaking have you done to this system before posting here? If you have done some major changes we may not be able to help you. Once some permissions have been changed or ownership has been taken without full understanding what and how it will impact the system can cause a lot of issues and make it very hard to repair. These changes can give you problems now or will give you many in the future.
My System SpecsSystem Spec
31 May 2010   #7
Serexx

Windows 7
 
 

thanks - for now I hit the 'aw heck' switch and turned UAC off. With a restart that allowed me to run this particular msi.

Having said that I would like to have UAC back on at some point, so if we can walk through this I would be grateful... here is all the info I have at this point - I have only had the machine for a couple of weeks and have not fiddled much beyond app-based settings.


Windows 7 Pro 64 Bit (OEM From Dell). It is on a two-station Workgroup. In relation to Perms/Ownership I have taken the following steps:

1. Manually "took ownership" of the parent folder and the .msi file itself. That didnt work so

2. downloaded and installed the Microsoft "TakeOwnership" patch (provides 'take ownership' option in r-click menu). Executed on same two objects. No luck so,

3. In local security policy, local policy, security options, user Acclount Control Settings are as shown on the attached screenshot (let me know if it didnt upload).

4. tried your suggestions (thanks)

5. as mentioned turned UAC Off (slider to the bottom) and rebooted

Hope that helps you help me ;-)

PS - the Administrator account itself is disabled - I may have turned that off when it first arrived, not sure.


Attached Thumbnails
Permissions Nightmare-useraccountcontrolsettings.png  
My System SpecsSystem Spec
31 May 2010   #8
Bare Foot Kid
Microsoft MVP

W 7 64-bit Ultimate
 
 

I know you said no tutorials but you'll want to have a look at the one at the link below, this way you can keep UAC at default settings if you choose.


Elevated Program Shortcut without UAC Prompt - Create
My System SpecsSystem Spec
31 May 2010   #9
Serexx

Windows 7
 
 

PS - two items

just noticed the 'my specs' button on the forums page - here is the output from that:
OS Windows 7 Enterprise (x64)
Memory 8GB
Monitor(s) Displays 2 Dell 19" LCD
Screen Resolution 1280x1024

Keyboard Dell
Mouse Dell Optical
Internet Speed 40meg







2. I also just noticed your question as to whether I was not the Sys Admin - I am the only user on the system so I made the ASSumption that I would be in the Administrators Group but maybe not ....
My System SpecsSystem Spec
31 May 2010   #10
Bare Foot Kid
Microsoft MVP

W 7 64-bit Ultimate
 
 

Quote   Quote: Originally Posted by Bare Foot Kid View Post
I know you said no tutorials but you'll want to have a look at the one at the link below, this way you can keep UAC at default settings if you choose.


Elevated Program Shortcut without UAC Prompt - Create



Just to make sure you see this.
My System SpecsSystem Spec
Reply

 Permissions Nightmare




Thread Tools




Similar help and support threads
Thread Forum
WLM nightmare
Every time I go to set someone up with a live mail account and use their in existing email address the wretched program will not accept the address they already have and keeps requesting that it has to be set up as a hotmail one. If I ask it to use their own address it comes with some rubbish...
Browsers & Mail
2nd Monitor nightmare!
For several years I have used 2 monitors without any problem. A few days ago I decided to replace the 2nd monitor connected by VGA cable for a new HP x2301 MicroThin LED Bright View. My main monitor is a HP x2558hc connected to the desktop HDMI socket. The video card is a NVIDEO GeForce 8600 GS...
Graphic Cards
ICS Nightmare! (pls help!!)
HELP!! (please) :shock: I don't know what else to do.:rolleyes: I have tried many different options and searched the net for similar issues but I haven't yet found the way out (or any hint to pintpoint the source of the problem) The problem: I have a desktop connected to Internet through a...
Network & Sharing
Bootloader nightmare
So I'm having some trouble with the windows 7 bootloader. I have a dual boot system with Gentoo Linux as the other operating system. I have Linux installed on partition 1, swap on partition 2, Windows on partition 3, and a storage drive as partition 4. Partition 4 was NTFS format, but I...
Backup and Restore
BSOD Nightmare!
Hey everyone! I've been getting BSOD's ever since last week and it's been a real annoyance. I really don't know what prompted these BSOD's; perhaps it had something to do with my weekly anti-virus/spyware updates. I've even taken desperate measures and re-installed (clean install, by the way)...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:14.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App