Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Command prompt won't open

26 Jun 2010   #1

Windows 7 32 Bit
Command prompt won't open

I'm running 32 bit Windows 7, and when I run cmd.exe or click on the icon in the System32 folder nothing happens. I checked the task manager and the process is running but no window displays. Any ideas?


My System SpecsSystem Spec
26 Jun 2010   #2

Vista 64 Ultimate, Windows 7 64 Ultimate, Ubuntu 9.10

Try this, go to Start and type cmd in the lower bottom box, when it appears in the upper window right mouse click and run as administrator, you can also make it a shortcut to cmd on the desktop or in the Taskbar set to run as admin.
My System SpecsSystem Spec
26 Jun 2010   #3

Windows 7 32 Bit

yeah i had tried that, but it has the same result, nothing happens. strange right? i have like 15 cmd.exe processes running in the background now according to the task manager haha
My System SpecsSystem Spec

26 Jun 2010   #4

Vista 64 Ultimate, Windows 7 64 Ultimate, Ubuntu 9.10

Yikes, this answer comes from another forum and has solved this issue, if you feel comfortable working in the Registry you might want to give this a go.

This problem may be also caused by the policies keys. You can use the followling method to remove the policies keys:
Remove Group Policy
1. Click Start, type REGEDIT in the Start Search bar and press Enter.
2. Locate the following key in the left pane:


3. Highlight “Microsoft” folder and click "Delete".
4. Repeat to delete the following keys:
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Group Policy]
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Group Policy]
If some keys do not exist, please ignore them.
If the issue persists, you can run an in-place upgrade to repair the system.

In-place Upgrade
1. Insert the Windows 7 DVD in the computer's DVD drive.
2. Click Start and choose Computer.
3. Please find the "setup.exe" file in the DVD-ROM and double click it.
4. Click Install now.
5. When we are prompted to input the product key, please click Next without inputting any key. The setup wizard will prompt and ask if you agree to install Windows Vista without the key. Please choose to confirm.
6. When you reach the "Which type of installation do you want" screen, click Upgrade to upgrade the system files of Windows 7.
My System SpecsSystem Spec
26 Jun 2010   #5

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86

Run a scan with MBAM.

My System SpecsSystem Spec
26 Jun 2010   #6

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install


I know that you were given the instructions in the first post, but I have seen this before, make sure you are doing this exactly.

Elevated Command Prompt

The problem in the similar thread was that the OP was using the run command to ask for cmd.
My System SpecsSystem Spec
26 Jun 2010   #7

Windows 7 Ultimate 64 bit

Some thoughts:

1. It's been disabled: Open GPEDIT.MSC and check that it hasn't been disabled (see attached pic) and navigate to User Config | Admin Templates | System.
2. It's off Screen: if it appears in the taskbar, hold down the shift key and right click on it, select MOVE and move it somewhere that you can see it.
3. Run it as a seperate memory process: Type CMD into SEARCH, right click on it and send it to the desktop (i.e. create a shortcut). Right click on the shortcut and select properties, On the shortcut tab select ADVANCED. On the Advanced window, tick the box "Run as Administrator", leave the separate memory space box ticked. Press Ok, OK. and try your new shortcut.
4. You have a nasty virus: Install UNHACKME, the trial installs a full version for a few days, although I recommend that you buy a copy. As a system admin, I use this in the business environment as well as at home. This will check for rootkits and other virus' which are likely to disable CMD.



Attached Thumbnails
Command prompt won't open-gpedit.msc.png  
My System SpecsSystem Spec
26 Jun 2010   #8

Windows 7 32 Bit

so I've tried all of the suggested solutions except the registry deletions but they have all yielded the same result. they all add a cmd.exe process but none display a window. the malware scan yielded a few results but none made a difference. I will do the registry deletions if there is confidence it will work and if there are no other ideas.

thanks again everyone
My System SpecsSystem Spec
26 Jun 2010   #9

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install

If you decide to go with registry

Make a system restore point first


Back up the registry

You mess with registry and there is no back up, its bad.
My System SpecsSystem Spec
26 Jun 2010   #10
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8

As an alternative, you can try to run the Windows Power Shell. You find that in All Programs > Accessories. But you have to also run it in elevated mode - easiest is to right click on it > Properties > Advanced button > tick the "Run as Admin" box > OK > Apply. Now it will always run in elevated mode. Now you can use it to execute the cmd commands. If you type in help, it will show you all the commands possible.
My System SpecsSystem Spec

 Command prompt won't open

Thread Tools

Similar help and support threads
Thread Forum
cant get windows 7 pro to open a command prompt
I bought computer that I do not know password. I dont want to reinstall windows. I read that restarting computer and press f8 and choose safe mode with command prompt. Problem is my computer loads the drivers as normal on the black DOS screen but when it gets done and is suppose to give a command...
Installation & Setup
Command prompt - open problem
I have installed Windows 7 Pro x32 and I'm in corporate lan (domain), but I have admin rights. After a while I can't open command prompt, but cmd.exe and conhost.exe can be found in Task Manager. What have I tried until now without luck: - remove policy keys - upgrade Windows 7 - run as...
General Discussion
Command Prompt Won't Open
I was messing around with the command prompt, trying to make a script to scare the shit out of my friend when he opens it. I entered the following code, under the assumption that it would make the prompt go full screen. 0x4,"Console","FullScreen", 0x1 After I hit enter it asked me if I...
Command prompt won't open!
Hi. Segref here, another newbie.:mad: I can't quite figure how to post without replying, so here goes. I am running 7 build 7600. When I try to open the command prompt as administrator Windows goes to the User Account Control. I say yes and am returned immediately back to the desktop or...
General Discussion
How to open Elevated Command Prompt?
Hi friends ! Uber Philf told me to start a new thread with my problem. I cannot open an Elevated Command Prompt, Dont know why. I know that I can open it in two alternative ways : 1). Win+R, type cmd, hit enter eith ctrl+shift pressed ; and 2). start > all programs > accessories > command prompt >...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:39.
Twitter Facebook Google+