Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Problem with locked EXE files

01 May 2012   #21

XP X64 SP2, back up of Win7 RTM

Did this get solved? as I'm having the same problem, I already have Program Compatibility Assistant Service running though.

My System SpecsSystem Spec
01 May 2012   #22

MS Windows 7 Ultimate SP1 64-bit

Please start your own thread, stating your problem and particulars.

Thus we will be able to direct our answers and efforts to solving your problem.

Your consideration and cooperation is appreciated,
My System SpecsSystem Spec
19 May 2012   #23

Windows 7 Ultimate x64
My Experience of the Same Problem & Fix Result

I am very knowledgable of PCs and Windows which means that I can fix nearly all faults, usually without too much trouble, in fact I'm often called to fix problems on friends and neighbour's PCs. I have however experienced exactly the same problem with the system locking files for up to a couple of minutes on Windows 7 x64 and I've been tearing my hair out trying to fix it for months. It has caused all sorts of problems, too many to list, for example LOTRO (Lord of the Rings Online) failed to update as it couldn't update the main EXE due to it being locked, unfortunately the updater then fell over without letting me retry in a few minutes which would have worked as the lock lasts about 1-2 minutes. This left the game in a state where it couldn't even run the updater again and I had to download a special standalone updater to allow me to attempt the update again which still failed every time with exactly the same problem. I eventually managed to work-around the problem by renaming the problem EXE after waiting a couple minutes for it to unlock before running the downloaded stand alone updater. Even a Windows update (a security update for NET framework 4.0) failed today and when I looked up the error code it was because it didn't have the required permissions (almost certainly the same problem), luckily after reloading Windows it worked on a second attempt, but this problem is now really bugging me and I just know that eventually it will most probably cause something very serious to fail that could be a lot more difficult to fix / workaround.

I have tried numerous things to attempt to resolve the problem including disabling my antivirus software (Comodo Internet Security) and so many other things that I could write for ages. I refused to reinstall Windows as this would be a massive amount of work with all my applications + games and it's an overkill solution that still wouldn't have diagnosed the real fault. Obviously re-installing Windows wouldn't even guarantee that the same fault wouldn't return in future either as one still wouldn't understand what triggered it in the first place and this would put me back to square one.

Finally I have actually found a post that is actually useful after lots of searching useless forums and websites. I have set the Application Experience service to Automatic and have started it as suggested on a previous comment, it was disabled as I am a Windows tweak buff and normal documentation suggests that this service isn't normally essential. After running some tests the problem appears to be resolved, I will know for certain after a lot more testing over time, but it's certainly looking very good so far (I will update). Assuming this is the fix I'm very surprised that it's not documented anywhere properly, Microsoft should obviously reword the description of this service to make people aware that it is an essential part of Windows where disabling it may cause serious problems. The current description, "Processes application compatibility cache requests for applications as they are launched" doesn't sound essential as normally caches are optional although sometimes they can improve performance, but waiting up to a few minutes for a file to become unlocked without it is a lot worse than just poor performance as it causes all sorts of errors and problems.

Thankyou very much for the very useful information. :)
My System SpecsSystem Spec

17 Dec 2012   #24

Windows 7 Enterprise x64

After long searching for exactly the same issue on W7 Enterprise x64 i stumbled upon this and would like to thank you for resolving this.

I can confirm pjcnet, some Windows Service (which i disabled for performance considerations) is partly responsible for this, as confirmed via Local Windows Debugger. I have no explanation for this effect, but it does not happen when the Application Experience Service is active.

What i could not yet clarify is wether this is a side-effect of COMODO Internet Security Software or does happend on plain Windows installations, as yet only reported on peple who have or had COMODO installed (including me).

However, the workaround (enabling the service) does work and im glad i can finally use my windows again

Even more keywords for Google so others find this: windows executable lockdown, exe, bat, insufficient rights, cannot delete, unable to delete exe files
My System SpecsSystem Spec

 Problem with locked EXE files

Thread Tools

Similar help and support threads
Thread Forum
Problem with locked EXE files
I have this problem where my .exe files get locked by explorer so I canot update programs. I can sometimes delete the .exe file and usually can always use unlocker. It's the same problem these people have had
General Discussion
Locked out of files.....yes another one of those
I'v been here multiple times and you guys always help me when i need it but i have been searching for the solution for a while and still not success when i built a new comp i hooked up my harddrives and had access to some files but not all and made due with what i had and would eventually come...
General Discussion
files locked!
i have just discovered a folder in my music folder that contains about 18 albums all of the files within are locked how can i change this ,i have tried to change permissions in the properties /security but no joy any ideas?
General Discussion
All my files are locked? AHH!!
Ok, this is a nightmare. I do a lot of photoshop graphics for work. I open a file in photoshop and edit...then save....WRONG!! It says I cannot save because it is locked. ALL MY FILES ARE LOCKED? How do I correct this insanity?
General Discussion
Windows 7 locked some of my files !
Hello I changed my Windows 7 Beta to Windows 7 RC1. Now some of y files are locked . I solved the problem : Right Click on locked file > Properties > Security Tab > Advanced > Permissions Tab > Continue > Check "Include inheritable" But I should do this for files one by one !:sarc: How...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:40.
Twitter Facebook Google+