Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 64 bit doesn't have WIA. Why?

14 Jul 2010   #1

windows 7
Windows 7 64 bit doesn't have WIA. Why?

I just put on 64 bit windows 7 as a dual boot with my vista. i found out the hard way that Image Acquisition service isn't installed. i installed sony vegas 9 64 bit and it requires this service to start. I was wondering if this service could somehow be put on. (doesn't even show up in services, though it is there in vista 32 bit).
this is probably a fairly obscure topic, but i thought i'd put it out there and see if anybody has any insight into this!


My System SpecsSystem Spec
14 Jul 2010   #2

Vista 64 Ultimate, Windows 7 64 Ultimate, Ubuntu 9.10

If you have either, Professional, or Ultimate, version of Windows 7 you can use XP Virtual Machine. I don't have any problems with my Windows 7 32 bit Professional, 64 bit Professional or 64 bit Ultimate seeing any of my imaging devices nor any of my imaging software. I am not familiar with your Sony Vegas so I don't understand what problems you are having and if you would care to elaborate perhaps I, or another, can help you further, it would also be of great benefit were your complete specs filled in as well.
My System SpecsSystem Spec
14 Jul 2010   #3

windows 7

thanks for the reply.
Ok, i'm using an acer 6530 laptop, 4g ram, athlon x2 ql-90.
Sony Vegas is a nice piece of video editing software I use in vista, so i thought i'd try out the 64 bit version in windows 7 64 bit. but i keep coming up with an error starting up that 'wia is missing'. not sure why. it's a standard windows 7 installation (only 2 days old!) so i thought all the services would be there.
someone said there shound be a 'stisvc' entry under 'HK Local Machine\System\CurrentControlSet\Services\".
I don't see such a listing. are you using windows 7? do u have such an entry.
so, that's basically it, i don't have Windows Imaging Service listed under services and i'm wondering why. I installed all the updates, by the way. everything works fine under vista, but i was told 7 is even better, so i'd to get vegas working in it!
My System SpecsSystem Spec


 Windows 7 64 bit doesn't have WIA. Why?

Thread Tools

Similar help and support threads
Thread Forum
Windows repair doesn't detect unbootable Windows as installed
Hi, I'm not sure if it's the correct section, but I have a big problem I need to fix ASAP. I'll describe it from the beginning: 1. PC with Windows 7 x64 worked completely fine one day, I used the sleep functionality. 2. The next day I woke it up. At the first sight everything was ok, logging...
Installation & Setup
My bluetooth doesn't work. bttray doesn't open.
Hello. I am quite new here, but I've been wanting to get this problem solved for a long time, and I haven't seemed to get any answer. So here's my problem: I bought my Asus N53SV for around a year ago, and it worked great. But for some reason something changed. When I try to open bluetooth,...
Windows 7 doesn't see my SSD...
Hello all, I am trying to install Windows 7 Professional 64 bit on a Kingston HyperX 240Gb SSD. The motherboard is an ASSRock Extreme4 Gen3. I've set my SATA3 port in ACPI mode, but still, Windows 7 simply cannot find my SSD. When I press install it says "A required CD/DVD drive device driver...
Installation & Setup
HELP: power option doesn't work - screen saver doesn't start!
I have an ASUS notebook running windows 7 64-bit. I am using the QuietOffice power profile, however the screensaver won't kick in no matter what I do, and the display does not turn off even though I set it to be after 5-minutes of inactivity. I don't know if there is something running in the...
General Discussion
Windows 7 doesn't use all its ram
Hello everyone, I have tried searching around, but haven't found anything useful. I just installed 2 extra sticks of DDR3 ram in my mobo. In total there are 4gbs of ram. Windows 7 recognizes it, but will only use 2gb of it. I am using Windows 7 64bit Ultimate. Would I need to reinstall it or...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:57.
Twitter Facebook Google+