Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Changing read only settings on folders

21 Jul 2010   #1

Windows 7 X64 Professional
Changing read only settings on folders

Hi all, I am new to Windows 7 and am having a problem with my setup.

My computer is used as a CAD station and connected to it is a 1 TB external (USB) drive with all my CAD files on it.

For some reason the folder that has all these files in it is set to read only (F:\NEW)

When I uncheck the box and click apply, everything seems to work though as soon as I click ok the folder reverts back to read only this is causing me a major problem as when using the CAD software (Solidworks) I cant save any changes made to exisiting files.

Has anyone got any ideas?



My System SpecsSystem Spec
21 Jul 2010   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Hi Craig ! Welcome to SF !

You may have a try ( may be you have tried it). Right click on the folder, select properties (at the bottom of the context menu) . You will get the folder properties window.

In the folder properties window, at the bottom there is attributes. Uncheck Read only, apply and then ok .

Read-only File and Folder Attribute

If it does not work, you may take ownership of the folder using . ( Unzip, double click install take ownership.reg to merge it with registry, right click on the target folder and click take ownership in the context menu. It will take a bit time depending the volume of the folder) .

Dont forget to post back what happened .

My System SpecsSystem Spec

 Changing read only settings on folders

Thread Tools

Similar help and support threads
Thread Forum
Changing a file to read-only does not remain read-only
I'm having the opposite problem from most of what I have read here. I am trying to set a file to read-only. Each time I do, the next time I open explorer the check-mark is gone making it writable to again. The file is an LSO that (if I delete it) regenerates itself. I have tried to change the...
General Discussion
how to read Russian without changing OS language
hello. I bought new PC and Installed windows 7 ultimate x64. This is my first x64 and I encountered a problem reading Russian texts. I have english US set as OS language. I googled a lot and everyone says the same: "In order to read Russian, change display language to Russian-Restart PC" I've...
General Discussion
Changing External HDD letter made it 'read-only'
OK first of all, for some reason - a few days ago - the drive letter of my External HDD had changed from I:\ to J:\ without me realising this. The only way I found out this had even happened was while I was wondering why MusicBee couldn't find any of my music on my External HDD - since the file...
General Discussion
Font size changing whenever changing settings in personalization.
Hello sevenforums! I have a problem with my computer i recently purchased. Here is my story. This all started whenever I wanted to change my text size different by changing my DPI settings. What I did was right click, go to screen resolution, and clicked on "Make text and other items larger or...
General Discussion
Problem Changing Permissions of Folders and Files; e.g. read, write
On Windows 7 we have UAC which I have set to notify me only if others want to make changes to reduce the popups. I am the only user, the administrator, logged in as such and yet changes that I make to folder and file permissions do not "stick." Changes are apparently made but they default back...
System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:30.
Twitter Facebook Google+