Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: cannot add program to Open With menu

31 Oct 2010   #21

Win7 Prof. x64

I had this exact problem quite a few times and it was always with programs I updated at some point or of which I installed a new Version at another location. For example, I had two versions of Notepad++ on my PC and deleted one version.
As it turned out, the version I deleted was the version, that was originally associated with my .txt files and therefore in the "Open With" context-menu. Now that I deleted (or uninstalled, I'm not sure) this version, it didn't show up in the open with menu, but I couldn't add the new location either.

And here is a solution, that worked for me!

I downloaded the program OpenWithView and looked at the standard entries of my open with menu. And there it was, an entry referring to the old location of the program I deleted. A simple rightclick -> disable in the OpenWith program and I could add the new program-location the normal way that has been described in this thread approx. 30 times. (right click on file -> open with -> choose program -> select exe -> voilą, program is in the menu)

I hope this helps some people, who stumble upon this thread, looking for a solution of this annoying bug/situation/progblem..

My System SpecsSystem Spec
06 Aug 2011   #22


@ SlushPuppy

Thank you for your great advice...

You Sir, helped me big time because this error had annoyed me for a past few days........

Thanks a ton
My System SpecsSystem Spec
20 Oct 2011   #23

win 7 x64

thank you!
My System SpecsSystem Spec

19 Nov 2011   #24

Windows 7 Pro x64

I'd re-installed the software into different location to fix another issue and broke the association.

I uninstalled and re-installed into the original location and all's well.

Thanx slushpuppy.

My System SpecsSystem Spec
28 Jan 2012   #25

Windows 7/ Ubuntu

Is there a Group Policy blocking it? Which one?
Is this a bug? If so where to report it to Microsoft?

I have this problem too with one big exception: It only happens when my programs are installed on a second hard drive. I have a number of programs such as Firefox storing everything on my P:\ drive so that I don't lose the settings when I reinstall Windows or boot into another version of Windows. It's also great for easily copying them to a USB drive or syncing with Dropbox.

However, when I try to "Open with..." one of these programs Win7 refuses to add it to the dialogue box or open it. I also cannot associate it via Control Panel. Using Registry fixes or "OpenWithView" or another program, "FileTypesMan," is a big pain but I'll do it if necessary.
My System SpecsSystem Spec
28 Jan 2012   #26

Windows 7/ Ubuntu

I found a solution! It's an external program called "OpenWithAdd" here Registering programs with the "Open With" dialog It hasn't been updated since 2007 and says it's compatible with XP and Vista. But it worked! Even worked on my second hard drive.

FYI if you have any problems just right click the program and Run it as Administrator... but I had no problems. Very easy to use.
My System SpecsSystem Spec
03 Mar 2012   #27

Windows 7 Ultimate (32 bit)
Registry Cleaner

cleaning the registry using a registry cleaner program would suffice. :]
My System SpecsSystem Spec
06 Oct 2012   #28

Windows 7 Ultimate x64

Just a note to say I had the same issues as the OP and the external program called "OpenWithAdd" as described by mmmelaney in post #26 above worked for me after several hours of tweaking the registry etc.
My System SpecsSystem Spec
07 Oct 2012   #29

Windows 7/ Ubuntu

@redcard: So awesome to know when I've helped someone. Funny thing is I was just here the other day because I forgot my own solution! A quick google brought up a familiar post from a girl griping about it, and Voila! That girl was me.

@SlushPuppy: I use OpenWithView all the time but, unfortunately it doesn't change the file association permanently, just the programs in the right-click>>Open-with... list. The same developers have a program called Filetypesman that can be used to change most file types (though Windows7 still hides and holds on to some like a greedy rat.) It still doesn't get the program to show up in the Open With>>"Choose program" box after browsing either.

@wysiwyg: Shell:sendto doesn't change the file association or the "choose program" box. You are stuck with using right click>>sendto forever.

VLC is particularly plegged with this problem on my 64bit machine. I even have it installed on the C drive (unlike my other misbehaving programs.)

What I really wish is that I could excommunicate Windows Media Player from the Open With... list. But my registry editing attempts so far have only lead to failure. I can't uninstall WMP either because I use Media Center for TV recording, which relies on WMP. God forbid you accidentally open an mp3 with it. It will scan your entire computer for audio and add 10's of 1000's of .jpg album art files to the folders, slowing your computer to a crawl whenever you browse them. (My album art is embedded within the files by Mediamonkey.) I've found no one who has solved this problem so I simply point the "My Music" library to an empty folder for now.

Back on topic anyway, OpenWithAdd is still the simplest solution I've found for adding programs to the "Choose Program" box when they refuse to be browsed for. I'm thankful to the developers.
My System SpecsSystem Spec
28 Dec 2012   #30

Windows 7 home premium 64-bit

@ mmmelaney

I hope that you eventually find this post.

First, thanks for the link to a must-have program. That thing should be a basic part of everybody's windows PCs.

Anyway, I have had somewhat similar problems to what you're describing. My first & only recommendation is to use a registry patch file to get rid (mostly) of the "Libraries" junk in Windows 7. (If you're Windows 7 is a 64-bit, & it sounds like it is, you'll have to run task manager at the same time, kill the explorer process before you run the registry patch, & then run explorer as a new task again). I don't know if you're a fan of the libraries junk, but I couldn't stand it. If you do do this, be warned that it will kill a lot of your "Start menu" entries, but the way that I 'fixed' that (sort of) was to make a new folder named "Start menu" at the desktop level, & put links to everything that I wanted links to into that. Even the "Run" command can put into it by just dragging it (literally) from the old Start menu to where you want to put it (the effect actually just makes a copy of it). You can also add links to "Computer" & some other things using that method. All of that is less work than it sounds, & it has made my laptop so much better without "Libraries" in my life.
My System SpecsSystem Spec

 cannot add program to Open With menu

Thread Tools

Similar help and support threads
Thread Forum
Program Problem - Program won't open - No Error Messages
Ahhh back to the experts. I have a rather unusual, 'never happened before', problem. When I click on one particular shortcut either on the desktop or elsewhere it flashes real quick on the screen but does not open. The program is Webroot Window Washer which is no longer available nor is support....
many program I cant open Only Run as Administrator I open the program
many program I cant open Only Run as Administrator I open the program how to disable Run as Administrator I want to open a double click program
'Open with' every time I try to open a program
So I've spent a while browsing and can't find anything related to the problem I'm having. My girlfriend recently lent me her laptop (Win7 32bit) it was still using IE so when I go to install chrome the built in 'security program' (Win7 internet security 2011 or something like that) tells me that...
General Discussion
Menu links won't open in program
Hi, I recently installed Guitar Pro 6 software on my computer. Installation went fine but after opening up the program I noticed that none of the menu buttons, such as file, edit etc. will open up. I tried reinstalling the program to a new folder to see if that would fix it but no luck. I...
Open/Search Menu Tree menu Sometimes the open/save menu will show up like this, especially in older programs. I am wondering if there is a way of changing the recent places to My documents to save a few clicks. Thanks

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 08:31.
Twitter Facebook Google+