Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: New Ati 4850 problems in Win7

15 May 2009   #1
weaselciuy

Windows 7 Ultimate SP1 build 7601
 
 
New Ati 4850 problems in Win7

Hello to all,

I`m new to Win7 and this forum, ofcourse but tis good to see i have a place where to ask for help and maybe even fix something.
Before i upgraded to a Ati 4850 i had a nvidia 9600GT that worked fine...in Vista. When i got the 4850 i did a clean install of Windows 7 build 7100 RC .
I installed all the new drivers for mobo, audio, graphics etc...defraged, installed antivirus and my ussual programs and games. All ok ...
...ultill i played my first movie in VLC, its very pixelated. Other players work fine, just VLC is pixelated, i looked around its settings but nothing helped.

Another problem i discovered and its big, I cant use 75hertz on my monitor.
If i use 75 i get flickering red dots all over my screen, in my desktop or in games. Its very annoying since most games come with standard 75hz i have to manually adjust them in regedit to use 60. 60 works great. Before the 4850 upgrade i could use 75 with my nvidia card.

Another problem i cant explain is somewhat bad performance for my video card. Ofcourse ATI drivers for win7 now are bad but still i get same performance i got with my 9600GT. Around 9500 points in 3DMard06. Same score i was geting with the 9600GT. Still posibly my CPU is draging me down...but still thats to much draging down ...

Hopefully the new 9.5 Catalyst drivers will solve some issues but in case they dont , what will i do ...

Any advice or help, maybe you seen these problems before, i dunno ... plz tell me

ty


My System SpecsSystem Spec
.
15 May 2009   #2
junkieweb

windows 7 7100
 
 

Well, I am not sure to help ... but, try this forum post : AMD Game Forums - 4850 / Windows 7 /after installing 9.4 Lost 75hz Refresh

I think it is a driver problem at all ...
My System SpecsSystem Spec
15 May 2009   #3
Coldout

Windows 7
 
 

Well can't help on the refresh issue, but I can reccomend Smplayer inplace of VLC. I watch all my avi's divx etc on it - without issues. Comes with all the codecs I've ever needed.

SMPlayer - Downloads

Maybe give it a go unless you really need VLC, for streaming or somthing. (Though I could never get streaming to work with VLC or anything else for that matter)
My System SpecsSystem Spec
.

15 May 2009   #4
shanghei

Windows 7
 
 

I have the 4850 and have the exact problem with VLC. I also have over heating issues with the card in Windows 7 that I did not happen in Vista.
My System SpecsSystem Spec
15 May 2009   #5
jfar

Vista Ult64, Win7600
 
 

Quote   Quote: Originally Posted by shanghei View Post
I have the 4850 and have the exact problem with VLC. I also have over heating issues with the card in Windows 7 that I did not happen in Vista.
Hi shanghei. What program do you use, to cool your card.?
My System SpecsSystem Spec
15 May 2009   #6
shanghei

Windows 7
 
 

Quote   Quote: Originally Posted by jfar View Post
Hi shanghei. What program do you use, to cool your card.?
I use the Catalyst control center. I leave it automatic control which always worked in windows vista without problems.
My System SpecsSystem Spec
15 May 2009   #7
Coldout

Windows 7
 
 

9.5 are out, maybe they will fix your issues. Goodluck.

techPowerUp! :: Downloads
My System SpecsSystem Spec
15 May 2009   #8
weaselciuy

Windows 7 Ultimate SP1 build 7601
 
 

Quote   Quote: Originally Posted by junkieweb View Post
Well, I am not sure to help ... but, try this forum post : AMD Game Forums - 4850 / Windows 7 /after installing 9.4 Lost 75hz Refresh

I think it is a driver problem at all ...
Ty , i`ll surelly give it a read. About the VLC issue, i replaced it with WMP Classic Homecinema, heard it plays best 1080i formats.

Luckly i dont have a cooling problem cause of the his iceQ4, it really stays cool and GPU fan always at 2% cause of the heatpipes. Sux the drivers are infantile.
My System SpecsSystem Spec
15 May 2009   #9
weaselciuy

Windows 7 Ultimate SP1 build 7601
 
 

Yes i was downloading before i gor email notification from then i read. Tyvm anyway

i`ll report back.
My System SpecsSystem Spec
15 May 2009   #10
shanghei

Windows 7
 
 

Quote   Quote: Originally Posted by Coldout View Post
9.5 are out, maybe they will fix your issues. Goodluck.

techPowerUp! :: Downloads
9.5 didnt fix my problems
My System SpecsSystem Spec
Reply

 New Ati 4850 problems in Win7




Thread Tools




Similar help and support threads
Thread Forum
Ati 4850 upgrade ?
Hi 7 Forum members I want to upgrade my Ati 4850 to something better , but i am not sure of the power supply I know its 425 watts but i do not know what the amp ratting is . i need help in trying to get the amps reading off of it i am not sure how to read the specks on the side ! The...
Graphic Cards
Help with HD Radeon 4850
please someone help me, i'm getting nowhere with this.. i have my PC plugged into a new Samsung LED 6300.. and i see refresh lines on the TV... you know when you watch a tv show and in the background is a computer and you see the refresh lines going up and down it.. its very annoying. hardly...
Graphic Cards
Ati 4850 problems
Hi, I recently installed RTM Windows 7 Pro. Before i had 7000,7056 and 7100. On 7000 and at 7056 i've had similar problem i have now. When i try to refresh my Windows Experience Index my screen goes black with colour boxes and i have to restart computer. Screen goes black when windows try to...
Graphic Cards
ati 4850
Hi guys I'm getting a new pc in a week or 2 and I have a question about the graphics card drivers. I want to install windows 7 x86 version, but which ati drivers should i install with it? When I looked at the ati driver page, there were no drivers for windows 7 x86 version. Can anyone help me...
Drivers
ATI 4850 gpu
second question. Running win7 and phoshop cs4, how do I know gpu mode is used ? Photoshop seems not to detect gpu it asks to consult a site where no specific information is availaible Would love to see the effect, or is photoshop cs4 picking up gpu automaticaly ?
Graphic Cards
4850 wei
Hi Everyone, I Just installed Build 7057 x64 and usually my GPU makes it to 7.9 in the WEI and now it's gone to 5.9 and gaming graphics to 6.0. There's something really wrong here. I have 2 4850's Can anyone help me out here.
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:19.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App